Author Topic: Just Another Troubleshooting Thread  (Read 6101 times)

0 Members and 1 Guest are viewing this topic.

Offline Colonol Dekker

  • HLP is my mistress
  • 213
  • Aken Tigh Dekker
    • My old squad sub-domain
Re: Just Another Troubleshooting Thread
Dekker: Are you using a very recent nightly?
Clearly not:
Code: [Select]
fonts.tbl(line 5): Error: Required token = [#End] or [$Font:], found [$TrueType: OpenSans-Regular.ttf].
Whatever build that is, it predates TrueType font support.

fs2_open_3_7_5_SSE2-DEBUG_apng  actually.


redownloading asets now. 

 

Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Re: Just Another Troubleshooting Thread
fs2_open_3_7_5_SSE2-DEBUG_apng  actually.
So quite old, then, given how long APNG support has been in master. Grab a recent nightly build instead.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME
<MageKing17> THE REASON IS PEOPLE ARE STUPID
<MageKing17> ESPECIALLY ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
(...)
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.

 

Offline m!m

  • 210
Re: Just Another Troubleshooting Thread
m|m: try out the attached mission file. Turns out I completely disabled the sath shortcut, but its back now. Use cheats and press 4 to activate. Cheats and 1 key was the boss rush start combo, which I guess you found out.
Thank you! I found the cheats+1 kombo by looking at the mission files :p

EDIT: I found the root cause of the bug and fixed it so thanks again for giving me that alternative mission.
« Last Edit: March 04, 2017, 08:29:50 am by m!m »

 

Offline CT27

  • 210
Re: Just Another Troubleshooting Thread
I just downloaded JAD and am beginning to play it.

I'm having fun so far but there's a minor issue:  in the second mission (where there's a Hades and a Colossus rams a Sathanas) the Shivan Seraphim bombers launch Cyclops bombs.  Shouldn't it be a Shivan bomb?

 

Offline Darius

  • 211
Re: Just Another Troubleshooting Thread
What's the best build to use for this? I'm getting a whole bunch of LUA errors during VN sequences on the 3rd March nightly.

Code: [Select]
LUA ERROR: [string "vs2-sct.tbm - On Game Init"]:678: attempt to index local 'entry' (a nil value)

------------------------------------------------------------------
ADE Debug:
------------------------------------------------------------------
------------------------------------------------------------------


------------------------------------------------------------------

stack traceback:
[C]: ?
[string "vs2-sct.tbm - On Game Init"]:678: in function 'AssignActor'
[string "vs2-sct.tbm - On Game Init"]:729: in function 'Show'
[string "vs2-sct.tbm - On Game Init"]:513: in function 'Show2'
[string "vs2-sct.tbm - On Game Init"]:241: in function 'ProcessLine'
[string "vs2-sct.tbm - On Game Init"]:193: in function 'NextLine'
[string "vs2-sct.tbm - On Game Init"]:269: in function 'ProcessLine'
[string "vs2-sct.tbm - On Game Init"]:193: in function 'NextLine'
[string "vs2-sct.tbm - On Game Init"]:269: in function 'ProcessLine'
[string "vs2-sct.tbm - On Game Init"]:193: in function 'NextLine'
[string "vs2-sct.tbm - On Game Init"]:2094: in function 'CheckTimers'
[string "vs2-sct.tbm - On Frame"]:5: in main chunk
------------------------------------------------------------------

------------------------------------------------------------------

Most of them let me hit "Continue" and keep playing but I've now hit a sequence of unending LUA error boxes (in the sequence after we are introduced to the Empress).

 

Offline Axem

  • Administrator
  • 211
Re: Just Another Troubleshooting Thread
CT27: JAD1 is so old that when I made it, there were no shivan-specific secondaries, so they had all default Terran weapons (just like retail!)

Darius: Oh no, that's definitely new. Try something around Feb 22, they were working when I released. If that doesn't work, post a debug log and maybe I can hunt the issue down.

 

Offline Axem

  • Administrator
  • 211
Re: Just Another Troubleshooting Thread
Darius: I just tried the latest March 11 nightly and VN scenes seem fine... maybe try again? Let me know if you run into problems.

I uploaded a new update, just the root vps were touched for you guys doing manual installs. I did my best to fix the problems you've all posted and tried to make things a bit less frustrating for you crazy insane people playing insane.

 
Re: Just Another Troubleshooting Thread
This may be because I haven't had a chance to get the updated version, or it may be because it's impossible for Holley to not forget her homework, but no matter what I do, I can't get her to remember homework in the escape from high school mission, and I even restarted the campaign and played all the way up to it. But when I did that, it still had something about one of Holley's friends being sensitive about her first kiss, like some variables did not unset when I restarted the campaign.
There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline Axem

  • Administrator
  • 211
Re: Just Another Troubleshooting Thread
no matter what I do, I can't get her to remember homework

If you can figure out how to get her to remember, please let me, her father, and all her teachers know, but until then that's really more of a "feature" of Holley, than a "bug". ;)

I even restarted the campaign and played all the way up to it. But when I did that, it still had something about one of Holley's friends being sensitive about her first kiss, like some variables did not unset when I restarted the campaign.

That is sort of odd though. There's a number of hints and other events that get saved across the campaign when you happen across them so you won't need to redo them during replays. But they should clear on campaign restart... still, I'd take the free hints!

 
Re: Just Another Troubleshooting Thread
Ok. Thanks. Now I guess I just have to figure out how to beat the butler instead of getting my ass handed to me by him.
There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 
Re: Just Another Troubleshooting Thread
Are your variables players-persistant? Those have been recently (as in last night, I think!) been determined to not reset with the campaign.

 
Re: Just Another Troubleshooting Thread
Ok, it is entirely possible that I'm just an idiot.  But can someone please tell me how to scroll down on this menu so I can see the missing option to leave this conversation?

Is the fact that I still use an old 4:3 CRT monitor (bite me, it hasn't died on me yet, and I don't throw things away until I have reason to!) and 1152 x 864 resolution a possible contributing factor?
"Any idiot can face a crisis; it is this day to day living that wears you out." – Anton Chekhov

 

Offline Axem

  • Administrator
  • 211
Re: Just Another Troubleshooting Thread
Well, technically yes, the resolution is low enough that the script is trying to use a low res version of the message box. I did not realize that the low res version was too short to get all the lines needed for situations like this. That's my fault for not testing hard enough.

http://lazymodders.fsmods.net/files/vn_msgbox1.png

Can you try and save this in [JAD directory]/data/hud and see if it fixes your problem?

 
Re: Just Another Troubleshooting Thread
YES!  That totally fixed it.
[bows and scrapes]
I am blown away that such a simple fix was all it took. I never would have thought of that in a million years!  You are a marvel and ridiculously fast!
"Any idiot can face a crisis; it is this day to day living that wears you out." – Anton Chekhov

 

Offline Axem

  • Administrator
  • 211
Re: Just Another Troubleshooting Thread
Thanks. :) Hope you enjoy the rest of the mod!

 
Re: Just Another Troubleshooting Thread
I've got an odd, but unfortunately show stopping bug in JAD 2.21. In Forced Feeding I made it successfully through the first section, only to die in the second one after the hambeast reveals himself (I learned not to get in between him and spicy foods). It luckily seemed to have a checkpoint as when I restarted it it started to play the cutscene at the beginning of the second section, but then it also starts playing the cutscene at the beginning of the first section at the same time! Both sets of messages go concurrently with each other, the poor camera is flung about it all sorts of confusing ways, and when I finally regain control, both the large hambeast and the various cheeses are on the battlefield at once. Clearly it managed to load and play both sections at once without a fatal error. Every time I attempt to load the mission now, it does the same thing.

 

Offline Axem

  • Administrator
  • 211
Re: Just Another Troubleshooting Thread
Ah, shoot. Sorry for the trouble. I think I managed to fix it. (Looking at it, I wonder if that actually ever worked... :nervous:)

Let me know how the attached mission works for you. Throw it in [YourJADFolder]/data/missions (making the directories if they don't exist)

 

Offline PIe

  • 26
Re: Just Another Troubleshooting Thread
I'm using FSO 3.8.0 RC1.
After finishing the Beta Tester Counterattack mission of JAD 2.21, FSO threw an error.
Code: [Select]
LUA ERROR: [string "vs2-sct.tbm - On Game Init"]:879: attempt to index field 'Graphic' (a nil value)

------------------------------------------------------------------
ADE Debug:
------------------------------------------------------------------
------------------------------------------------------------------


------------------------------------------------------------------

stack traceback:
[C]: ?
[string "vs2-sct.tbm - On Game Init"]:879: in function 'Show'
[string "vs2-sct.tbm - On Game Init"]:608: in function 'Show2'
[string "vs2-sct.tbm - On Game Init"]:306: in function 'ProcessLine'
[string "vs2-sct.tbm - On Game Init"]:253: in function 'NextLine'
[string "vs2-sct.tbm - On Game Init"]:310: in function 'ProcessLine'
[string "vs2-sct.tbm - On Game Init"]:253: in function 'NextLine'
[string "vs2-sct.tbm - On Game Init"]:337: in function 'ProcessLine'
[string "vs2-sct.tbm - On Game Init"]:253: in function 'NextLine'
[string "vs2-sct.tbm - On Game Init"]:300: in function 'ProcessLine'
[string "vs2-sct.tbm - On Game Init"]:253: in function 'NextLine'
[string "vs2-sct.tbm - On Game Init"]:290: in function 'ProcessLine'
[string "vs2-sct.tbm - On Game Init"]:253: in function 'NextLine'
[string "vs2-sct.tbm - On Game Init"]:177: in function 'LoadScene'
[string "vs2-sct.tbm - On Game Init"]:90: in function 'L'
[string "String: VS2:L('m1d_vn')"]:1: in main chunk
------------------------------------------------------------------

------------------------------------------------------------------
Then when going back to the main hall, FSO crashed to desktop.
Replaying the mission didn't cause any problems.

 

Offline Axem

  • Administrator
  • 211
Re: Just Another Troubleshooting Thread
That's sort of a known code issue, I'm afraid. The game slowly runs out of bmpman slots as you go through missions (even though the game should be freeing them up), and eventually it runs out and gives you wacky headanis or an error like you got. A game restart should fix the problem. But let me know if it comes up consistently in the same spot every time.

(Getting to the bottom of that is a lot of unfun work :()

 
Re: Just Another Troubleshooting Thread
Ah, shoot. Sorry for the trouble. I think I managed to fix it. (Looking at it, I wonder if that actually ever worked... :nervous:)

Let me know how the attached mission works for you. Throw it in [YourJADFolder]/data/missions (making the directories if they don't exist)

Well it worked better. Not perfectly, unfortunately. I finished the second section, and then when I assume the mission normally ends (hambeast blew up, some dialogue afterwards), the mission warped back to the beginning of the first section (after the cutscene) very briefly and then went straight into a VN section with Holley and her dad, but no text ever came up, and I could still hear some targeting and battle sounds, as though the first section was still going on in the background.

EDIT: Upon replaying it, it started and played normally all the way through, so it may have just been some weird player variables that were still around the first time.
« Last Edit: May 10, 2017, 09:23:53 pm by Asteroth »