Author Topic: Help please!  (Read 1936 times)

0 Members and 1 Guest are viewing this topic.

Offline Admiral Nelson

  • Resurrecter of Campaigns
  • 211
  • The GTA expects that every man will do his duty.
What resolution are you running?  Talon's revised hud file contains some assumptions about specific resolutions.
If a man consults whether he is to fight, when he has the power in his own hands, it is certain that his opinion is against fighting.

 
1024x768 windowed.

The graphics driver on my laptop is a bit odd. My desktop is currently being shipped from overseas. I wonder if trying the mod on it might eliminate some of the problems...

For now I'm stuck with the laptop though.

 

Offline Admiral Nelson

  • Resurrecter of Campaigns
  • 211
  • The GTA expects that every man will do his duty.
I wonder if it is related to $Required Aspect?

Code: [Select]
#Gauge Config
$Ships: ( "F-86C Hellcat V" )
$Base: (1024, 768)
$Required Aspect: Full Screen
;$Min: (640, 480)
$Max: (1280, 960)

Perhaps the hud_gauges table doesn't like the window?  What is the native screen resolution of your laptop?
If a man consults whether he is to fight, when he has the power in his own hands, it is certain that his opinion is against fighting.

 
2880x1920

Edit: I tried changing the resolution and running in fullscreen. It works!

Thank you so much!
« Last Edit: May 29, 2017, 08:24:36 pm by crazycanuck »

 
The hardpoints gauge works now. Next I have to position all the weapon icons on it.

Is there a GUI/tool or something to help figure out where the gauges are on the screen (as opposed to guessing then typing in the coordinates)?

 

Offline AdmiralRalwood

  • 211
  • Mister Subspace Strikes
    • Skype
    • Steam
    • Twitter
Is there a GUI/tool or something to help figure out where the gauges are on the screen (as opposed to guessing then typing in the coordinates)?
No. But you can position them according to fractions of the screen size instead of absolute coordinates.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME
<MageKing17> THE REASON IS PEOPLE ARE STUPID
<MageKing17> ESPECIALLY ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
(...)
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.

 
Ok, I think I have editing the weapons gauge figured out!

My next problem is the thrusters on the Hornet. For some reason they have moved inside the ship. Everything looks good in pcs2. I have attatched a picture of the problem. Any Ideas where the problem could be?

Also, does anyone have any good resources in how to greate shield icon gauges? I know each part of the gauge needs to be saved as a different frame in an .ani file. I am wondering if there is a efficient way to create the shield quadrants on the display.

 

Offline Nyctaeus

  • Betrayal is his middle name
  • 211
  • HLP Tileraping Division
    • Exile
Check if your model has offset. I mean main model of LOD0. If yes, set it to 0:0:0 [for each axis respecrively]. you may need to adjust position of subsystems and other stuff alike.

Add "generate icon" to ship flags in ships.tbl entry. If you want classic Freespace style icon, you must do some magic in some graphic software. I'm not sure if shield icons can be saved as PNG, but you can make individual frames of the animation and bound them via .eff container file.
Exile | Shadow Genesis | DA Profile | P3D Profile

MY RELEASED CONTENT SO FAR
Old Conversions | GTSD Anchorage | ORFg Tychicus | GTCa Sagittarius | SCv Scylla | EFC Evangelist | EFFg Solomon | GTL Latona | SC Raguel | PVD Atum | GTCv Eurynome | FractalSpace - Apophysis Skydome Pack | Updated Ancients Models
All of my stuff can be used ONLY in Freespace campaigns and missions.

Veteran modder and graphic designer of all kinds. 3D is my speciality. Feel free to PM me if you looking for a model or other GFX help.

 
The offset was the problem. Thanks for the help!

 
I finally finished making all the shield icons.

Next problems:

The transparent parts on the Raptor are showing as all white in engine. The nose and the sensor under it are supposed to be transparent. I assume it is a texture problem but I don't know how to fix it. It worked fine in vanilla Saga.

The mouse control menu is missing in WCSO. It's not a blocker but it would be nice to fix.

Also, I get the error: "Failed EnumAdapterModes in UpdateAntialiasList" whenever I start the launcher.

Any ideas?

 

Offline AdmiralRalwood

  • 211
  • Mister Subspace Strikes
    • Skype
    • Steam
    • Twitter
Also, I get the error: "Failed EnumAdapterModes in UpdateAntialiasList" whenever I start the launcher.
Use a recent version of wxLauncher instead of Launcher 5.5g.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME
<MageKing17> THE REASON IS PEOPLE ARE STUPID
<MageKing17> ESPECIALLY ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
(...)
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.

 
How can I make a portion of the model transparent and shiny?

 
I solved my transparency problem by reverse engineering it from a model in the mediavps pack. The model now works perfectly!

Next problem is fixing the enemy ships jumping in in the sample missions. I'm pretty sure its a FRED problem.