Author Topic: Release: 3.6.14 Final  (Read 38577 times)

0 Members and 2 Guests are viewing this topic.

Offline Dragon

  • Citation needed
  • 212
  • The sky is the limit.
Right. Sorry, didn't catch that. In this case, it's indeed weird. Some rather big optimizations went in in 3.6.14, and it was faster for me (at least when I switched, it was quite some time ago).

 

Offline chief1983

  • Still lacks a custom title
  • Moderator
  • 212
  • ⬇️⬆️⬅️⬅️À➡️⬇️
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • Fate of the Galaxy
Anyway, I'd still like to see the video of the crazy pilot screen, could upload to youtube and link it here.

Would also be concerned that the drivers aren't up to date for that card.
Fate of the Galaxy - Now Hiring!  Apply within | Diaspora | SCP Home | Collada Importer for PCS2
Karajorma's 'How to report bugs' | Mantis
#freespace | #scp-swc | #diaspora | #SCP | #hard-light on EsperNet

"You may not sell or otherwise commercially exploit the source or things you created based on the source." -- Excerpt from FSO license, for reference

Nuclear1:  Jesus Christ zack you're a little too hamyurger for HLP right now...
iamzack:  i dont have hamynerge i just want ptatoc hips D:
redsniper:  Platonic hips?!
iamzack:  lays

 

Offline FSHero

  • 25
Wow, the sound code in 3.6.14 has been really tightened up! this is the first thing I noticed when playing mediavps_3612 with the new build today; things that happen behind you clearly sound so!

I'm sure we'll all find more cool stuff brought to us by this latest release. Thanks guys!

 

Offline Dando

  • 22
Greetings. Are you planning to release standard builds for 3.6.14? For there are serious problems with my game's hangings in the mission named Exodus in standard build version 3.6.12 and I hope new version will resolve them. I have checked this mission with Inferno build and it's working just fine, but to start the game from the beginning is a very difficult business. Thank you.

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
What do you mean by Standard builds?
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Greetings. Are you planning to release standard builds for 3.6.14? For there are serious problems with my game's hangings in the mission named Exodus in standard build version 3.6.12 and I hope new version will resolve them. I have checked this mission with Inferno build and it's working just fine, but to start the game from the beginning is a very difficult business. Thank you.

All builds are now Inferno builds and you should be using them, since there's no reason not to.

 

Offline karajorma

  • King Louie - Jungle VIP
  • Administrator
  • 214
    • Karajorma's Freespace FAQ
Ha! It's been so long I'd completely forgotten about non-inferno builds.
Karajorma's Freespace FAQ. It's almost like asking me yourself.

[ Diaspora ] - [ Seeds Of Rebellion ] - [ Mind Games ]

 

Offline chief1983

  • Still lacks a custom title
  • Moderator
  • 212
  • ⬇️⬆️⬅️⬅️À➡️⬇️
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • Fate of the Galaxy
I had not planned on making any 3.6.14 non-Inferno builds.  I'll see if we can figure something out though.

Edit:  Ok, here's a couple things you can try.  If you fired up an Inferno build, you should already have an Inferno pilots folder now in your players folder.  You can copy (not move, in case this doesn't work) your current pilot to that folder, and the Inferno build should be able to convert it in place and you should be able to continue your game with Inferno builds.

Just to clarify, the standard pilots folder is in Freespace2\data\players\single, and you want to copy the .cs2 and  .pl2 files to Freespace2\data\players\single\inferno.

Or, try the Antipodes builds, which have the new unified pilot code.  That should also work but could potentially be a bit more buggy than 3.6.14 or even the nightlies.
« Last Edit: November 13, 2012, 12:09:24 pm by chief1983 »
Fate of the Galaxy - Now Hiring!  Apply within | Diaspora | SCP Home | Collada Importer for PCS2
Karajorma's 'How to report bugs' | Mantis
#freespace | #scp-swc | #diaspora | #SCP | #hard-light on EsperNet

"You may not sell or otherwise commercially exploit the source or things you created based on the source." -- Excerpt from FSO license, for reference

Nuclear1:  Jesus Christ zack you're a little too hamyurger for HLP right now...
iamzack:  i dont have hamynerge i just want ptatoc hips D:
redsniper:  Platonic hips?!
iamzack:  lays

 

Offline Dando

  • 22
Thank you, but I guess there is no way as I've learned from topic about Antipodes, for my profile migrated from the retail version to 3.6.9 and then to 3.6.12.

 

Offline chief1983

  • Still lacks a custom title
  • Moderator
  • 212
  • ⬇️⬆️⬅️⬅️À➡️⬇️
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • Fate of the Galaxy
Hmm?  Which topic?  I was still under the impression that any Inferno build could convert any previous release's non-Inferno pilot files as the format hasn't changed much.  I don't think we changed the format between .12 and .14 at all but I could be wrong on that.
Fate of the Galaxy - Now Hiring!  Apply within | Diaspora | SCP Home | Collada Importer for PCS2
Karajorma's 'How to report bugs' | Mantis
#freespace | #scp-swc | #diaspora | #SCP | #hard-light on EsperNet

"You may not sell or otherwise commercially exploit the source or things you created based on the source." -- Excerpt from FSO license, for reference

Nuclear1:  Jesus Christ zack you're a little too hamyurger for HLP right now...
iamzack:  i dont have hamynerge i just want ptatoc hips D:
redsniper:  Platonic hips?!
iamzack:  lays

 

Offline Dando

  • 22
http://www.hard-light.net/forums/index.php?topic=73257.0 the quote in the first post. And my attempts of converting by the 3.6.14 INF result in crash to desktop with Windows crash report. Also I've tried Nightly (Windows): 13 Nov 2012 - Revision 9343 with the same result. But I don't understand something, maybe.

 

Offline chief1983

  • Still lacks a custom title
  • Moderator
  • 212
  • ⬇️⬆️⬅️⬅️À➡️⬇️
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • Fate of the Galaxy
Well, if you tried it, and it crashed there might be a problem somewhere after all.  Perhaps try converting to Inferno with a 3.6.12 Inferno build?
Fate of the Galaxy - Now Hiring!  Apply within | Diaspora | SCP Home | Collada Importer for PCS2
Karajorma's 'How to report bugs' | Mantis
#freespace | #scp-swc | #diaspora | #SCP | #hard-light on EsperNet

"You may not sell or otherwise commercially exploit the source or things you created based on the source." -- Excerpt from FSO license, for reference

Nuclear1:  Jesus Christ zack you're a little too hamyurger for HLP right now...
iamzack:  i dont have hamynerge i just want ptatoc hips D:
redsniper:  Platonic hips?!
iamzack:  lays

 

Offline Dando

  • 22
Sorry, I haven't written about it, but I've already tried to convert with 3.6.12 Inferno with the same frustrating crash.

 

Offline chief1983

  • Still lacks a custom title
  • Moderator
  • 212
  • ⬇️⬆️⬅️⬅️À➡️⬇️
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • Fate of the Galaxy
That does sound more like a bug than intended behavior.  If you could please upload your pilot/campaign file we might be able to take a look at it, there might be something about it we can fix somewhere.
Fate of the Galaxy - Now Hiring!  Apply within | Diaspora | SCP Home | Collada Importer for PCS2
Karajorma's 'How to report bugs' | Mantis
#freespace | #scp-swc | #diaspora | #SCP | #hard-light on EsperNet

"You may not sell or otherwise commercially exploit the source or things you created based on the source." -- Excerpt from FSO license, for reference

Nuclear1:  Jesus Christ zack you're a little too hamyurger for HLP right now...
iamzack:  i dont have hamynerge i just want ptatoc hips D:
redsniper:  Platonic hips?!
iamzack:  lays

 

Offline Dando

  • 22
Hope it will help you to improve the build.

[attachment deleted by a basterd]

 
Maybe its because of the mods I'm playing. Haven't touched the original campaign in .14
Could you link me to the shadow and sunshafts build?

 

Offline chief1983

  • Still lacks a custom title
  • Moderator
  • 212
  • ⬇️⬆️⬅️⬅️À➡️⬇️
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • Fate of the Galaxy
Dando, after someone looked at your pilot file, I was told over IRC that the pilot file itself is fine, but the campaign seems to have been too corrupted to convert properly.  Unfortunately that means moving it to an INF campaign or the antipodes code is not going to work, sorry.

Master_of_the_blade: What?
Fate of the Galaxy - Now Hiring!  Apply within | Diaspora | SCP Home | Collada Importer for PCS2
Karajorma's 'How to report bugs' | Mantis
#freespace | #scp-swc | #diaspora | #SCP | #hard-light on EsperNet

"You may not sell or otherwise commercially exploit the source or things you created based on the source." -- Excerpt from FSO license, for reference

Nuclear1:  Jesus Christ zack you're a little too hamyurger for HLP right now...
iamzack:  i dont have hamynerge i just want ptatoc hips D:
redsniper:  Platonic hips?!
iamzack:  lays

 

Offline Dando

  • 22
Thank you, Chief. I was guessing this from the beginning. Do you have any idea about how they have become corrupted? Maybe because of multiple changing of my game's versions?

 

Offline chief1983

  • Still lacks a custom title
  • Moderator
  • 212
  • ⬇️⬆️⬅️⬅️À➡️⬇️
    • Minecraft
    • Skype
    • Steam
    • Twitter
    • Fate of the Galaxy
The old campaign code has had a bad habit of corrupting itself in various ways, some of which might not prevent you from finishing the game, but some that might and you won't know until the damage is done.  Mod changing, version changing could possibly do it I suppose, but it's not the only way.
Fate of the Galaxy - Now Hiring!  Apply within | Diaspora | SCP Home | Collada Importer for PCS2
Karajorma's 'How to report bugs' | Mantis
#freespace | #scp-swc | #diaspora | #SCP | #hard-light on EsperNet

"You may not sell or otherwise commercially exploit the source or things you created based on the source." -- Excerpt from FSO license, for reference

Nuclear1:  Jesus Christ zack you're a little too hamyurger for HLP right now...
iamzack:  i dont have hamynerge i just want ptatoc hips D:
redsniper:  Platonic hips?!
iamzack:  lays

 
Hello guys!

I seem to have several problems with the 3.6.14 built. I installed everything (even the hole media VPs) via the FSOpen Installer. In the launcher I activated everything in the grafik-tab, like nomal maps and post-processing. I had no crashes or severe problems like error messages. But two things seem to be wrong:

1.
I don´t have normal maps. Do I have to do something to activate the shaders? Are the shaders only included in elder builts before 3.6.12?

2.
The AA doesn´t work properly. I activated the features in the video-tab (to the limit of course), but nothing happens (it looks really ugly   :eek2:).

Then I activated FXAA and post processing with no effect at all. Only when I "force" my card to activate FXAA via driver it looks quite better. But not as it should look... :confused:


Then I tried an elder built (3.6.12), same problems with that one.

I have a quadcore CPU and an NVidea 670 grafikcard with the newest drivers.

What am I doing wrong? Is it a known problem with the 670 drivers or something?