Author Topic: WXLauncher Crashing Upon Hitting "Play"  (Read 102 times)

0 Members and 1 Guest are viewing this topic.

WXLauncher Crashing Upon Hitting "Play"
Hello!

Whenever I attempt to play the game from WXLauncher, the launcher crashes before launching the game. I am able to run the game just fine with the game's executable. I have tried launching with and without mods, still the same result. The launcher crashes with the following attached wxWidgets Debug Alert:

Any suggestions?


 

Offline Firesteel

  • 27
  • Guy who thinks way too hard about things
    • Steam
    • Twitter
    • YouTube Channel
Re: WXLauncher Crashing Upon Hitting "Play"
wxLauncher 0.10 and FSOpen 3.8.0 don't play nice because of the SDL changes. You'll need to use wxLauncher 0.12 beta or stick to a 3.7 release of FSO. If that isn't the source of your problem I'm not sure what else it would be. That's the only problem I've ever encountered with wxLauncher.

Linky to wxLauncher 0.12
https://github.com/scp-fs2open/wxLauncher/releases/tag/0.12.0-rc.2
Current Projects:

- Ongoing analysis of games through video segments
- A short campaign inspired by a certain command briefing animation

 
Re: WXLauncher Crashing Upon Hitting "Play"
wxLauncher 0.10 and FSOpen 3.8.0 don't play nice because of the SDL changes. You'll need to use wxLauncher 0.12 beta or stick to a 3.7 release of FSO. If that isn't the source of your problem I'm not sure what else it would be. That's the only problem I've ever encountered with wxLauncher.

Linky to wxLauncher 0.12
https://github.com/scp-fs2open/wxLauncher/releases/tag/0.12.0-rc.2

This sorted this out! Thank you very much!