Author Topic: [SOLVED?]Linux Install Issue making fs2_open  (Read 499 times)

0 Members and 1 Guest are viewing this topic.

[SOLVED?]Linux Install Issue making fs2_open
Hello,

I'm having issues on step 2 of the README.txt when trying to build fs2_open. I run the autogen.sh and then when I run make I get.

cfile/cfilearchive.cpp: In function ‘int cfread_lua_number(double*, CFILE*)’:
cfile/cfilearchive.cpp:252:34: error: ‘LUA_NUMBER_SCAN’ was not declared in this scope
  int items_read = fscanf(cb->fp, LUA_NUMBER_SCAN, buf);


I am on Arch Linux and am currently up to date

My System is
CPU:  i7-5960X
ram: 16G DDR4(don't remember the type off hand)
GPU: nvidia gtx Titan

not sure what else you might need, any help would be appreciated.
« Last Edit: October 30, 2015, 05:42:02 pm by Ezzestus »

 

Offline niffiwan

  • 211
  • Eluder Class
Re: Linux Install Issue making fs2_open
What version of LUA does Arch currently provide? Freespace Open currently needs 5.1, not 5.2 or later.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Linux OBS Packages: FSO 3.7.0 | FSO BP Build | wxLauncher (?) | PCS2 (?) | wxVPView (?)
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: Linux Install Issue making fs2_open
ah its 5.3.1. that is probably the issue then.