Author Topic: Just Another Troubleshooting Thread  (Read 5750 times)

0 Members and 1 Guest are viewing this topic.

Offline Axem

  • Administrator
  • 211
Just Another Troubleshooting Thread
Got problems? Found a bug? Post here and I, or maybe some else, will do our best to help you! :)

Looking for the experimental debug and FRED builds for JAD2.22?
Click here to grab them all!
« Last Edit: April 01, 2016, 05:32:55 pm by Axem »

 
Re: Just Another Troubleshooting Thread
Which Linux build is preferred?
Code: [Select]
./fs2_open_3.7.5_20160401_f4645e3 -mod JAD2-2
Unrecognized command line parameter "-disable_shadows".  Ignoring...
ERROR: "Invalid Species Heroes defined in table entry for ship GTB Rhea Mk2#Proto." at ship/ship.cpp:2202
AL lib: ReleaseALC: 1 device not closed
Ubuntu MATE 14.04 64 bit

Log attached

Quote
Code: [Select]
"WARNING: "Unable to find WEAPON_LIST_TYPE string "Spamming Red Turret" in stuff_int_list  Many possible sources for this error.  Get a programmer!" at parselo.cpp:2841
:D Nice error message

Any idea?

[attachment DELETED!! by Strong Bad]

 

Offline Axem

  • Administrator
  • 211
Re: Just Another Troubleshooting Thread
I did reply to that in the other thread, but I'll repost!

Quote
If Windows isn't your thing, you can build your own build with from source using this branch from niffiwan's github repo: https://github.com/niffiwan/fs2open.github.com/tree/apng_jad

Also you appear to be missing jad221_root.vp... This was updated recently, so maybe try running the installer again and hopefully it'll catch that its missing. If its still missing, you can manually download the files here.

Let me know if you're still having problems.

 
Re: Just Another Troubleshooting Thread
Code: [Select]
checking for SDL - version >= 1.2.6... no
*** Could not run SDL test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means SDL was incorrectly installed
*** or that you have moved SDL since it was installed. In the latter case, you
*** may want to edit the sdl-config script: /usr/bin/sdl-config
configure: error: *** SDL >= 1.2.6 not found!

[attachment DELETED!! by Strong Bad]

 
Re: Just Another Troubleshooting Thread
Install libsdl1.2-dev

 

Offline m!m

  • 210
Re: Just Another Troubleshooting Thread
Also, if this is your first time compiling FSO then you should follow this guide. That contains a list of all packages that are required for compiling the engine.

 
Re: Just Another Troubleshooting Thread
Now compiling works, thanks. Didn't remind my own Wiki article (some parts of it) for compiling from source.

https://wiki.ubuntuusers.de/Spiele/Freespace_2/Installation/#Vorbereitung

https://wiki.ubuntuusers.de/Spiele/Freespace_2/Installation/#Quellcode

In combination compiling was possible (32bit libraries and the libraries from the HL wiki). 32bit users should also install both respective lists of dependencies.

 
Re: Just Another Troubleshooting Thread
Using 3.7.4 build.
No animation appeared. Where it would appear, i was showered with a ton of error message then there's just the dialogue box and the background.
And all model was invisible except for it's engine flames

the attached 3.7.5 apng build shows the animations correctly, but it ignores the screen resolution setting in the launcher and switch to low resolution (1024x768, i think), and models are still invisible.

Switched to 3.7.2 Final build and i could play the fighting level normally. But it still showers me with error everytime dialogues with animations comes up.

Screenshots taken from the apng build

[attachment DELETED!! by Strong Bad]
« Last Edit: April 05, 2016, 03:27:48 am by jedi19941 »

 

Offline niffiwan

  • 211
  • Eluder Class
Re: Just Another Troubleshooting Thread
You'll need to use the apng builds, otherwise (as you've seen) you'll get errors messages all throughout the VN missions.

Can you please grab the apng debug builds from here:

Click here to grab them all!

And then please post your fs2_open.log file.  Instructions on how to do this can be found in this post.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Linux OBS Packages: FSO 3.7.0 | FSO BP Build | wxLauncher (?) | PCS2 (?) | wxVPView (?)
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline Axem

  • Administrator
  • 211
Re: Just Another Troubleshooting Thread
Aw, sorry to hear you're having trouble. :( I hope we can find the problem with those debug builds niffiwan linked to so you can enjoy the mod!

 
Re: Just Another Troubleshooting Thread
This showed up when the game was in loading screen half way.
Could not find a usable bitmap (railgun_p) for weapon 'OnlyMyRailgun#LightNovel'!

ntdll.dll! KiFastSystemCallRet
kernel32.dll! WaitForSingleObjectEx + 67 bytes
kernel32.dll! WaitForSingleObject + 18 bytes
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
fs2_open_3_7_5_SSE2-DEBUG_apng.exe! <no symbol>
kernel32.dll! BaseThreadInitThunk + 18 bytes
ntdll.dll! RtlInitializeExceptionChain + 99 bytes
ntdll.dll! RtlInitializeExceptionChain + 54 bytes

Clicked on YES and the game will crash, hit NO 2 times and it loads normally.
Here's the log.

[attachment DELETED!! by Strong Bad]

 

Offline Axem

  • Administrator
  • 211
Re: Just Another Troubleshooting Thread
Well shoot, that's just me forgetting to include a graphics file. But it shouldn't be the cause of completely missing models... (Coders, any insights?)

 

Offline Spoon

  • 212
  • ♪ ♬ ヾ(´︶`♡)ノ ♬ 淫画
Re: Just Another Troubleshooting Thread
Could not find a usable bitmap (railgun_p) for weapon 'OnlyMyRailgun#LightNovel'!

Brilliant weapon name :lol:
Urutorahappī!!

[02:42] <@Axem> spoon somethings wrong
[02:42] <@Axem> critically wrong
[02:42] <@Axem> im happy with these missions now
[02:44] <@Axem> well
[02:44] <@Axem> with 2 of them

 

Offline niffiwan

  • 211
  • Eluder Class
Re: Just Another Troubleshooting Thread
Could not find a usable bitmap (railgun_p) for weapon 'OnlyMyRailgun#LightNovel'!

You can ignore this warning, it shouldn't cause the issue you're seeing.

I can't see any obvious errors in the logs, and I'm going to assume that all the VPs have been installed corrected (did you use the installer?)

I noticed that your video card isn't exactly a speed demon; one website I read says that its about the same as an Intel HD 4000.  Could you try;

1) updating your video card drivers
2) select "Disable GLSL (Shader) Support in the launcher; on the Advanced Setting tab, under the heading Troubleshooting

I acknowledge that since the models seem to work OK on 3.7.2, this is not likely to be directly caused by your PC; but I'm fairly sure there's been some shader updates since 3.7.2 which might have introduced these issues for you. Disabling GLSL should eliminate the effects of the changes to the shaders.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Linux OBS Packages: FSO 3.7.0 | FSO BP Build | wxLauncher (?) | PCS2 (?) | wxVPView (?)
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Online AdmiralRalwood

  • 211
  • Mister Subspace Strikes
    • Skype
    • Steam
    • Twitter
Re: Just Another Troubleshooting Thread
Given that 3.7.2 was pre-deferred renderer, that's almost certainly why the models worked.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME
<MageKing17> THE REASON IS PEOPLE ARE STUPID
<MageKing17> ESPECIALLY ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
(...)
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.

 
Re: Just Another Troubleshooting Thread


1) updating your video card drivers
2) select "Disable GLSL (Shader) Support in the launcher; on the Advanced Setting tab, under the heading Troubleshooting.

The second option did fixed it. though now models isn't as pretty.
Is there anyway to get around the fixed 1024x768 resolution?
 

 

Online AdmiralRalwood

  • 211
  • Mister Subspace Strikes
    • Skype
    • Steam
    • Twitter
Re: Just Another Troubleshooting Thread
Let me get this straight... if you try 3.7.4 you get the proper resolution, but the 3.7.5 APNG build is 1024x768?
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME
<MageKing17> THE REASON IS PEOPLE ARE STUPID
<MageKing17> ESPECIALLY ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
(...)
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.

 
Re: Just Another Troubleshooting Thread
That's right. The 3.7.5 APNG just ignore my setting.

 

Offline niffiwan

  • 211
  • Eluder Class
Re: Just Another Troubleshooting Thread
You can workaround the resolution issue by setting is manually in the launcher. On the advanced settings tab, in the "Custom Flags" box add this, replacing 1600x900 with your monitors resolution.

Code: [Select]
-res 1600x900

As for losing the "prettiness" with "Disable GLSL (Shader) Support", you could also try these two options instead of that, both separately and together.

Advanced Settings Tab, Troubleshoot section:
  Disable batched model rendering
  Disable geometry shader for effects

Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Linux OBS Packages: FSO 3.7.0 | FSO BP Build | wxLauncher (?) | PCS2 (?) | wxVPView (?)
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline m!m

  • 210
Re: Just Another Troubleshooting Thread
Let me get this straight... if you try 3.7.4 you get the proper resolution, but the 3.7.5 APNG build is 1024x768?
What commit is the APNG build based on? If it includes 09ce1f1846f02c6e2c4061b5dbb5a1384700759f then it may cause these issues if, for some reason, Windows decided again that it didn't like the registry path.