Author Topic: FS2_Open Linux Mini Howto - Revised  (Read 11626 times)

0 Members and 1 Guest are viewing this topic.

Offline Amon_Re

  • 28
  • Posts: 297
    • http://www.kefren.be
FS2_Open Linux Mini Howto - Revised
All right gentlemen, you want to install fs2open on linux now do we? All righty then let's get to it.
Lets start by making a temporary work directory for the source code, so open up a console, and make one.

Now we need to download the sourcecode, you could download it with your favourite browser, or you could just copy & paste the following command, from within the newly created directory:

    wget http://icculus.org/~taylor/fso/releases/fs2_open-3.6.7.tar.bz2

This will download the sourcecode with the wget command. Don't have wget? don't worry, just download it with a browser, or another tool (you might want to install wget tho ;))
Now we have to extract the code from the archive, so issue the following command:

    tar -xvf fs2_open-3.6.7.tar.bz2

This will create a new directory called 'fs2_open-3.6.7', so cd to this directory.

Now we have to configure the build for our own system, so we execute the command:

   ./configure

And let it do it's work. After this we only have to issue 'make' to compile the program itself, so do

   make

and sit back, grab a cup of coffee and relax. If all is well it should finish compiling without a gitch, if you get errors relating to openal, then it means your openal install is eighter too old, or not present, so install OpenAL and run make again.

The last thing to do when it's compiled is to copy the program into the freespace2 game directory, the program is in the code directory and is called fs2_open_r

Happy gaming!


PS: I'll try & keep this thing up to date, please post compile issue's etc here, so that they can be added to the howto if needed.
Sig? What sig?

 

Offline northtwilight

  • 25
  • Posts: 51
Re: FS2_Open Linux Mini Howto - Revised
Hi Amon Re

I'm a Linux user currently attempting to get FS2 Open to work on Debian Unstable. I've been having a bit of back and forth with Taylor as yet (still unresolved, but I'm sure it'll happen eventually). He's been a terrific resource and massively patient help, but I'd like to stop bugging him for help. This too may or may not happen soon but one day...

Anyway, I suggested to Taylor that I'd make a HOWTO on installing/compiling/playing FS2O -- this was early last week -- and then I stumbled across your mini HOWTO in this thread.

Would you be open to expanding it, and to me working with you in doing so? We could distribute it to other FS2 community sites, perhaps even get it tied into karajorma's FAQ if it's complete. What do you think?

My e-mail address is n___.t______[ a t ] g mail DOOT com , or just PM me here  if you prefer.

Looking forward to hearing from you
Mass

 

Offline Amon_Re

  • 28
  • Posts: 297
    • http://www.kefren.be
Re: FS2_Open Linux Mini Howto - Revised
PM sent
Sig? What sig?

 

Offline naht

  • 20
  • Posts: 1
Re: FS2_Open Linux Mini Howto - Revised
Hm, maybe you should add that ./configure does not fail if you're missing  libopenal-dev or libvorbis-dev, but compiling will fail. So install these two, and it should work. (I did work for me after that, at least) :p

 

Offline marvel_01

  • 21
  • Posts: 3
Re: FS2_Open Linux Mini Howto - Revised
The last thing to do when it's compiled is to copy the program into the freespace2 game directory, the program is in the code directory and is called fs2_open_r

Happy gaming!

Hello. I do appreciate this how-to, but I have a question concerning the last step qouted above.  How do I install the game from the CD so that I would be able to complete this last step?   My Freespace 2 is the one obtained from www.freespacezone.com.  Thanks a lot.

By the way, is this what I need http://www.icculus.org/freespace2/ ?   I've tried that but it seemed to asked for some file which is non-existant in my CD!!   So I'm wondering wether this installer is still valid, or an alternate procedure is required for freespace2 to function under linux.  The distro is Slackware 10.2
« Last Edit: January 24, 2006, 07:53:05 am by marvel_01 »

 

Offline northtwilight

  • 25
  • Posts: 51
Re: FS2_Open Linux Mini Howto - Revised
Basically at this point you will need to get the full directory of installed files from the CDs.

Unfortunately the only practical and quick way to do this is to install the game on Windows, and then either mount or symlink to the directories on the Windows partition. You can then copy over the directories into one of your choosing, or you can leave the symlinks in place.

Once the binary is built from the FS2 open code, copy or move it into the folder containing the game files (containing the symlinks if you've done it this way), and then just run the binary from the command line.

Good luck!

 

Offline HangFire

  • 20
  • Posts: 1
Re: FS2_Open Linux Mini Howto - Revised
That's not entirely true - I can't remember which, but I used the Windows installer through either (up-to-date) wine or cvscedega; so it is possible.

About the icclus.org installer - there's a problem to do with (I think!) European/American versions of the game. Basically, what it comes down to is that there are a number of files ending *_f (or similar - an example is  tango1_fs2.vp) on each of the cds. Copy the cd contents into a directory, change the file names to *_fs2.vp, and then the Windows installer will work. I believe that the icclus.org installer has the same problem, but I haven't tried.

So - on to the mv_*.vp files - what cli options are people here using to get them to work? I have:
- Fetched the files (
- Unzipped them into my ./freespace2 directory
- Ran: ./fs2_open_r -spec -glow -jpgtga -targetinfo -nomotiondebris -2d_poof -snd_preload

... But it doesn't look any better! Hints? (I'm running 3.6.7, linked above)

-> Does anyone have movies working correctly? I'm getting sound distortion. During the game, it's minimal but during the movies it overrides everything.

 

Offline Alneyan

  • 22
  • Posts: 5
Re: FS2_Open Linux Mini Howto - Revised
The how-to worked flawlessly for me, after installing those libraries Naht mentioned. Thanks! I'm not playing with any sound on though, so I cannot comment on that.

I can confirm that Wine works fine with the FS2 installer, and can allow to get those files the icclus installer misses. It's not particularly convenient, but it can be done without having access to Windows. It might also be possible to open the .cab files directly from the CD, depending on how exactly they were made, but the problem I tried doesn't work with them (Orange, from the Debian archives).

 

Offline WMCoolmon

  • Purveyor of space crack
  • 213
  • Posts: 8,707
Re: FS2_Open Linux Mini Howto - Revised
IIRC the program "unshield" can open the .cab files, but you need to have them all in the same directory or something.
-C

 

Offline Fieari

  • 24
  • Posts: 20
Re: FS2_Open Linux Mini Howto - Revised
Is there any way to have the ./configure file check for those libraries?

Also, when I run ./fs2_open_r, I get:
Code: [Select]
Unrecognized command line parameter "-mipmap".  Exiting...I installed FS2 using the recent torrent with mediavps and a bunch of mods etc already put into the propper directories.  Could that have anything to do with it?

There wouldn't be an equivelent to "Launcher" for linux, would there?  I'm migrating from windows to linux now, and still feeling my way around things... once I get this working, I hope to be able to tinker around with the source code.
« Last Edit: February 21, 2006, 12:54:15 pm by Fieari »

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
  • Posts: 5,098
    • http://www.icculus.org/~taylor
Re: FS2_Open Linux Mini Howto - Revised
Get ./configure to check for which libraries?  It does check for most things now (except properly detecting OpenAL perhaps) but OpenGL and OpenAL libraries will soon not be linked in and be loaded at runtime instead.  After that ./configure won't need to detect them.

Which version of the FS2_Open binary are you trying to run?  The -mipmap option was renamed from -d3dmipmap so if it's an older build (3.6.7 qualifies as old at this point) then the -mipmap option doesn't have the same name.

And there is no Launcher for Linux, at least not yet.  A new Launcher is in the works which will be a completely new one for Windows that also support Linux and OS X.  I'm not sure when that will get completed though since it's not a port of the Windows Launcher but a completely new application.

 

Offline Fieari

  • 24
  • Posts: 20
Re: FS2_Open Linux Mini Howto - Revised
I'm using 3.6.7, and the error comes up even when I don't use any arguments at all.  I tried expressly using -mipmap, and now I just tried expressly using -d3dmipmap... same error again.

EDIT: Compiling the most recent CVS instead seems to fix this problem.  Cool.
« Last Edit: February 21, 2006, 02:34:03 pm by Fieari »

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
  • Posts: 5,098
    • http://www.icculus.org/~taylor
Re: FS2_Open Linux Mini Howto - Revised
I'm using 3.6.7, and the error comes up even when I don't use any arguments at all.  I tried expressly using -mipmap, and now I just tried expressly using -d3dmipmap... same error again.
You've probably just got it in one of the cfg files.  Check in ~/.fs2_open/data/cmdline_fso.cfg, ~/.fs2_open/data/cmdline.cfg, and <gamedir>/data/cmdline_fso.cfg and see if those files include any cmdline options in them.  That's probably why the newer build works, it supports the new options.  It's a good idea to know exactly what options are listed in those files though since you may find that certain options are enabled/disabled without you realizing it.

("~/.fs2_open/data/cmdline.cfg" is depreciated but the game will still read it, if the file exists then please remove/rename it)

 

Offline Fieari

  • 24
  • Posts: 20
Re: FS2_Open Linux Mini Howto - Revised
Huh.  Yep, that's what was causing that... heck, it was causing a bunch of other problems too!  Thanks!  Apologies for cluttering the forum with my problem here... err... I'll probably have to request another thread I started to be deleted.

 

Offline northtwilight

  • 25
  • Posts: 51
Re: FS2_Open Linux Mini Howto - Revised
This page from the FS2 Wiki lists all the relevant command line options:

http://www.hard-light.net/wiki/index.php/Command-Line_Reference

Good luck.

 

Offline CaptJosh

  • 210
  • Posts: 1,218
Re: FS2_Open Linux Mini Howto - Revised
How do you tell it what screen resolution to use? I loathe 640x480.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
  • Posts: 5,098
    • http://www.icculus.org/~taylor
Re: FS2_Open Linux Mini Howto - Revised
How do you tell it what screen resolution to use? I loathe 640x480.
Edit ~/.fs2_open/fs2_open.ini and change the "VideocardFs2open" setting.

 

Offline bigdady92

  • 23
  • Posts: 11
Re: FS2_Open Linux Mini Howto - Revised
I am getting the following error when I compile the code on CentOS 4.2:
sound/ds.cpp: In function `int ds_init(int, int, unsigned int, short unsigned int)':
sound/ds.cpp:1663: error: invalid conversion from `void*' to `ALCcontext*'
sound/ds.cpp:1663: error:   initializing argument 1 of `ALCboolean alcMakeContextCurrent(ALCcontext*)'
sound/ds.cpp:1702: error: invalid conversion from `ALubyte*' to `const ALchar*'
sound/ds.cpp:1702: error:   initializing argument 1 of `ALboolean alIsExtensionPresent(const ALchar*)'
sound/ds.cpp: In function `void ds_close()':
sound/ds.cpp:2178: error: invalid conversion from `void*' to `ALCcontext*'
sound/ds.cpp:2178: error:   initializing argument 1 of `void alcDestroyContext(ALCcontext*)'
make[1]: *** [ds.o] Error 1
make[1]: Leaving directory `/home/me/freesp2/fs2_open-3.6.7/code'
make: *** [all-recursive] Error 1



This leaves me to believe that I didn't install all the AL libraries. I have installed all the ones found here just to be sure:

http://www.openal.org/downloads.html

Both the source and binary rpm's for ALUT and OpenAL.

Am I missing some other libraries here?

 

Offline aptget

  • 20
  • Posts: 1
Re: FS2_Open Linux Mini Howto - Revised
Hello,

I am getting the following error when I compile the code on CentOS 4.2:
[...]

I had precisely the same problem compiling this tgz on Debian testing. I simply retrieved the version from CVS:
http://www.hard-light.net/wiki/index.php/Fs2_open_on_Linux#CVS_Checkout

No more problem.

Julien

EDIT: sorry i didn't notice that another topic has been opened mainwhile:
http://www.hard-light.net/forums/index.php/topic,39533.0.html

 

Online Herra Tohtori

  • The Academic
  • 211
  • Posts: 3,529
  • Bad command or file name
Re: FS2_Open Linux Mini Howto - Revised
Hello... Even though this is bit of a thread necromancy, I figured it'd be better to post here than make a specific thread to just my problems.

So, I've managed to get 64-bit Ubuntu 6.06 working quite well and decided to install FS Open on it. That went well. I have a few notes and questions, though.

Firstly, the official FSO 3.6.7 build didn't compile on my computer. It did go through the configuration, but on make-command it always went through the code at some point and then stopped, I have no clear picture of why but the last lines nagged something about mveplayer and some missing file/directory, and then halted the compilation process. If someone wants sdditional information, I can reproduce the phenomenon and send the last lines of compilation here, should it have any importance - which I doubt, since I did found another build that compiled without difficulties and works quite well.

This build that I'm now using is Taylor's 20060502 build which supposedly has env mapping for OGL... the thing with this is, however, that I can't see it being there. Also, some of the textures don't look like 32-bit - for example, the GVD Hatshepsut textures have streaked colouration instead of glide colours, if you understand what I mean... I can provide a screenshot to make it clear if needed. One other thing I'm not sure is affecting anything is the -ambient_factor N flag. I have it on zero, and everything looks too bright to me.

$ ./fs2_open_r -help gives me the following:

Code: [Select]
FS2 Open: The Source Code Project, version 3.6.8
Website: http://scp.indiegames.us
Mantis (bug reporting): http://lore.maxgaming.net/~scp/mantis/

Usage: fs2_open [options]
    [ -spec ]                   - Enable specular
    [ -glow ]                   - Enable glowmaps
    [ -jpgtga ]                 - Enable jpg,tga textures
    [ -mipmap ]                 - Enable mipmapping
    [ -nomotiondebris ]         - Disable motion debris
    [ -2d_poof ]                - Stops fog intersect hull
    [ -noscalevid ]             - Disable scale-to-window for movies
    [ -cache_bitmaps ]          - Cache bitmaps between missions
    [ -missile_lighting ]       - Apply Lighting to Missiles
    [ -img2dds ]                - Compress non-compressed images
    [ -no_vsync ]               - Disable vertical sync
    [ -dualscanlines ]          - Another pair of scanning lines
    [ -targetinfo ]             - Enable info next to target
    [ -orbradar ]               - Enables 3d radar
    [ -rearm_timer ]            - Enable Rearm/Repair Completion Timer
    [ -ballistic_gauge ]        - Enable the analog ballistic ammo gauge
    [ -nobeampierce ]           - Disable beams piercing shields
    [ -ship_choice_3d ]         - Use models for ship selection
    [ -3dwarp ]                 - Enable 3d warp
    [ -warp_flash ]             - Enable flash upon warp
    [ -tbp ]                    - Toggle features for The Babylon Project
    [ -wcsaga ]                 - Toggle features for Wing Commander Saga
    [ -snd_preload ]            - Preload mission game sounds
    [ -nosound ]                - Disable sound and music
    [ -nomusic ]                - Disable music
    [ -standalone ]             -
    [ -startgame ]              -
    [ -closed ]                 -
    [ -restricted ]             -
    [ -multilog ]               -
    [ -clientdamage ]           -
    [ -mpnoreturn ]             - Disables flight deck option
    [ -oldfire ]                -
    [ -nohtl ]                  - Software mode (very slow)
    [ -no_set_gamma ]           - Disable setting of gamma
    [ -nomovies ]               - Disable video playback
    [ -noparseerrors ]          - Disable parsing errors
    [ -safeloading ]            -
    [ -query_speech ]           - Does this build have speech?
    [ -d3d_bad_tsys ]           - Enable inefficient textures
    [ -novbo ]                  - Disable OpenGL VBO
    [ -noibx ]                  - Don't use cached index buffers (IBX)
    [ -loadallweps ]            - Load all weapons, even those not used
    [ -env ]                    - environment mapping
    [ -alpha_env ]              - uses alpha for env maping
    [ -decals ]                 - impact decals
    [ -ingame_join ]            - Allows ingame joining
    [ -voicer ]                 - Voice recognition
    [ -fps ]                    - Show frames per second on HUD
    [ -pos ]                    - Show position of camera
    [ -window ]                 - Run in window
    [ -timerbar ]               -
    [ -stats ]                  - Show statistics
    [ -coords ]                 - Show coordinates
    [ -show_mem_usage ]         - Show memory usage
    [ -pofspew ]                -
    [ -tablecrcs ]              -
    [ -missioncrcs ]            -
    [ -dis_collisions ]         - Disable collisions
    [ -dis_weapons ]            - Disable weapon rendering
    [ -output_sexps ]           - Outputs SEXPs to sexps.html
    [ -output_scripting ]       - Outputs scripting to scripting.html
    [ -nograb ]                 - Don't grab mouse/keyboard in a window

I cannot see -ambient_factor there. Does it exist in Linux version? At least it isn't complaining about unrecognized command parametres when I have that on my command line... So I'd have to guess it is there but it just doesn't feel like it's working.

Is there a limit to command line length?

And do I have to do something specific about envmapping to get it working? I remember something about a file that is needed if the computer cannot generate it by itself. What was that about?

One more thing: I posted it on Derelict SCP thread, but perhaps it's good to mention it here also: When I'm playing (or trying to, anyway) Derelict SCP campaign, the voice in briefings, de-briefings and such becames intolerably garbled by loud, sporadic white noise. Moreover, it seems to actually cause more than just FUBARed voice: If I keep too long in briefing window, the program stops due a memory overflow, kicks me back to the console with mouse cursor locked (keyboard works, though) and just practically tells me that there was a memory overflow. It doesn't even give me any error report that I'm aware of.

Strange thing is, when I get into game itself (ie. into cockpit) the problem goes away. The voice becomes normal and as good as it can be on my onboard sound card.

Thanks in advance.

Relevant specs:

OS: 64-bit Ubuntu Dapper 6.06 currently running on 2.6.15-25-amd64-k8 kernel

Sound: ALSA on Realtek AC97 onboard sound card

Build: Taylor's 2006/05/02 build
Current command line: $ ./fs2_open_r -mod Media_VPs, ,Derelict_SCP -spec -glow -jpgtga -mipmap -env -alpha_env -ambient_factor 0 -2d_poof -missile_lighting -dualscanlines -targetinfo -orbradar -rearm_timer -ship_choice_3d -3dwarp -warp_flash -fps -allslev -noscalevid -cache_bitmaps

I do have the latest OpenAL libraries (otherwise I'd hardly be able to even compile the build) and also the latest OGG libraries, so that shouldn't be a problem. Besides, as the problem only appears when in briefing, I doubt it would be as simple as a file incompatibility. But I can't really be sure. Heck, I got this OS instaled only a week ago and installed FS2 today. I wouldn't be surprized if there's a lot of what I don't have the foggiest idea about.  :p
There are three things that last forever: Abort, Retry, Fail - and the greatest of these is Fail.