Author Topic: Mouse always jumps to bottom right corner  (Read 1926 times)

0 Members and 1 Guest are viewing this topic.

Offline Cybertinus

  • 22
  • Posts: 5
Mouse always jumps to bottom right corner
Hello,

I'm just new to this forum, but I'm a FreeSpace fan since the very beginning :) (yes, I played FS1 in 1998 ;) ). I'm using the installer and stuff also for a few years now.
Now I'm trying to set it up on my Gentoo Linux machine (64 bit, ~amd64 to be exact). Rest of the specifications:
Intel Core 2 Duo E6600 processor (running on 3,6 Ghz instead of 2,4 Ghz)
8 GB DDR2 PC6400 RAM (running on 964 Mhz instead of 800 Mhz)
54 GB for / (1 partition of 3, on a RAID0 set)
2,7 TB for /home (the only partition on a RAID6 set)
nVidia GeForce 9600GT 512 MB RAM
Samsung SyncMaster 2443nw (24" TFT, 1920x1200 screen)

First I used the normal Java installer to get everything running, so that was FSO 3.6.9. With that version I had 2 problems:
1. I tried to use /dev/[sound/]dsp as sound device, which (obviously) didn't work
2. The mouse is in the bottom right corner and jumps back to it, every second. I can move the mouse, but it jumps back to that  corner within a second, making the game unplayable, because I can't even get to the briefingroom ;)

Then I downloaded the latest SVN (revision 5160) and compiled that (for my computer, with autogen.sh --enable-debug CFLAGS="-O2 -pipe -fomit-frame-pointer -fno-ident -march=core2" CXXFLAGS="$CFLAGS") and problem 1 was solved :). I got sound then. But the mouse was still doing it weird stuff, and kept jumping back to the lower right corner.

Changing the resolution doesn't make any difference. Running it in windowed mode instead of full screen also doesn't make a difference.

I really don't know what could be wrong here. If anyone has an idea to get it to work (or when you need more information) please tell me, then I'll do my best to give it to you. Thnx for reading ;)

 

Offline FUBAR-BDHR

  • Self-Propelled Trouble Magnet
  • 212
  • Posts: 5,829
  • Master Drunk
    • 165th Beer Drinking Hell Raisers
Re: Mouse always jumps to bottom right corner
Try disabling the joystick in game.  It might be picking up some other input device as a joystick even if you don't have one.
No-one ever listens to Zathras. Quite mad, they say. It is good that Zathras does not mind. He's even grown to like it. Oh yes. -Zathras

 

Offline Rhymes_With_PSYCHO

  • Galactic Mediator
  • 28
  • Posts: 454
  • Fatum Iustum Stultorum
Re: Mouse always jumps to bottom right corner
:welcomered:, Cybertinus!

Yeah, the whole joystick/mouse problem is something people have been coming here about a lot lately.
“All they are is Hate. All they have is Hate. All they need is Hate. All they want is butternut fudge ice chocolate pickles. No. Wait. That's what I want.”

 

Offline Cybertinus

  • 22
  • Posts: 5
Re: Mouse always jumps to bottom right corner
OK, I can try that. Thnx for the tip :). But how do I disable the joystick, when I can't get to the ingame options :). Is there some option I can add to ~/.fs2_open/fs2_open.ini to disable it?

 

Offline captain-custard

  • previously known as andicirk
  • 210
  • Posts: 1,221
  • one sandwich short of a picnic
Re: Mouse always jumps to bottom right corner
you will need to get the linux launcher from the cross platform selection and have a look at that ......


here

http://www.hard-light.net/forums/index.php/topic,53206.0.html
« Last Edit: April 14, 2009, 04:55:14 am by andicirk »
"Duct tape is like the force. It has a light side, a dark side, and it holds the universe together."

 

Offline Herra Tohtori

  • The Academic
  • 211
  • Posts: 3,534
  • Bad command or file name
Re: Mouse always jumps to bottom right corner
Well, F2 should get you to the configs. But I don't remember if you can use keyboard to navigate the menu... I've never had to do that myself. And I can't really try it at the moment as I don't have access to working FS2_Open installation (or rather the PC that has one is working erroneously). Try it, though... worst case, you can only fail. :p
There are three things that last forever: Abort, Retry, Fail - and the greatest of these is Fail.

 

Offline captain-custard

  • previously known as andicirk
  • 210
  • Posts: 1,221
  • one sandwich short of a picnic
Re: Mouse always jumps to bottom right corner
you can use the keyboard , start the game adn then choose your pilot using the arrow keys....tab for multi single when you get to the launch bay or whatever version your running use f4 then the arrows and tab key to navigate around

but try downloading and setting up the launcher
"Duct tape is like the force. It has a light side, a dark side, and it holds the universe together."

 

Offline Cybertinus

  • 22
  • Posts: 5
Re: Mouse always jumps to bottom right corner
I've downloaded and setup YAL, but that doesn't have support for Joystick just yet :( (I downloaded the latest release, because the SVN version didn't compile), so I can't disable it there.
Then I tried the F4 option, but F4 doesn't do anything, so I can't get to the options using that. I managed to get a mission going (the mousepointer is in the center of the screen right in the beginning, and there is the briefingroom, when I click without moving the mouse I get in ;), then I must commit a few times but that is bottom right, so that is no problem ). Then I could press F2 to get to the options, but then I only could switch the page, not get to the options itself :(. And I don't see how I can disable the joystick there, I can only set the sensitivity back, nothing more.
Anyone any idea's left? :)

 

Offline castor

  • 29
  • Posts: 749
    • http://www.ffighters.co.uk./home/
Re: Mouse always jumps to bottom right corner
I attached a player file which has J/S sensitivity set to min + all control axis disabled (so ship won't turn with mouse either, but atleast you'll see if it makes any difference).

Delete or move out everything in ~/.fs2_open/data/players/single/
Then unzip the attached file there, run the game.

[attachment deleted by evil Tolwyn]

 

Offline Cartman

  • 21
  • Posts: 2
Re: Mouse always jumps to bottom right corner
This is probably not a problem with FS itself. IIRC Doom3 had the same problem once on my machine (also gentoo). Try running
Code: [Select]
export SDL_VIDEO_X11_DGAMOUSE=0 before starting FS on your terminal. That fixed it for me.

 

Offline Cybertinus

  • 22
  • Posts: 5
Re: Mouse always jumps to bottom right corner
sweet Cartman. That did the trick indeed :D. Now I can play FS2 properly :D. Thnx a lot. I'm putting this in my ~/.zshrc, so I don't have to enter it every time I want to play ;)

 

Offline castor

  • 29
  • Posts: 749
    • http://www.ffighters.co.uk./home/
Re: Mouse always jumps to bottom right corner
Great! That sounds something to be Wikified.

 

Offline captain-custard

  • previously known as andicirk
  • 210
  • Posts: 1,221
  • one sandwich short of a picnic
Re: Mouse always jumps to bottom right corner
yeah that would be great this problem had ppl scratching there heads for a good while in irc and here
"Duct tape is like the force. It has a light side, a dark side, and it holds the universe together."

 

Offline Cybertinus

  • 22
  • Posts: 5
Re: Mouse always jumps to bottom right corner
Great! That sounds something to be Wikified.

Done :D http://www.hard-light.net/wiki/index.php/Mouse_jumps_to_bottom_right_corner
I'm only unable to add a link to this page on the index (http://www.hard-light.net/wiki/index.php/Guide_to_FS_Open_on_Linux), When I try to add it with the line ***[[Fs2_open_on_Linux/Mouse jumps to bottom right corner|Mouse jumps to bottom right corner]] it links to a new page, although it should exists. Maybe someone with a bit more Wiki editing experience knows how to do this ;)

edit:
Ah, never mind. I just added the link, woohoo :)
« Last Edit: April 15, 2009, 04:15:05 pm by Cybertinus »