Author Topic: Hit "Run" and see just a black screen  (Read 4963 times)

0 Members and 1 Guest are viewing this topic.

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: Hit "Run" and see just a black screen
Ya, but size (not on-disk, actual size) for A is 24.2 MB (25,386,260 bytes) and B is 81.9 MB (85,907,413 bytes)

That's quite a bit of overhead, considering an empty .zip file is ~22 bytes


EDIT: just re-downloaded the VP tools onto this machine, and:

tangoA contains game_dat2.set

tangoB contains game_dat1.set

(No I didn't mix those up, dat2 goes with A, dat1 goes with B)
« Last Edit: April 30, 2012, 02:53:56 am by jr2 »

 

Offline Jeff Vader

  • The Back of the Hero!
  • Moderator
  • 212
  • Bwahaha
    • Twitter
Re: Hit "Run" and see just a black screen
Hmm. Maybe they contain some files needed in the installation? Iunno, I just know that everyone so far has been successful in his/her FreeSpace playing without them.
23:40 < achillion > EveningTea: ass
23:40 < achillion > wait no
23:40 < achillion > evilbagel: ass
23:40 < EveningTea > ?
23:40 < achillion > 2-letter tab complete failure

14:08 < achillion > there's too much talk of butts and dongs in here
14:08 < achillion > the level of discourse has really plummeted
14:08 < achillion > Let's talk about politics instead
14:08 <@The_E > butts and dongs are part of #hard-light's brand now
14:08 <@The_E > well
14:08 <@The_E > EvilBagel's brand, at least

01:06 < T-Rog > welp
01:07 < T-Rog > I've got to take some very strong antibiotics
01:07 < achillion > penis infection?
01:08 < T-Rog > Chlamydia
01:08 < achillion > O.o
01:09 < achillion > well
01:09 < achillion > I guess that happens
01:09 < T-Rog > at least it's curable
01:09 < achillion > yeah
01:10 < T-Rog > I take it you weren't actually expecting it to be a penis infection
01:10 < achillion > I was not

14:04 < achillion > Sometimes the way to simplify is to just have a habit and not think about it too much
14:05 < achillion > until stuff explodes
14:05 < achillion > then you start thinking about it

22:16 < T-Rog > I don't know how my gf would feel about Jewish conspiracy porn

15:41 <-INFO > EveningTea [[email protected]] has joined #hard-light
15:47 < EvilBagel> butt
15:51 < Achillion> yes
15:53 <-INFO > EveningTea [[email protected]] has quit [Quit: http://www.mibbit.com ajax IRC Client]

18:53 < Achillion> Dicks are fun

21:41 < MatthTheGeek> you can't spell assassin without two asses

20:05 < sigtau> i'm mining titcoins from now on

00:31 < oldlaptop> Drunken antisocial educated freezing hicks with good Internet == Finland stereotype

11:46 <-INFO > Kobrar [[email protected]] has joined #hard-light
11:50 < achtung> Surely you've heard of DVDA
11:50 < achtung> Double Vaginal Double ANal
11:51 < Kobrar> ...
11:51 <-INFO > Kobrar [[email protected]] has left #hard-light []

 

Offline The E

  • He's Ebeneezer Goode
  • Global Moderator
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: Hit "Run" and see just a black screen
I do not know what these files are, just that they're nothing FS2 needs or uses.
Let there be light
Let there be moon
Let there be stars and let there be you
Let there be monsters and let there be pain
Let us begin to feel again
--Devin Townsend, Genesis

 

Offline Wonz

  • 23
Re: Hit "Run" and see just a black screen

Tried with the "Tango-files)

I once tried to run FS after setting Adv. Sys. Care and IOBit Malware fighter not to start at Windows startup (and not executing them manually later of course). Didn't help.
Could defrag mess FS2 up?

F-sec. never gave me a hard time, but then I'm a pretty ordinary user not doing anything complex really.
Hmm. I think I'll  switch anti-virus to MSE. It's acclaimed says a quick google search.

 

Offline Wonz

  • 23
Re: Hit "Run" and see just a black screen
No go on trying FS2 with Lubuntu. wxlauncher didn't work, too much detail for my skills...

  

Offline niffiwan

  • 211
  • Eluder Class
Re: Hit "Run" and see just a black screen
I can give you a hand with getting it running on Lubuntu if you can give me details of what went wrong.

Also, have you had a read of these instructions? :)
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline jr2

  • The Mail Man
  • 212
  • It's prounounced jayartoo 0x6A7232
    • Steam
Re: Hit "Run" and see just a black screen
Defrag wouldn't mess it up.  Try once more after ditching F-Secure.

 

Offline Wonz

  • 23
Re: Hit "Run" and see just a black screen
I can give you a hand with getting it running on Lubuntu if you can give me details of what went wrong.

Also, have you had a read of these instructions? :)

Ran in terminal, typed:
wxlauncher

wxlauncher: error while loading shared libraries: libwx_baseu-2.8.so.0: cannot open shared object file: No such file or directory

Tried to ( sudo apt-get <name> ) this library and said:
invalid operation

I just can't.

And I did follow those instructions, I think.

 

Offline niffiwan

  • 211
  • Eluder Class
Re: Hit "Run" and see just a black screen
I think you may need to run:

Code: [Select]
sudo apt-get install libwxbase2.8-0

to install the library you mentioned.  However, I though if you'd built from source that you'd have needed that library already? 

Anyway, if the command above doesn't get it working, could you send the output of this?

Code: [Select]
ldd $(which wxlauncher)
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline Wonz

  • 23
Re: Hit "Run" and see just a black screen
I think you may need to run:

Code: [Select]
sudo apt-get install libwxbase2.8-0

to install the library you mentioned.  However, I though if you'd built from source that you'd have needed that library already? 

Anyway, if the command above doesn't get it working, could you send the output of this?

Code: [Select]
ldd $(which wxlauncher)

Thanks a lot!

Did that and it worked.

Now it says:
wxlauncher: error while loading shared libraries: libwx_gtk2u_core-2.8.so.0: cannot open shared object file: No such file or directory

I installed wxlauncher from here
http://code.google.com/p/wxlauncher/downloads/list
this .deb
wxlauncher-0.8.0.deb

It seems to be old.


 

Offline Wonz

  • 23
Re: Hit "Run" and see just a black screen
NOW it works.
And the guilty one was... F-SECURE.

Removed it and installed MSE (and also IoBit and ASV is on) and it works perfectly.
And I've got only a trackball, no joystick.
And FS 2 is lovely, reminds me of my TIE-Fighter game sessions back in the 90's. The feel :)

So thank You All for assisting, I wouldn't have figured this out.


 

Offline niffiwan

  • 211
  • Eluder Class
Re: Hit "Run" and see just a black screen
Glad you got it working - and you don't need the linux stuff now :)

Anyway, just in case it's useful for future, to resolve these sort of errors you can run "apt-file search filename". e.g.

Code: [Select]
$ apt-file search libwx_gtk2u_core-2.8.so.0
libwxgtk2.8-0: /usr/lib/libwx_gtk2u_core-2.8.so.0
libwxgtk2.8-0: /usr/lib/libwx_gtk2u_core-2.8.so.0.7.0

Then run "apt-get install package-name", e.g.

Code: [Select]
sudo apt-get install libwxgtk2.8-0

(and just in case apt-file isn't installed by default, you can run "sudo apt-get install apt-file")
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline Cyborg17

  • 29
  • A-1 Supar
Re: Hit "Run" and see just a black screen
And the guilty one was... F-SECURE.

Perhaps we should update the manual install page to reflect that F-SECURE has been known to cause issues with running the game?