Author Topic: FS2 Not even starting  (Read 3689 times)

0 Members and 1 Guest are viewing this topic.

Offline jonsul

  • 22
Hi FreeSpace is one of my favorite games of all time but I have been having trouble getting it up. I used the installer to install and all installed perfectly, I installed the linux 32bit binary, but now when I try to run I get this message.

[email protected]:~/Desktop/g/freespace$ sh ./fs2_open
fs2_open.bin: pcm_params.c:2351: sndrv_pcm_hw_params: Assertion `err >= 0' failed.
Aborted (core dumped)

is there anyone who can help me get the awesome game working

Oh yeah I'm running Ubuntu upgraded to Gutsy. And thanks to jr2 for pointing me in the right direction.

 

Offline Herra Tohtori

  • The Academic
  • 211
  • Bad command or file name
What sound card (I'm assuming onboard, but have to ask) and what sound system are you using? ALSA? Do you have any other application open that might be reserving the sound output for itself?

Do all other sound producing programs work normally?

Do you have libopenal and libopenal-dev packages installed? ($ sudo apt-get install libopenal libopenal-dev)

You could try with -nosound command line argument, to try if the game runs without sound. If it does, the problem is definitely in the sound system - if it doesn't, there's something else amiss...
There are three things that last forever: Abort, Retry, Fail - and the greatest of these is Fail.

 

Offline jonsul

  • 22
Hmmm... I'm using PulseAudio
I installed it after hearing that it's going to be installed by default in the next ubuntu. Could this be the issue?

 

Offline Herra Tohtori

  • The Academic
  • 211
  • Bad command or file name
Well, I don't really know that much about Linux side of business, but I do know that on Linux you have to specifically set up software mixing if you want to use several audio applications at the same time.

There are some commands to find out if the audio system is reserved but I can't really remember them for the love of flying spaghetti monster, and I've never had any luck actually getting the software sound mixing to work on my sound card(s). It involves editing some audio configuration files.

Did you check the libopenal and libopenal-dev packages already?
There are three things that last forever: Abort, Retry, Fail - and the greatest of these is Fail.

 

Offline jonsul

  • 22
yeah I just checked they're installed. and as you said -nosound started it. So I guess I better try to figure out PulseAudio. I thought I had sound mixing enabled I'll check though.

is there any info about PulseAudio for FS2-open?

 

Offline castor

  • 29
    • http://www.ffighters.co.uk./home/
What do you have in the .openalrc? I guess it should contain this line:
(define devices '(esd))

 

Offline jonsul

  • 22
no I had :
(define devices '(arts esd native))

in it from VegaStrike.

But I updated it to what you said and now it starts but there is still no sound. Here is what it says:

Quote
Could not open ESoundD library: libesd.so: cannot open shared object file: No such file or directory
open /dev/[sound/]dsp: Device or resource busy
Could not open ESoundD library: libesd.so: cannot open shared object file: No such file or directory
open /dev/[sound/]dsp: Device or resource busy
Could not open ESoundD library: libesd.so: cannot open shared object file: No such file or directory
open /dev/[sound/]dsp: Device or resource busy
Could not open ESoundD library: libesd.so: cannot open shared object file: No such file or directory
open /dev/[sound/]dsp: Device or resource busy
Could not open ESoundD library: libesd.so: cannot open shared object file: No such file or directory
open /dev/[sound/]dsp: Device or resource busy
Could not open ESoundD library: libesd.so: cannot open shared object file: No such file or directory
open /dev/[sound/]dsp: Device or resource busy
Could not open ESoundD library: libesd.so: cannot open shared object file: No such file or directory
open /dev/[sound/]dsp: Device or resource busy
(null): "DirectSound could not be initialized.  If you are running any applications playing sound in the background, you should stop them before continuing."
Could not open ESoundD library: libesd.so: cannot open shared object file: No such file or directory
open /dev/[sound/]dsp: Device or resource busy

 

Offline Herra Tohtori

  • The Academic
  • 211
  • Bad command or file name
Quote
"DirectSound could not be initialized.  If you are running any applications playing sound in the background, you should stop them before continuing."


Tell you what, why not try running the game on a dedicated X server?

I might be wrong, but that should pretty certainly make sure that there are no sound playing applications running at least on that X display's background... dunno if it's the active X display that counts, or all of them. :nervous:

Here are pretty detailed instructions on setting FS2_Open to run on dedicated X server display... which is good practice anyway since when the FS2_Open jams and requires you to Ctrl+Backspace to kill the X, you'll only lose the FS2_Open, not all the applications you may or may not be running on the background, 'cause they are on the primary X display.

Don't know if this'll help with the sound problems or not, but I'd say it's worth trying at least.
There are three things that last forever: Abort, Retry, Fail - and the greatest of these is Fail.

 

Offline taylor

  • Super SCP/Linux Guru
  • Moderator
  • 212
    • http://www.icculus.org/~taylor
Just use:
(devices '(alsa))

Assuming that you have PulseAudio setup properly, and that the ALSA plugin is installed (which is mostly likely true), then you should be fine.  The ALSA backend for OpenAL will then just get routed through PulseAudio behind the scenes and there should be nothing else for you to be required to mess with in that area.

 

Offline jonsul

  • 22
Yep that did it!

but I have to start it using padsp, but that's not big I created a launcher to do it automatically.

Thanks everyone so much!!!