Modding, Mission Design, and Coding > FS2 Open Tools

PUBLIC BETA: Knossos 0.15.0-dev+73b131a (combined launcher/installer)

<< < (228/233) > >>


--- Quote from: Raneko on August 16, 2022, 12:08:36 am ---And stopped using Knossos for a week, and now it's having a stroke.  Stuck in endless loops, whether trying to download new content or load any mods. I tried an uninstall and reinstall no joy.

--- End quote ---

Nuke the settings file.  Mebbe post a debug log if you can find it.

Whoever is working on Knossos needs to add a failsafe in the code for the Max Downloads setting.  If a user (like myself in this instance) sets it at 0 or a negative number Knossos completely refuses to do anything that requires network access, such as download the mod list on start-up.

Shraavan V S:

I was trying to install and use Knossos to install mods. But I am stuck at "Installing Freespace 2" "Preparing...".

But I have already downloaded and installed Freespace 2 from steam.
It asked me to select "Root_fs2.vp" and I selected the same and clicked the option to continue, after which I am stuck with this issue.

I have very limited knowledge about the computers and so please help me fix this issue.


Iain Baker:
Knossos sometimes takes a VERY long time to install anything. If you click on the install button it should bring up progress bars for the versions things it is trying to do. But sometimes it appears to get stuck for hours. Then if you try and do it again the next day it will do it in minutes. Basically Knossos is very temperamental at times. At the risk of sounding g line Roy from The IT Crowd “Have you tried turning it off and on again?” Because that seems to work pretty well. You might need to fully restart your PC too just to make sure.

Huh...wanted to get back a bit into FS2 and I got Knossos 1.4.3, installed the latest VP's (but got an error at he end, had to re-start).
Can't start anything now.

FSO is launching flashes for a moment and ...nothing. It worked before. Win7 by the way.


[0] Message Index

[#] Next page

[*] Previous page

Go to full version