Modding, Mission Design, and Coding > Test Builds

Unicode text support

<< < (10/11) > >>

jr2:

--- Quote from: Nikogori on February 02, 2018, 05:06:12 am ---
--- Quote from: Arkblade on January 28, 2018, 12:41:40 pm ---Have you made progress? The major problem seems like he presented.
--- End quote ---

As I said before, these “problems” can be easily avoided. There is workaround for each of them.

“Token too long” error is a bit annoying, though. Sometimes it is very difficult to explain mission objectives in a 10-letter text...


--- Quote from: AdmiralRalwood on January 29, 2018, 12:25:16 pm ---Well, yes, if there's only one space in a long string of text, wordwrapping will generally force a linebreak there. Now, granted, I'm no Japanese expert, but surely you can just... add more spaces, so there are other, more natural places for wordwrapping to break lines? If not, well, can you maybe use a non-breaking space (U+00A0)?
--- End quote ---

I'd like to use existing old Japanese localization patch. Sadly it contains hundreds of “spaces” and it will take some time to remove/replace all of them.
However, if you guys believe it is not easy to let FSO handle them properly, of course I can do this task manually. I guess there are other Japanese players who want to join.

I've been busy working on my own project (I'm writing a blog about Orbiter simulator). I'll be back on this localization project as soon as my current project is finished (Hopefully it will be done by April).

--- End quote ---

Should be able to do a Find and Replace All (Use Notepad++, and do a Search > Replace > Replace All).  With a bit of fiddling you should be able to find something that will work to do what you want.

Np++ should have localization for your (and most) languages.

Nikogori:
Unicode text doesn't show up when I use recent Nightly. Is there anything I should add to mod file?


I'm using Japanese localization mod and unicodeTest mod.

I have tried some of the Nightly builds and this is the result:

fs2_open_3_8_1_20180113_830fd70_x64_SSE2.exe or older – OK
fs2_open_3_8_1_20180116_2779629_x64_SSE2.exe or newer – doesn't work

Nikogori:

--- Quote from: Nikogori on December 13, 2017, 07:46:49 am ---I don't know what “MAX_BRIEF_LINE_LEN” means but it seems Japanese briefing text is too long to display (actually they are not that long). Cutting them in half can fix this error.



--- End quote ---

I found that I can avoid this error by starting a new line.

It seems FSO doesn't like lengthy sentence which contains no space (use of “space” is not common in most Asian languages. Usually we don't separate words in a sentence). All I have to do is separate them by adding space or CR/LF.
If you don't do this, briefing text doesn't appear properly or the game will crash immediately.

m!m:

--- Quote from: Nikogori on May 31, 2018, 11:42:45 am ---Unicode text doesn't show up when I use recent Nightly. Is there anything I should add to mod file?
<snip>

I'm using Japanese localization mod and unicodeTest mod.

I have tried some of the Nightly builds and this is the result:

fs2_open_3_8_1_20180113_830fd70_x64_SSE2.exe or older – OK
fs2_open_3_8_1_20180116_2779629_x64_SSE2.exe or newer – doesn't work

--- End quote ---
I can not reproduce this issue with the latest master version (which should also be the newest nightly). Please post your fs2_open.log file.  Instructions on how to do this can be found in this post.

Nikogori:
Attached fs2_open.log is created when I encountered the problem above.

That being said, I believe I found a solution... Because everything is working fine now (with the latest Nightly). :confused:

This is all I did:

delete cache folder from mod folder.
run the game with "Run in window" option.
Unicode text is back!

I guess I did something wrong. Sorry.

[attachment stolen by Russian hackers]

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version