General FreeSpace > FreeSpace & FreeSpace Open Support

OpenAL doesn't work?


Hi there!

I really appreciate your work and it's amazing that there are still Freespace-Fans out there. Thought it to be dead since years, even before "Tachyon - the Fringe" came out.

I played Freespace for years, like till 2002 or so. Every part and even bought the Silent Threat.

Of course i wanted to test this Open Project. So i did like it's written on the page But If i run from the new Launcher, it always says

"OpenAL 1.1 or newer is required for proper operation. Please upgrade your OpenAL drivers, which are available at, and try running the game again."

I installed the OpenAL for Windows, the OpenAL SDK for Windows and even found a Creative Labs Page with some installer (where you have to accept an agreement on the Webpage first). I tried to run the game on every single step of installing the OpenAL. Although it works, the message as written bold before always appears and there is not a single sort of sound in the game.

Please help me. Did i do something wrong?.

Your OpenAL install is probably corrupt (Windows users check Windows\System32 for either ct_oal.dll or nvopenal.dll. These are the OpenAL 1.0 .dlls and they are causing the screwup. Delete them and run the OpenAL installer again. ). If that doesn't work try deleting OpenAL32.dll and wrap_oal.dll and then running the installer file again.

thx Karajorma.

I had to delete those 3 Files: nvopenal.dll, OpenAL32.dll, wrap_oal.dll
The File ct_oal.dll wasn't on my system, but other people might check for it too. Delete them like Karajorma said and install OpenAL again.

Now it all works smoothly and I'm going to check out all those goodies. :)

Thx very much.

You shouldn't really have both ct_oal.dll and nvopenal.dll on the same machine anyway in most cases as they are both the OpenAL 1.0 drivers for different sound cards. :)


[0] Message Index

Go to full version