Author Topic: Crash in raider wars campaign  (Read 1435 times)

0 Members and 1 Guest are viewing this topic.

Crash in raider wars campaign
When I try to start the mission "Slipping the Noose" tbp crashes and gives the following error:

Invalid variable name.

In sexpression: ( when
   ( is-subsystem-destroyed-delay
      "EA Gibraltar"
      "engine01"
      0
   )
   ( modify-variable
      "EnginesScorched"
      ( + [] 1 )
   )
)
(Error appears to be: EnginesScorched)
<no module>! KiFastSystemCallRet
<no module>! WaitForSingleObject + 18 bytes
<no module>! <no symbol>
<no module>! <no symbol>

What other informatin do you need to help me fix this?

I previously played past this mission running version 3.6.9 of the engine (fs2_open_3_6_9.exe) but then I upgraded to version 3.6.11 (fs2_open_3_6_11r_INF_SSE2-20091229_r5749.exe) in order to play some multi-player games with a friend on linux and it wouldn't accept my old player file so I had to start over.

Edit: I have tried with the latest nightly build (fs2_open_3_6_11r_INF_SSE2-20100101_r5758.exe)and it still doesn't work.
« Last Edit: January 03, 2010, 03:09:23 am by Trabber Shir »

 

Offline FUBAR-BDHR

  • Self-Propelled Trouble Magnet
  • Moderator
  • 212
  • Master Drunk
    • 165th Beer Drinking Hell Raisers
Re: Crash in raider wars campaign
You need Zathras.  There was an old bug that allowed variables to be placed in positions that FRED should have never allowed.  The fixed version of the mission is included in Zathras. 

Links available in public development.  It's on ModDB and Download.com.
No-one ever listens to Zathras. Quite mad, they say. It is good that Zathras does not mind. He's even grown to like it. Oh yes. -Zathras

 
Re: Crash in raider wars campaign
Thank you much, that fixed it.