Announcements > Getting Started

Having problems with FreeSpace?

<< < (40/40)

The E:

--- Quote from: BoOReD on January 15, 2017, 03:39:38 am ---Hello, i've tried googling this without much success, does this work on windows10? Thank you!

--- End quote ---

Yes, it does.

Hey, I am new here  :nod:.
Do I need the english version to run mods? I have got the germane one.

Try hopping on the HLP Discord server and asking for a more immediate answer.  I would think the German version could be used as a base for installing FSO, but I'm not absolutely certain.



Hi. I'm new to this forum, but I need some help getting FreeSpace 2's input just right.

This year, after how long, I revisited Descent FreeSpace (FSport) and FreeSpace 2. I got through Descent FreeSpace alright, so far so good. I made sure to disable mouse input so that it can't interfere with my joystick. I beat the game (main campaign, not including Slient Threat expansion) with no problems, and then I proceeded to update my downloaded mods through Knossos, and then moved on to FreeSpace 2.

I began playing the first mission (Surrender, Belisarius!), and I noticed that not only was mouse input on, but there was a strange rolling as my ship kept on tumbling. I hit F2, and DISCOVERED I COULDN'T SWITCH MOUSE INPUT OFF. I got "Mouse Input: Mouse/JOY-0" rather than "Mouse Input: On/Off", and now I'm stuck. What's going on? I update, and now I keep tumbling and my mouse can't be switched off. I even tried Retail and MediaVPs 4.5 and It didn't help at all. Help?

First of all, welcome back!

Secondly,  There was a major change to the controls as of FSO version 22.0.  The mouse and joystick controls were finally split to be independant of each other, and multi-joy is now available.

We've also recently added a FAQ to the wiki, since this is a major change. (Why we didn't have such a page to begin with is another matter)

Right. So.  Go to your controls config menu and remove the Mouse axes bindings from your pitch and roll.  There should be a second column of bindings instead of just the one that you are normally accustomed to.  This will effectively turn the mouse OFF.  If you want to totally disable the mouse from activating weapons, etc. then you should unbind all buttons, too.  (Remember that you can use the Search button to quickly find the action an axis or button is bound to).


[0] Message Index

[*] Previous page

Go to full version