Modding, Mission Design, and Coding > Cross-Platform Development

My little amdgpu bughunt

<< < (2/3) > >>

Did that. I've got a 2GB trace file sitting in my fs folder now. Not sure if it helps, though,
because this time, graphics didn't freeze for longer than half a second - everything worked normally after that!
Could apitrace be restarting whatever crashes in my card?

AMDGPU-PRO is giving me real bad framerates now and again, btw. So if this can't be solved easily,
I'll play without shadows on the open driver and wayland in the future.

Edit: Just had a freeze trying to replay the trace. About ready to give up on this and play without shadows.

Got to thinking about this again.
What was most strange about it is this:
There was no freeze while running in apitrace,
only a slight hang - as if apitrace "made" my GPU "go on normally"
 - I don't know how to express this technically - after the cause of the freeze.

I booted with amdgpu.gpu_recovery=1. No freeze this time, not even an appreciable
FPS drop. I still get lots of red lines in journalctl, though:
amdgpu 0000:01:00.0: GPU fault detected: 146 0x078a4414 for process fs2_open_19_0_0 pid 1477 thread fs2_open_1:cs0 pid 1497
amdgpu 0000:01:00.0:   VM_CONTEXT1_PROTECTION_FAULT_ADDR   0x001070F1
amdgpu 0000:01:00.0:   VM_CONTEXT1_PROTECTION_FAULT_STATUS 0x05044014
amdgpu 0000:01:00.0: VM fault (0x14, vmid 2, pasid 32772) at page 1077489, write from 'TC1' (0x54433100) (68)

(and dozens more like that)

I'm fairly certain it's an AMDGPU bug, but as long as I can work around it ...

@m!m: Maybe you could verify this / test if shadows work with that parameter set?

EDIT: Ah hell. On some missions, this helps, on some it doesn't.

Sorry to engage in some forum necromancy, but I'm hitting this exact problem. The description in OP matches my experience almost exactly.

Given that this thread is a couple of years old at this point, what are my options? Have these problems been fixed, or is there some option I can tweak to keep from getting these crashes?

I got a new GPU in the meantime, but the only thing that worked for me on polaris cards is using AMDGPU-PRO and/or lowering shadow quality. Can give you hints how to do it on Arch when I'm back at my machine. I've also opened an issue with mesa, link to follow.

Thanks! I'm on Arch as well, using an AMD Vega GPU, which is also based on Polaris.

amdgpu: hwmgr_sw_init smu backed is vegam_smu

01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Polaris 22 XL [Radeon RX Vega M GL] (rev c0)


[0] Message Index

[#] Next page

[*] Previous page

Go to full version