Hard Light Productions Forums

Hosted Projects - FS2 Required => FreeSpace Conversion => Topic started by: Farewell on June 25, 2006, 02:21:54 am

Title: -Deleted-
Post by: Farewell on June 25, 2006, 02:21:54 am
Title: Re: Newbie Help!
Post by: Wanderer on June 25, 2006, 04:05:58 am
So you had FSPort mod selected via launcher? Did you select the FSPort campaing (The Main FreeSpace 1 Campaign or Silent Threat) from the campaign screen instead of the FreeSpace 2 campaign?
Title: Re: Newbie Help!
Post by: geblar on June 25, 2006, 05:47:05 am
I am having a similar problem - I hate to make my first post requesting noobish help, but unfortunately I'm at my wit's end.

I have a similar setup to badme, most recent CVS build and mediaVPs - I even have them set up just like in the FAQ, in their own directory named mediavps.  I downloaded the mission vp, the main FSPort vp, the sparky vp, and even ripped all the voice and cutscene data from my FS1 discs to the data folder of the FSPort directory I made. 

Unfortunately, upon selecting the FSPort mod and using multimod to making it load the VPs as well, something is wrong. I can select the FS1 campaign, the ships are working and look good, so obviously the multimod is working fine. What doesn't work is that the main screen is seemingly the one from the FS2. I'm not sure if you guys ever fit in the original's one in hires, but I'll tell ya anyway. My main problem is that upon starting the campaign, I get a Ulysses with no weapons instead of an Apollo as intended. I just did a fresh install and I have no tables in my tables directory to mess stuff up, so I'm pretty clueless at the moment.

Like I said though, the mediavps are working so it doesn't seem to be a problem with the way that I installed said mod, it might have something to do with needing a new table or maybe just some conflict between the latest releases.  Any help would be appreciated, and also many thanks for this excellent project's existence.
Title: Re: Newbie Help!
Post by: Wanderer on June 25, 2006, 06:15:21 am
Have you tried... Creating a new pilot just for the FSPort? Clicking 'reset loadouts' in the briefing/loadout screens?

Have you got sparky_hi_fs1.vp? (probably)

Could you post your commandline? And if have the contents of mod.ini file related to FSPort
Title: Re: Newbie Help!
Post by: geblar on June 25, 2006, 06:39:50 am
The new pilot thing I'm sketchy on - in my FSPort directory under players it lists one pilot, but I don't even see that specific one in game - not sure if that means it's not really reading my FSPort pilots or not.

Either way, I found a table pack and put it in my tables directory. Now, the mainhall displays correctly and whatnot. However, when I try to load the first mission of the campaign I get this error.

Error: Can't open model file <navbuoy-terran.pof>
Line: 1829
[This filename points to the location of a file on the computer that built this executable]

Call stack:
    fs2_open_r.exe 004f2400()
    fs2_open_r.exe 004b0347()
    fs2_open_r.exe 0040ecb4()
    fs2_open_r.exe 0040ec11()
    fs2_open_r.exe 00411cf5()
    fs2_open_r.exe 00413d81()
    fs2_open_r.exe 00415485()
    fs2_open_r.exe 0041546e()
    fs2_open_r.exe 00416174()
    fs2_open_r.exe 00529f36()
    fs2_open_r.exe 0040227f()
    fs2_open_r.exe 00408c62()
    fs2_open_r.exe 004fea86()
    fs2_open_r.exe 00407be5()
    fs2_open_r.exe 004fed79()

Not sure exactly what's going on there. It is worth noting that if I take out the ships.tbl, I can run the mission, and now I get a Ulysses, but with weapons. Still not an Apollo, so maybe that ships.tbl is outdated?

But yes, I have sparky_hi, I've tried resetting and whatnot. Commandline is:

C:\Games\FreeSpace2\fs2_open_r.exe -mod fsport -spec -glow -env -jpgtga -mipmap -nomotiondebris -2d_poof -missile_lighting -dualscanlines -orbradar -rearm_timer -ballistic_gauge -ship_choice_3d -3dwarp -warp_flash -snd_preload

, and my mod.ini is simply
secondrylist = ,mediavps;
Title: Re: Newbie Help!
Post by: Wanderer on June 25, 2006, 11:10:17 am
geblar: You shouldnt need any tableset for FSPort 3.0.3 as all required files are provided within the VP archive files. Check that you have the 3.0.3 version of the FSPort
Title: Re: Newbie Help!
Post by: geblar on June 26, 2006, 07:13:23 am
Thanks, Wanderer, for pointing out the obvious to me - somehow I had managed to copy the main FSPort file into the wrong directory. Whoops.

Anyway, now it's working great, but I have a feeling I'm missing out on some of the new ships models/maps. For example, ships like the Anubis or Angel look terrible, I know maps for at least the Anubis are somewhere out there. Basically all I need to know is if I already have these files to make the ships look good and somehow my mediavps are overwriting them or something, or do I need to get them from another source?