Author Topic: Osiris error on MVPs 4.6.6  (Read 1706 times)

0 Members and 1 Guest are viewing this topic.

Offline CT27

  • 211
Osiris error on MVPs 4.6.6
I ran into an error involving the Osiris bomber on the newest MVPs (4.6.6).

Hits don't always register on it.  I launched dual Trebs at it from behind and at the side and they did nothing (they didn't go through the Osiris as I didn't see them come out the other end)...I didn't even see an explosion.  Same with primary fire, most of the time firing on an Osiris did nothing in terms of hull damage...bolts weren't going through the ship I just didn't see any little sparks or anything that I normally do when hitting the craft nor did damage happen.  Sometimes wingmen could do damage to Osiris bombers so it's not impossible to destroy but just extremely difficult now.

(I tested this on a FSPort campaign and a post-Capella campaign).

This isn't a problem with everything in MVPs 4.6.6, just the file "mv_assets_v.vp".  I had my complete 4.6.5 file saved away somewhere thankfully, so I replaced the 4.6.6 version of that Vasudan file with the 4.6.5 version and things worked normally again with the Osiris (primary and secondary weapons were able to hit and do damage).


Offline mjn.mixael

  • Cutscene Master
  • Moderator
  • 212
  • Chopped liver
    • Steam
    • Twitter
Re: Osiris error on MVPs 4.6.6
I tested this from multiple angles in BtA which uses MVPs 4.6.6 and could not reproduce the issue. Shots land as I expect them to. It's possible you had a corrupted VP file. I would not stick with the 4.6.5 file as 4.6.6 fixes several issues with Vasudan ships.
Cutscene Upgrade Project - Mainhall Remakes - Between the Ashes
Youtube Channel - P3D Model Box
Between the Ashes is looking for committed testers, PM me for details.
Freespace Upgrade Project See what's happening.


Offline CT27

  • 211
Re: Osiris error on MVPs 4.6.6
This is  weird.  I tried BTA  with a new download of the 4.6.6 "mv_assets_v.vp" file and that worked okay like you said (Osiris bombers were able to be destroyed normally), but when I tried the new file with other campaigns the Osiris still had the problems I talked about earlier (you would see shield flashes but after destroying the shield hull shots wouldn't register).

Could it have something to do with labeling?  In the campaign that things worked right in (Templar BTA version) the Osiris bombers were labeled "GVB Osiris".  In the FSport campaign I had the Osiris problem in (Aftermath CE) they were labeled "PVB Osiris".  In the post-Capella campaign I had the problem in (Aftermath Reboot II...aka The Blue Guardian), the Osiris bombers had the label "VNB Osiris".  I have no idea why that would cause a problem but it's something I noticed.

If I want to play a campaign where I'm facing Osiris bombers I may have no choice but to stick with the 4.6.5 version of this file (like I said it doesn't seem to be a problem with all the new MVPs 4.6.6 files...just this particular one for some reason).
Also FYI:  I'm not having problems with other Vasudan crafts as of yet, just the Osiris.  On other bombers and fighters, shots register against the hull and they're able to be destroyed normally.


Offline CT27

  • 211
Re: Osiris error on MVPs 4.6.6
I think I might have found the issue:

For some reason when I played Templar (BTA version) and was playing on full MediaVPs 4.6.6 , I was using FSO 22.2 RC8.  When I was playing the other two campaigns with full MediaVPS 4.6.6, I was using FSO 22.0
I then tested TBG using FSO 22.2 RC8 and Osiris bombers received hull damage and were able to be defeated properly.

So it looks like 4.6.6 needs at least 22.2 RC8 to work fully.

Could a difference in FSO builds explain things?