Author Topic: Help Me Bring Light Into a Universe of Darkness  (Read 331 times)

0 Members and 1 Guest are viewing this topic.

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Help Me Bring Light Into a Universe of Darkness
This is an attempt to get some broader feedback and hopefully solve a lighting issue I've been having with recent Nightly builds.  I've had frequent assistance from m!m in trying to resolve this, but we appear to be at a loss now.

Builds newer than October 31st have no ambient lighting for me.  The glowmaps work, but all ambient lighting is gone.  I've tried increasing the ambient factor in the launcher but there was no change.  Oddly enough, Debug builds don't have this problem for me.  m!m was unable to reproduce this, but he isn't using an ATI card like I am, and I was hoping that other ATI users might be able to confirm my findings.  I've also found that jumpnodes render as black under these builds.

You see an example of my lighting issue in the Dec. 6th Nightly Build Thread.

My card is an ATI HD 5770 with 1GB RAM.  I'm using Windows 7 Pro 64-bit.  Because of this, I can't used the very latest drivers.  In fact, the last driver set released for my configuration was in 2015.

Has anyone had this problem, or can shed some... light, on what might be causing this?
The Trivial Psychic Strikes Again!

 
Re: Help Me Bring Light Into a Universe of Darkness
I've inconsistently had this problem as well. Usually never in game, but I've seen it in FRED and also in the little ship previews in the briefings.

 

Offline Novachen

  • 27
  • The one and only Capella supernova.
Re: Help Me Bring Light Into a Universe of Darkness
I had this issue only in FRED2. the first visit in the technical database as well in the weapon loadout screen. But never in mission.

But i had this problem in Pre-3.8.0 Nightlies only that use the new lightning model. But after that, i did not have any issues. But also it made no difference if i used Debug or normal builds.

But during this time also some new graphic drivers were released... maybe they were responsible for my solution in the first place.

Well, i can not help you in this matter unfortunately, because the difference between debug and normal builds stumple me, too. Did you try to check some lightning flags? I am talking about Emissive Light or Deferred Lightning?
Female FS2 pilot since 1999.

German Translations created by me:
Between the Ashes: Slaves of Chaos, FreeSpace Port, The Destiny of Peace, Silent Threat: Reborn, Awakenings (in development),

Other projects:
FSPort Mission Upgrade, Out of the Shadow: Nova Safiya Edition (Remake of the Out of the Shadow campaign, in development)

If you want to know, what my nickname means, -chen is a german diminutive term, so you can translate Novachen as something like Little Nova or Novalet.
Even my original meaning of this name is more like "Sweet pretty deadly (Super)Nova" ;).

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Re: Help Me Bring Light Into a Universe of Darkness
Emissive light and deferred lighting are both enabled.
The Trivial Psychic Strikes Again!

 

Offline Novachen

  • 27
  • The one and only Capella supernova.
Re: Help Me Bring Light Into a Universe of Darkness
Emissive light and deferred lighting are both enabled.

And the problem is the same if you play without it?
Female FS2 pilot since 1999.

German Translations created by me:
Between the Ashes: Slaves of Chaos, FreeSpace Port, The Destiny of Peace, Silent Threat: Reborn, Awakenings (in development),

Other projects:
FSPort Mission Upgrade, Out of the Shadow: Nova Safiya Edition (Remake of the Out of the Shadow campaign, in development)

If you want to know, what my nickname means, -chen is a german diminutive term, so you can translate Novachen as something like Little Nova or Novalet.
Even my original meaning of this name is more like "Sweet pretty deadly (Super)Nova" ;).

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Re: Help Me Bring Light Into a Universe of Darkness
Disabling Emissive Lighting results in no change, but disabling Deferred Lighting brings things back to near normal.  I say near normal because when comparing it on and off on the October 31st build, the last build before this problem began, having Deferred Lighting disabled makes it just a bit brighter than with it on.  I don't have time right now to compare whether having DL turned off also restores my jumpnodes or not, but I'll likely try it tomorrow.  I'll let you know what I find.
The Trivial Psychic Strikes Again!

 

Offline m!m

  • 210
Re: Help Me Bring Light Into a Universe of Darkness
Please post your fs2_open.log file.  Instructions on how to do this can be found in this post.

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Re: Help Me Bring Light Into a Universe of Darkness
Log file using Dec. 12th fast Debug on Port3.5+MV2014 & FS2+MV2014 with Deferred Lighting disabled.
The Trivial Psychic Strikes Again!

 

Offline m!m

  • 210
Re: Help Me Bring Light Into a Universe of Darkness
Does lighting work in that configuration? You said above that it works if you disable deferred lighting. If it works then a log of a run where it doesn't work would also be helpful.

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Re: Help Me Bring Light Into a Universe of Darkness
Copy that.  Same configuration.  Just remember what I said earlier, that it renders with proper lighting under debug, even with deferred lighting enabled.
The Trivial Psychic Strikes Again!

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Re: Help Me Bring Light Into a Universe of Darkness
More data.  Although lighting appears normal with deferred lighting disabled when viewing in the lab, but in mission lighting is often dark again.  I say "often", because it sometimes flickers to proper lighting.  I haven't tested it with a jumpnode yet.
The Trivial Psychic Strikes Again!

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Re: Help Me Bring Light Into a Universe of Darkness
Good news!  Dec 17th build has proper lighting restored with no flickering.  I even have my jumpnodes back!  YAY!

Thanks to whoever figured it out!
The Trivial Psychic Strikes Again!

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Re: Help Me Bring Light Into a Universe of Darkness
This is really getting irritating.  I don't have time to do some proper testing, and probably won't for at least another week.  The Dec. 17th build working for me, appears to have been a one-off thing.  Now it won't do lighting again.  I loaded up the new Dec. 21st build and found no lighting.  Then I switched back to the Dec. 17th build, no lighting.  So I thought that perhaps one of the .dll files from the new build was responsible, so I re-extracted those with the Dec. 17th build and loaded it up, and still, no lighting.  Back to the beginning... Oct. 31st build works, debug builds work.  All release builds since Oct. 31st have no lighting.
The Trivial Psychic Strikes Again!

 

Offline m!m

  • 210
Re: Help Me Bring Light Into a Universe of Darkness
Could you try disabling shader caching (should be in the Troubleshooting section in the launcher)?

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Re: Help Me Bring Light Into a Universe of Darkness
Disabling shader caching leaves ships completely black, including glowmaps.  Glowpoints are visible however.  Unlike my previous and recurring issue however, this affects the techroom rendering.  In fact, the techroom rendering in this build displays the same as the lab and in-game with shader caching on... model with glowmaps.  With shader caching on, the dark texture problem I've been having is not manifest in the techroom.  I forgot to mention that.

I should also mention that I tried the Dec. 21st build with deferred lighting disabling and didn't encounter the flickering issue... this time.
The Trivial Psychic Strikes Again!