Hosted Projects - Standalone > Diaspora Tech Help

Error 0xc000007b - Launching from Knossos


I am finally getting around to play Diaspora and I keep running into this error

--- Quote ---fs2_open_3_8_1_20171118_dfdfd59_x64_sse2.exe - Application Error
The application was unable to start Correctly (0xc000007b).
Click Okay to close the Application
--- End quote ---

Talks about it very briefly and mostly just sounds like a shrug, But that thread is 6 years old.. I am hoping there is a proper workaround to fix this by now?

I installed Knossos about 6 months ago wanting to play Diaspora, and this happened then...   so I gave up and on a whim tried to launch the game a couple of months ago and it just worked with no explanation.
I recently re-installed Windows, and now it doesn't work again.

the thread says "google stuff and tell us if it works"   ... well nothing google tells me works... Either its a problem between 32 and 64 bit windows, or its a C++ Redistributable issue, or its a Direct X runtime issue.... Nothing has fixed it.

Surely by now somebody has a solution?  That would be really great.  This doesn't happen with any other game I try to launch from Knossos, only Diaspora.

If you're running a 32-bit version of Windows, you'll have to run a 32-bit FSO build; 64-bit builds won't run on 32-bit operating systems.

You might also try running a more recent version of FSO, as that particular build looks to be about four years old.

Is there an option to run 64 bit version of FSO / Knossos?  I just downloaded the file that was available.  I'm running Windows 11 64-bit...  had the same problem running Windows 10 64-bit.

I enabled some settings in graphics options and that got it running without crashing. I was getting the same error previously


[0] Message Index

Go to full version