Modding, Mission Design, and Coding > FS2 Open Tools

DAE support - so many issues

(1/3) > >>

In the last few days I've seen so many issue with .dae support it's ridiculous.  I rarely use helpers and prefer to do all my rigging in PCS2.  Every time I need to use .dae with helper PCS2 finds a new way to screw things up.  Depending on what version you use some things work, others don't and some just plain corrupt data.

Recently discovered:
-Any subobject with a space in the name is not exported in a format that can be imported int max with via Colladamax.
-Any texture name that starts with a number same issue.
-Collada 2.03 version will export paths and docking points fine but can't import them.  Latest version exports them incorrectly and I just lost 7 hours of work because of it.  Only dock point 2 had valid helper info and the others were tossed resulting in only one dock point per dock.  Also the dock point names were either not exported correctly or not at all.  Easy fix you think just rename them?  Well when there are 864 docks no it's not.

Someone working on this really needs to get some models, export to dae, import into max, export and see how bad it's frakking things up.  

Some additional ones:
-Bay paths (fighterbays) do not re-import.  If you disconnect them from the subobject then you can import them but of course they don't have parent info. 
-Paths are not parented to anything when imported. 
-Dock points with spaces in names get corrupted.
-Eye points do not parent to subobject just show as eye point. 

2.03 is obsolete now and will never be fixed.
How many of those result from a trip through max?

Most of them. 

Unfortunately I still have to use 2.03 as it's more stable with dae imports.  Dae exports work better with 2.1 or at least as far as models go.  Docking points export better with 2.03 but the info is still not formatted correctly for max to read.the name so you end up with everything being called dock x.  I tried naming one I imported into max and doing an export and that did read in with the name. 

The recent builds in Spicious' signature have been more stable, haven't they?  Import wise I mean.  I know for a long time 2.1 was incredibly unstable but it should have been getting better now.

As far as general model import 2.0.3 has so far been more stable for me.  Again I don't use helpers 99% of the time and am just importing geometry.  Granted I haven't tested the most recent but have tested one after the insignia stuff was merged and had bad results with it doing strange things to rotation and axis or subobjects.  Also load seems to load everything instead of just what you are trying to load.  If I have dock points selected and hit load it should only load dock points.  2.03 does that.  

Also you don't even want to get me started on the interface changes.  

Add special points exported import without $special=subsystem and radius of 1. 


[0] Message Index

[#] Next page

Go to full version