Hard Light Productions Forums

Modding, Mission Design, and Coding => The Modding Workshop => Topic started by: jadeddragoon on February 06, 2021, 03:12:22 pm

Title: Jaded's ModPacks
Post by: jadeddragoon on February 06, 2021, 03:12:22 pm
(https://annapuma.scrapironcity.net/image/jadeds-mod-packs-dark.png)
Jaded's ModPacks

Jaded's ModPacks are a set of mods for Freespace Open which bind together other mods available in the community into a single cohesive package for play by end users. They can be installed quickly and easily via Knossos.

Installation

Instructions
These modpacks target "HD (High Definition)" resolutions with their features. You are strongly advised to play at 1920x1080 or higher resolution when using these modpacks.

There are two special features for this mod pack: ScreenCam-Script and RadarIcon-Script. The former enables you to pause the action and enter a free-cam mode to view the action from all angles and take screenshots. The latter paints silhouettes of enemy and allied ships (Hud Icons) over the ships themselves to aid in visually locating them in dark or cloudy conditions.

The controls are as follows:
ALT+1: Enable or disable ScreenCam Mode while in a mission. You must come to a complete stop to exit ScreenCam Mode.
ALT+2: Toggle mission pause while in ScreenCam Mode
ALT+3: Toggle Hud Icons.

Frequently Asked Questions
Hidden Text: Show
  • It says the executable is missing when I try to start the modpack.
    This is a known bug with Knossos. Fortunately, there is a relatively simple workaround... here (https://www.hard-light.net/forums/index.php?topic=97350.msg1909089#msg1909089).


  • The above didn't work and/or there are no FSO versions listed.
    This is another, known bug with Knossos. You can manually install the needed executable using the workaround found here (https://www.hard-light.net/forums/index.php?topic=97350.msg1912131#msg1912131). Be sure to apply the above fix afterwards.


  • I have an error saying <mod name> is required but not installed... except it is installed.
    Yup. Another Knossos bug. What's actually happening in this case is that one of the optional packages for the named mod didn't get installed. The mod is there, but not all the parts of it that my modpack requires. You can go to the mod it claims isn't installed, click details > options > modify, and install any optional packages missing from that mod.


  • Why use (and even advocate for) Knossos when it has so many problems?
    Because Knossos, even with its flaws, is still a huge user experience improvement over previous launchers. That and these are all actually the same bug manifesting in different ways. Finally, the developer of Knossos is working on a completely new version of Knossos that should resolve these issues permanently.






Jaded's FreeSpace 2
v1.4.1

Freespace 2 with:
Freespace Ugrade MediaVPs
MjnMixael's Mainhalls (https://www.hard-light.net/forums/index.php?topic=96090.0)
HD Hud by Shivan Hunter (https://www.hard-light.net/forums/index.php?topic=97271.0) (modified)
Jaded's HD Radar Icons (https://www.hard-light.net/forums/index.php?topic=97340.0)
Lafiel's RadarIcon Script (https://github.com/BMagnu/FSO_Scripts)
Admiral MS' ScreenCam Script (https://www.hard-light.net/forums/index.php?topic=82173.0)
Nycteaus' NTF Reskin Pack (https://www.hard-light.net/forums/index.php?topic=96819.0)

(https://fsnebula.org/static/kn_download.png) (https://fsnebula.org/mod/jds_fs2)

                   
(https://fsnebula.global.ssl.fastly.net/storage/df/52/257f3d5291f3231e3f639d5391a7a745313da5fa7b3dcc5759726de08fce.png)

Change Log
Hidden Text: Show
1.4.1
  • Now requires FSO 22.0.0.
  • Mods updated:
    • Freespace Upgrade MediaVPs ~4.6.1
    • Generic Radar Icons ~1.0.0 (no in-game change)
    • Mjn's Mainhalls ~1.4.8

1.4.0
  • Realized balance is more important than things which bother me. Reverted some changes to game settings and ai from 1.2.0.

1.3.1
  • Reverted the NTC Trinity to a non-reskinned model.

1.3.0
  • Added Nycteaus' NTF Reskin Pack to the modpack. Required modifying some retail missions to use the reskinned ships.

1.2.0
  • Added "Jaded's Modpacks" splash screen.
  • Now targets engine version 21.0.0 and newer in game_settings.tbl. This results in many changes (improvements?) to gameplay which you can read about here (https://wiki.hard-light.net/index.php/Ai_profiles.tbl).
    Fair warning, I haven't fully tested the campaign with this.
    • Additional changes regarding effects visibility in nebulas (requires 21.2+)
     
  • Target HD Hud for BPC 0.6.0
    • Repositions gauges to ensure fewer overlaps.
    • AxMessage Gauges are now auto-scaling to fit your resolution (1080p and up only)
    • Now using truetype fonts for hud text to improve readability.
     
  • Added hud icon for unknown "fuzzy" radar blips

1.1.0
  • Switched to HD Radar Icons - Generic. There's no need for silhouettes in both the HUD and Radar.

1.0.0
  • Gold status achieved!
  • Reverted mainhalls dependency changes from RC6 as they didn't help.
  • Changed hd mainhalls version target to <=1.4.3 due to a breaking change in 1.4.4
  • Changed HD Hud target to ~0.5.0. This will result in a more BPC-like message interface in missions.

1.0.0-rc6
  • Added all remaining mjn mainhalls as dependencies in an attempt resolve an issue with knossos claiming there is no executable available for launching the mod pack. See `known issues` below.

1.0.0-rc5
  • Now with bomb hud icons!
  • Updated to HD Radar Icons v0.2.0
  • Updated to Lafiel's Hud Icons v21.2.12

1.0.0-rc4
  • updated to HD Radar Icons v0.1.4 (because knossos had a case of the dumb)

1.0.0-rc3
  • compat-patched a few more incorrect hud icon defs
  • updated to HD Radar Icons v0.1.3

1.0.0-rc2
  • fixed dependency issue with HD Radar Icons

1.0.0-rc1
  • PAY NO ATTENTION TO THAT MAN BEHIND THE CURTAIN!!!





Jaded's FreeSpace Port
v1.3.1

Freespace Port (https://www.hard-light.net/forums/index.php?board=39.0) with:
Freespace Ugrade MediaVPs
Freespace Port MediaVPs
MjnMixael's Mainhalls (https://www.hard-light.net/forums/index.php?topic=96090.0)
Jaded's HD Radar Icons (https://www.hard-light.net/forums/index.php?topic=97340.0)
HD Hud by Shivan Hunter (https://www.hard-light.net/forums/index.php?topic=97271.0) (modified)
Lafiel's RadarIcon Script (https://github.com/BMagnu/FSO_Scripts)
Admiral MS' ScreenCam Script (https://www.hard-light.net/forums/index.php?topic=82173.0)

(https://fsnebula.org/static/kn_download.png) (https://fsnebula.org/mod/jds_fsport)

                   
(https://fsnebula.global.ssl.fastly.net/storage/25/71/bda497c7bd16e817b7254852f57982536dfd74d008b3e4a0ed834441476e.png)

Change Log
Hidden Text: Show
1.3.1
  • Now requires FSO 22.0.0.
  • Mods updated:
    • Freespace Upgrade MediaVPs ~4.6.1
    • Freespace Port MediaVPs ~4.6.0
    • Generic Radar Icons ~1.0.0 (no in-game change)
    • Mjn's Mainhalls ~1.4.8

1.3.0
  • Realized balance is more important than things which bother me. Reverted some changes to game settings and ai from 1.2.0.

1.2.0
  • Added "Jaded's Modpacks" splash screen.
  • Does NOT target engine version 21.0.0 and newer in game_settings.tbl in order to preserve FS1 behavior as much as possible.
    • Additional changes regarding effects visibility in nebulas (requires 21.2+)
     
  • Target HD Hud for BPC 0.6.0
    • Repositions gauges to ensure fewer overlaps.
    • AxMessage Gauges are now auto-scaling to fit your resolution (1080p and up only)
    • Now using truetype fonts for hud text to improve readability.
     
  • Added hud icon for unknown "fuzzy" radar blips

1.1.0
  • Switched to HD Radar Icons - Generic. There's no need for silhouettes in both the HUD and Radar.
  • Removed superfluous dependencies to FSPort packages that are superseded by FSPort MediaVPs packages.

1.0.0
  • Gold status achieved!
  • Reverted mainhalls dependency changes from RC4 as they didn't help.
  • Changed hd mainhalls version target to <=1.4.3 due to a breaking change in 1.4.4
  • Changed HD Hud target to ~0.5.0. This will result in a more BPC-like message interface in missions.

1.0.0-rc4
  • Increased FSPort dependency to use FSPort ~3.6.8 which includes a fix for the erroneous value in the weapons.tbl. As such I've also removed my custom weapons.tbl override from the mod pack.
  • Added all remaining mjn mainhalls as dependencies in an attempt resolve an issue with knossos claiming there is no executable available for launching the mod pack. See `known issues` below.

1.0.0-rc3
  • Added weapon table fix till next FS Port release.

1.0.0-rc1
  • Initial Release Candidate





Jaded's Blue Planet Complete
v1.3.2

Blue Planet Complete (https://www.hard-light.net/forums/index.php?topic=90802.0) with:
HD Hud by Shivan Hunter (https://www.hard-light.net/forums/index.php?topic=97271.0) (modified)
Jaded's HD Radar Icons (https://www.hard-light.net/forums/index.php?topic=97340.0)
Lafiel's RadarIcon Script (https://github.com/BMagnu/FSO_Scripts)
Admiral MS' ScreenCam Script (https://www.hard-light.net/forums/index.php?topic=82173.0)
MjnMixael's Mainhalls (https://www.hard-light.net/forums/index.php?topic=96090.0) (for FS Blue)

(https://fsnebula.org/static/kn_download.png) (https://fsnebula.org/mod/jds_blueplanet)

                   
(https://fsnebula.global.ssl.fastly.net/storage/92/8a/b79c5ab9cd436e08d3db1345bafb63f3be5b7b5cd78ff96b49d0993ee8b2.png)

Change Log
Hidden Text: Show
1.3.2
  • Now requires FSO 22.2.0
  • Now requires the soyakaze package of MJN's Mainhalls. This mainhall is used for the SOC loop in FSBlue, a detail I had simply missed somehow.

1.3.1
  • Now requires FSO 22.1.0-20220507 (I normally wouldn't require a nightly build, but the controls change and confusion necessitates it in this case. This is the same nightly BP 3.0 requires.)
  • Mods updated:
    • Blue Planet Complete ~3.0.3
    • Freespace Upgrade MediaVPs ~4.5.1
    • Generic Radar Icons ~1.0.0 (no in-game change)
    • Mjn's Mainhalls ~1.4.8
    • (Removed) GOTY Mission Pack

1.3.0
  • Realized balance is more important than things which bother me. Reverted some changes to game settings and ai from 1.2.0.

1.2.0
  • Added "Jaded's Modpacks" splash screen.
  • Added MJN's Mainhalls (at long last!). Only needed for FS Blue and only available for the Aquitaine at this time.
  • Now targets engine version 20.0.0 and newer in game_settings.tbl. Cannot target 21.0 due to depreciated call in one of BPC's scripts.
    • Manually implemented changes that would be present if 21.0 was targeted version. Results in many changes (improvements?) to gameplay which you can read about here (https://wiki.hard-light.net/index.php/Ai_profiles.tbl).
      Fair warning, I haven't fully tested the campaign with this.
    • Additional changes regarding effects visibility in nebulas (requires 21.2+)
     
  • Target HD Hud for BPC 0.6.0
    • Repositions gauges to ensure fewer overlaps.
    • AxMessage Gauges are now auto-scaling to fit your resolution (1080p and up only)
    • Now using truetype fonts for hud text to improve readability.
     
  • Added hud icon for unknown "fuzzy" radar blips

1.1.1
  • BugFix: Was still depending on HD Radar Icons - Silhoettes. Fixed.

1.1.0
  • Switched to HD Radar Icons - Generic. There's no need for silhouettes in both the HUD and Radar.

1.0.0
  • Gold status achieved!
  • Main hall mod for aquitane in FSBlue still not included. Needs an update to MediaVPs which is waiting on FSO 21.4.0... I've decided not to wait because big changes are coming in my radar icons and hud mk2 mods.
  • Uses lafiel's hud icons v21.9.1 which fixes a crash bug in some campaigns (but not this one).

1.0.0-rc5
  • Increased BPC dependency to use BPC ~1.1.5 which includes a fix for sound table parsing errors. Currently only affects recent nightlies but would have been an issue in FSO 21.1.0.
  • Known Issues:
    • Mjn's Mainhalls have too many files and cause FSO to error out when combined with the other mods in this pack. As Mjn's Mainhalls are only used for the Aquitane mainhall in the FS Blue campaign,
      I am leaving Mjn's Mainhalls out of the pack until either the number of files in it are reduced or the FSO devs raise the file limit in the engine.

1.0.0-rc4
  • Swapped Axem's parseconfig script for the one used by blueplanet complete. Apparently they are different. This should solve the issue with FSO crashing when viewing the Database (fiction viewer) in-game.
  • Known Issues:
    • Mjn's Mainhalls have too many files and cause FSO to error out when combined with the other mods in this pack. As Mjn's Mainhalls are only used for the Aquitane mainhall in the FS Blue campaign,
      I am leaving Mjn's Mainhalls out of the pack until either the number of files in it are reduced or the FSO devs raise the file limit in the engine.

1.0.0-rc2
  • Offset Hud Icons have been fixed thanks to an addition made by Lafiel to his script at my request.
  • Known Issues:
    • Mjn's Mainhalls have too many files and cause FSO to error out when combined with the other mods in this pack. As Mjn's Mainhalls are only used for the Aquitane mainhall in the FS Blue campaign,
      I am leaving Mjn's Mainhalls out of the pack until either the number of files in it are reduced or the FSO devs raise the file limit in the engine.

1.0.0-rc1
  • Initial Release Candidate
  • Known Issues:
    • Some ships have their hud icons offset from the actual ship itself. A fix is forthcoming.





Jaded's Derelict
v1.3.1

Derelict (https://www.hard-light.net/forums/index.php?topic=85745.0) with:
Freespace Ugrade MediaVPs
MjnMixael's Mainhalls (https://www.hard-light.net/forums/index.php?topic=96090.0)
HD Hud by Shivan Hunter (https://www.hard-light.net/forums/index.php?topic=97271.0) (modified)
Jaded's HD Radar Icons (https://www.hard-light.net/forums/index.php?topic=97340.0)
Lafiel's RadarIcon Script (https://github.com/BMagnu/FSO_Scripts)
Admiral MS' ScreenCam Script (https://www.hard-light.net/forums/index.php?topic=82173.0)

(https://fsnebula.org/static/kn_download.png) (https://fsnebula.org/mod/jds_derelict)

                   
(https://fsnebula.global.ssl.fastly.net/storage/a4/ac/627deef5a4dfd9a3b4eeca21bb1f712b18e4c114f1e4a5c9763d972a49af.png)

Change Log
Hidden Text: Show
1.3.1
  • Now requires FSO 22.0.0.
  • Mods updated:
    • Freespace Upgrade MediaVPs ~4.6.1
    • Generic Radar Icons ~1.0.0 (no in-game change)
    • Mjn's Mainhalls ~1.4.8

1.3.0
  • Realized balance is more important than things which bother me. Reverted some changes to game settings and ai from 1.2.0.

1.2.0
  • Added "Jaded's Modpacks" splash screen.
  • Now targets engine version 21.0.0 and newer in game_settings.tbl. This results in many changes (improvements?) to gameplay which you can read about here (https://wiki.hard-light.net/index.php/Ai_profiles.tbl).
    Fair warning, I haven't fully tested the campaign with this.
    • Additional changes regarding effects visibility in nebulas (requires 21.2+)
     
  • Target HD Hud for BPC 0.6.0
    • Repositions gauges to ensure fewer overlaps.
    • AxMessage Gauges are now auto-scaling to fit your resolution (1080p and up only)
    • Now using truetype fonts for hud text to improve readability.
     
  • Added hud icon for unknown "fuzzy" radar blips

1.1.0
  • Switched to HD Radar Icons - Generic. There's no need for silhouettes in both the HUD and Radar.

1.0.0
  • Gold status achieved!
  • Reverted mainhalls dependency changes from RC3 as they didn't help.
  • Changed hd mainhalls version target to <=1.4.3 due to a breaking change in 1.4.4
  • Changed HD Hud target to ~0.5.0. This will result in a more BPC-like message interface in missions.

1.0.0-rc3
  • Added all remaining mjn mainhalls as dependencies in an attempt resolve an issue with knossos claiming there is no executable available for launching the mod pack. See `known issues` below.

1.0.0-rc2
  • Added HD Aquitane main hall to appropriate missions in campaign file.

1.0.0-rc1
  • Initial Release Candidate





Jaded's Silent Threat: Reborn
v1.0.1

Silent Threat: Reborn (https://www.hard-light.net/forums/index.php?topic=59120.0) with:
Freespace Ugrade MediaVPs
Freespace Port MediaVPs
MjnMixael's Mainhalls (https://www.hard-light.net/forums/index.php?topic=96090.0)
Jaded's HD Radar Icons (https://www.hard-light.net/forums/index.php?topic=97340.0)
HD Hud by Shivan Hunter (https://www.hard-light.net/forums/index.php?topic=97271.0) (modified)
Lafiel's RadarIcon Script (https://github.com/BMagnu/FSO_Scripts)
Admiral MS' ScreenCam Script (https://www.hard-light.net/forums/index.php?topic=82173.0)

(https://fsnebula.org/static/kn_download.png) (https://fsnebula.org/mod/jds_silentthreatreborn)

                   
(https://fsnebula.global.ssl.fastly.net/storage/d3/83/e58cfe56bf4791851d45143351d027cbde9d311afc0f052bfba0a3cec086.png)

Change Log
Hidden Text: Show
1.0.1
  • Now requires FSO 22.0.0.
  • Mods updated:
    • Freespace Upgrade MediaVPs ~4.6.1
    • Freespace Port MediaVPs ~4.6.0
    • Generic Radar Icons ~1.0.0 (no in-game change)
    • Mjn's Mainhalls ~1.4.8

1.0.0
  • Initial Release.
  • Has feature parity with current Jaded's FSPort (1.3.0)




Explanation: Why Mod Packs?
Hidden Text: Show
I currently have two modder's resources in the asset release forum. Both are also on Knossos. The way I prefer these resources be used is to be included as a dependency in mods via Knossos. This allows updates to the resources i have released to be easily (though not necessarily automatically) propagated to mods using them. This is different from how modder's resources have been used in the past where they were directly included as a part of the mod. Much could be written about the pros and cons of each approach. I don't especially discourage mod makers from using the old approach but I like my way and think the pros outweigh the cons.

That said, there are still cons. And Knossos in it's current form has some... quirks. Among them being a troubled dependency resolution system. To alleviate this I don't specify exact versions/packages of dependencies in modder's resources I upload to Nebula unless absolutely necessary... which in turn means that trying to run the modder resources I've uploaded directly from Knossos doesn't really work. So what happens when someone wants to try out HD Hud Mk2? Well... they can't... not without making their own mod that depends on it.

On top of that, many of these modder's resources start out as solutions to problems found in existing mods... a better hud for FS2 that works in BluePlanet Complete... radar icons that account for craft added in a new campaign. Etc. These mods I'm essentially patching are already released and often no longer in development... so my modder's resources aren't going to get included in them any time soon. So how do I get these "mod patches" to end users?

The solution is mod packs... mods that add nothing new but use dependencies to combine mods together in a single pack which can be launched from Knossos.
Title: Re: Jaded's ModPacks
Post by: praseodym on February 15, 2021, 12:06:55 pm
Instantly klicked on "Install", it tells me that "FSO" is missing. Which is not.

Ideas?
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on February 15, 2021, 04:08:41 pm
Which mod pack are you installing? FSPort?
Title: Re: Jaded's ModPacks
Post by: praseodym on February 16, 2021, 11:52:08 am
BPComplete and Derelict. Both of those regular mods are already installed, so are all mediavps.
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on February 16, 2021, 12:18:37 pm
Somehow, the version of FSO the packs were pinned to had been changed to the newest nightly. I'm guessing you have your stability setting in Knossos set to the default... which is RC (Release Candidate). 100% sure I had them set to a release candidate before... but here we are.

I've changed the FSO dependency settings for those two to target FSO 21.0.0 and re-uploaded the metadata. If you refresh your Knossos mod list/restart Knossos it should be possible for you to download them now.
Title: Re: Jaded's ModPacks
Post by: praseodym on February 17, 2021, 11:11:01 am
Now it tells me that HD Radar Icons are missing. Teste with BP only
Title: Re: Jaded's ModPacks
Post by: praseodym on February 21, 2021, 11:48:42 am
Debug Log:

https://fsnebula.org/log/60329cbed42c7b84b2d7bf58
Title: Re: Jaded's ModPacks
Post by: meppycola on March 02, 2021, 06:35:27 pm
yeah, it's telling me the same thing, can't play the mod cause it crashes, cause of hd icons
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on March 10, 2021, 03:23:45 pm
Sorry about the slow response. Valheim got its claws into me pretty good.

This issue was a bug in a recent release of the radar icons script resulting from changes Lafiel made at my request (whoops). It was actually fixed over a week ago now. You should only have to update the Radaricons Script mod in Knossos and the modpacks should automatically switch to using the fixed version.

Hope that helps. And, if not, let me know. I'll make a point to keep a closer eye on this thread from here on.
Title: Re: Jaded's ModPacks
Post by: SandyKcaz on March 11, 2021, 11:40:10 am
When I try launching your mod collection from Knossos, it says there is no executable found for this mod. What would I need to do to get this to work? Thx.
Title: Re: Jaded's ModPacks
Post by: praseodym on March 11, 2021, 02:47:50 pm
Choose "MOD default" in the settings
Title: Re: Jaded's ModPacks
Post by: SandyKcaz on March 12, 2021, 04:02:03 am
Choose "MOD default" in the settings
I checked the FSO settings and its on Mod default... Still no executable found.
Title: Re: Jaded's ModPacks
Post by: praseodym on March 12, 2021, 11:53:26 am
Then chose 21
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on March 12, 2021, 12:34:30 pm
When I try launching your mod collection from Knossos, it says there is no executable found for this mod. What would I need to do to get this to work? Thx.

This looks like a bug in Knossos that I have unwittingly stepped in. Apparently, MJN's Mainhalls must be fully installed even if you only need one mainhall. At least, that's the information I was able to find on the subject. Why that would create this specific error is beyond me. And this one is a bit difficult for me to test.

I'll change the dependencies on the mod in the next release candidate. For now, manually selecting FSO 21.0 should fix the issue.
Title: Re: Jaded's ModPacks
Post by: praseodym on March 13, 2021, 04:52:27 am
No, not here, still that error message. I also reinstalled BP from that modpack and installed all released HD radar icons separately. No effect
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on March 16, 2021, 08:27:02 am
Hmm... okay just to be entirely certain. From the mod page in knossos for the pack in question you went `Options` > `FSO Settings`  and set the `FSO Build` to `FSO 21.0.0`? And it still says no executable?

If so, could you go into knossos' settings, expand the `Knossos` section, change your `prefered engine stability` to `nightlies`, check `show engine builds in mod list`, save the settings, and then look for the "FSO" mod and install the latest version of that. Then see if it works? It shouldn't be requiring a nightly build but... knossos is a bit fickle about stuff. I may need to manually edit the mod.json for the next release candidate. This should tell me if that's the case.
Title: Re: Jaded's ModPacks
Post by: teejaycrunk on March 31, 2021, 07:12:30 pm
When I try launching your mod collection from Knossos, it says there is no executable found for this mod. What would I need to do to get this to work? Thx.

i was here looking for answers to this question as well, im having the same exact issue
Title: Re: Jaded's ModPacks
Post by: teejaycrunk on March 31, 2021, 07:19:38 pm
Hmm... okay just to be entirely certain. From the mod page in knossos for the pack in question you went `Options` > `FSO Settings`  and set the `FSO Build` to `FSO 21.0.0`? And it still says no executable?

If so, could you go into knossos' settings, expand the `Knossos` section, change your `prefered engine stability` to `nightlies`, check `show engine builds in mod list`, save the settings, and then look for the "FSO" mod and install the latest version of that. Then see if it works? It shouldn't be requiring a nightly build but... knossos is a bit fickle about stuff. I may need to manually edit the mod.json for the next release candidate. This should tell me if that's the case.

i tried all this, and still has no executable error, these were my settings like you recommended, feel free to message me, i can give  you my email there if you would like me to send any logs over or want me to check it, i can get on every evening just about.

(https://cdn.discordapp.com/attachments/782789739517444137/826973761008828466/unknown.png)
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on April 03, 2021, 08:31:58 pm
Okay. Just to be clear, that's not the location I'm talking about when I say "set the FSO version for the modpack to 21.0."  That one is for general defaults. It's not specific to any one mod. Here, this is what I was talking about...

(https://annapuma.scrapironcity.net/image/guide_to_fso_version_in_knossos.png)

Hidden Text: Show
This info is outdated. The above should fix the issue.

Also, in regards to allowing nightlies and show engine builds (and only necessary if you are doing that)... With that done, make sure you also update FSO as per:

(https://annapuma.scrapironcity.net/image/guide_to_fso_version_in_knossos-b.png)

If neither of these are solving the problem then, frankly, I'm at a loss. I'd suggest seeking help from #knossos on discord (https://discord.gg/tBPtjV5a8j) or the official knossos thread (https://www.hard-light.net/forums/index.php?topic=94068.0) on these forums. I'd be very interested in the solution they come up with.

Title: Re: Jaded's ModPacks
Post by: teejaycrunk on April 05, 2021, 03:54:10 pm


Quote
If neither of these are solving the problem then, frankly, I'm at a loss. I'd suggest seeking help from #knossos on discord (https://discord.gg/tBPtjV5a8j) or the official knossos thread (https://www.hard-light.net/forums/index.php?topic=94068.0) on these forums. I'd be very interested in the solution they come up with.


so going through and reinstalling the mod and ALL of the extras with it even if they have already been installed, i was able to run the freespace2 campaign with the updated visuals, and great job man, now im having issues with this on the blue planet complete. i made sure to install ALL of the files that were available for this install. and i havnt played yet, im just worried about issues. and if this is normal or if i should be informing the mods for blue planet about the issue to possibly get help if its needed.
(https://cdn.discordapp.com/attachments/782789739517444137/828733538684633128/unknown.png)



 i really appreciate your work with the mods, i wish i was able to do these things as well. i think it would be fun to tinker with
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on April 07, 2021, 10:33:22 am

so going through and reinstalling the mod and ALL of the extras with it even if they have already been installed, i was able to run the freespace2 campaign with the updated visuals, and great job man, now im having issues with this on the blue planet complete. i made sure to install ALL of the files that were available for this install. and i havnt played yet, im just worried about issues. and if this is normal or if i should be informing the mods for blue planet about the issue to possibly get help if its needed.
(https://cdn.discordapp.com/attachments/782789739517444137/828733538684633128/unknown.png)

i really appreciate your work with the mods, i wish i was able to do these things as well. i think it would be fun to tinker with

Hmm, that error usually means something isn't correctly installed. Like an installation partially failed. That's probably not a problem with blueplanet itself, so either my modpack or Knossos is going to be responsible.

Could you run the game in fast debug and then post a log for me? Fast Debug and the option to post a log can be found under the mods `Options` button in `Details`. Similar to the `FSO Settings` above. This should give me a complete list of what files it's failing to find and help me narrow down the source of the problem. Just run the game in fast debug until you get that error then exit and upload the log... then copy the link to me here so i can see it.
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on April 07, 2021, 01:53:51 pm
Hmm, that error usually means something isn't correctly installed. Like an installation partially failed. That's probably not a problem with blueplanet itself, so either my modpack or Knossos is going to be responsible.

Could you run the game in fast debug and then post a log for me? Fast Debug and the option to post a log can be found under the mods `Options` button in `Details`. Similar to the `FSO Settings` above. This should give me a complete list of what files it's failing to find and help me narrow down the source of the problem. Just run the game in fast debug until you get that error then exit and upload the log... then copy the link to me here so i can see it.

Looks like I was wrong... this actually IS an issue in Blueplannet Complete based on info teejaycrunk gave me in discord. There's been a recent change in FSO (https://github.com/scp-fs2open/fs2open.github.com/issues/3292) that affects how sound tables are parsed. It seems the formatting of the BluePlannet Complete sound tables runs afoul of this change.

BPC already has a fix coming down the pipe... i'll release another RC with that version of BPC soon. If you can't wait, make sure you are playing the BluePlanet Complete modpack on 21.0.0 as per here (https://www.hard-light.net/forums/index.php?topic=97350.msg1909089#msg1909089).
Title: Re: Jaded's ModPacks
Post by: eldarion on August 06, 2021, 12:56:44 pm
I really apreciate the work you are doing but i am getting the following:

 
When I try launching your mod collection from Knossos, it says there is no executable found for this mod. What would I need to do to get this to work? Thx.

This looks like a bug in Knossos that I have unwittingly stepped in. Apparently, MJN's Mainhalls must be fully installed even if you only need one mainhall. At least, that's the information I was able to find on the subject. Why that would create this specific error is beyond me. And this one is a bit difficult for me to test.

I'll change the dependencies on the mod in the next release candidate. For now, manually selecting FSO 21.0 should fix the issue.

". Apparently, MJN's Mainhalls must be fully installed"
Jesus.... this is everything that is wrong with Knossos. Please come back wxLauncher!

By the way, i faced this very same problem. It's the same if you try to install 4K Hud, for instance. I had to download Gb of data only for that!

Title: Re: Jaded's ModPacks (1.0.0 GOLD!)
Post by: jadeddragoon on August 09, 2021, 03:33:44 pm
Hey guys! Good news. I've been watching for bug reports from these mods for a while now and I'm hearing nothing that can't be traced to knossos bugs. As such I've decided to make the current RCs into the first gold release of my modpacks... with one exception.

The Blue Planet Complete modpack remains in RC status due to it still missing the hd mainhall mod. There's a whole thing behind this, but the good news is it's almost been worked out and the BPC modpack should go gold soon as well. All I'm waiting for is MVPS to update to depend on the 1.4.4 version of the mainhalls mod. Then I'll be able to include them and make one last RC for that modpack. I was originally planning to release the Gold version of the BPC mod without the hd mainhalls... but since we are so close I'm going to go ahead and do so. If I don't get any bug reports it should go gold as well not long after.

Please, if you spot any bugs, don't hesitate to let me know.
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on August 09, 2021, 03:39:27 pm
I really apreciate the work you are doing but i am getting the following:

 
When I try launching your mod collection from Knossos, it says there is no executable found for this mod. What would I need to do to get this to work? Thx.

This looks like a bug in Knossos that I have unwittingly stepped in. Apparently, MJN's Mainhalls must be fully installed even if you only need one mainhall. At least, that's the information I was able to find on the subject. Why that would create this specific error is beyond me. And this one is a bit difficult for me to test.

I'll change the dependencies on the mod in the next release candidate. For now, manually selecting FSO 21.0 should fix the issue.

". Apparently, MJN's Mainhalls must be fully installed"
Jesus.... this is everything that is wrong with Knossos. Please come back wxLauncher!

By the way, i faced this very same problem. It's the same if you try to install 4K Hud, for instance. I had to download Gb of data only for that!



This turned out to be an intermittent Knossos bug. In practice it seems the mainhalls do not need to be fully installed. The actual solution can be found here (https://www.hard-light.net/forums/index.php?topic=97350.msg1909089#msg1909089). Simply select an FSO build from the list. The 1.0.0 version of the mods are tested with 21.2.0... but 21.4.0-RC1 should work just fine as well.

As for going back to wxLauncher... that would be a huge blow to the community. For all of Knossos's flaws it's dependency management system is something this community has desperately needed for decades... almost since the start. The only reason I decided to de-lurk was when I discoved someone had finally made something like Knossos. And with the complete re-write of Knossos months if not weeks from public beta... moving back to wxLauncher now would be a huge mistake.

In any case, glad you're enjoying the mod packs. :-) I'm planning to release several more for other famous campaigns. But only once I've got these four to the point I want them.
Title: Re: Jaded's ModPacks
Post by: EatThePath on August 09, 2021, 04:51:32 pm
and anyway, you can still manually download packages from Nebula with a browser one at a time if you want...
Title: Re: Jaded's ModPacks
Post by: eldarion on September 21, 2021, 01:37:20 pm
I really apreciate the work you are doing but i am getting the following:

 
When I try launching your mod collection from Knossos, it says there is no executable found for this mod. What would I need to do to get this to work? Thx.

This looks like a bug in Knossos that I have unwittingly stepped in. Apparently, MJN's Mainhalls must be fully installed even if you only need one mainhall. At least, that's the information I was able to find on the subject. Why that would create this specific error is beyond me. And this one is a bit difficult for me to test.

I'll change the dependencies on the mod in the next release candidate. For now, manually selecting FSO 21.0 should fix the issue.

". Apparently, MJN's Mainhalls must be fully installed"
Jesus.... this is everything that is wrong with Knossos. Please come back wxLauncher!

By the way, i faced this very same problem. It's the same if you try to install 4K Hud, for instance. I had to download Gb of data only for that!



This turned out to be an intermittent Knossos bug. In practice it seems the mainhalls do not need to be fully installed. The actual solution can be found here (https://www.hard-light.net/forums/index.php?topic=97350.msg1909089#msg1909089). Simply select an FSO build from the list. The 1.0.0 version of the mods are tested with 21.2.0... but 21.4.0-RC1 should work just fine as well.

As for going back to wxLauncher... that would be a huge blow to the community. For all of Knossos's flaws it's dependency management system is something this community has desperately needed for decades... almost since the start. The only reason I decided to de-lurk was when I discoved someone had finally made something like Knossos. And with the complete re-write of Knossos months if not weeks from public beta... moving back to wxLauncher now would be a huge mistake.

In any case, glad you're enjoying the mod packs. :-) I'm planning to release several more for other famous campaigns. But only once I've got these four to the point I want them.

Sorry for the (really) late response, jadeddragoon.

I eventually end up downloading every mod that i need manually, manage the packages myself and have various batch scripts for launching the various campaigns. I'm a bit of a control freak and now that i understand who it works, i prefer it this way.
 
Sorry about the little rant about Knossos. It's a great tool if you just want a Steam like interface for quick download and play the mods (and have spare disk space to do so).  And i have a sweet spot for the framework that was used to develop it (qt), so, it's great to see that. As a software developer myself, i know how hard is to maintain something like that.  Going back to wxLauncher is realistically not doable, i understand that.   
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on September 26, 2021, 10:01:37 pm

Sorry for the (really) late response, jadeddragoon.

I eventually end up downloading every mod that i need manually, manage the packages myself and have various batch scripts for launching the various campaigns. I'm a bit of a control freak and now that i understand who it works, i prefer it this way.
 
Sorry about the little rant about Knossos. It's a great tool if you just want a Steam like interface for quick download and play the mods (and have spare disk space to do so).  And i have a sweet spot for the framework that was used to develop it (qt), so, it's great to see that. As a software developer myself, i know how hard is to maintain something like that.  Going back to wxLauncher is realistically not doable, i understand that.   


Absolutely nothing to apologize for! If anything I should. I'm a huge Knossos evangelist and technically have been since before Knossos was even a thing. I've always felt like this community needed something like Knossos. And now that it's here I can't help but be excited for it. So i'm sorry if I came across as upset. I wasn't... I'm just very hopeful for what Knossos can mean for the community from a systemic perspective.

Of course, not everyone is having a good experience with it. And the reasons why are many. Most are Knossos' own fault. Really hoping nu-knossos can address most of those issues. And there are, as you indicate, personal preference reasons some might have to prefer another approach. There's really nothing wrong with that.

Again, sorry if I came across as harsh. Wasn't my intention.
Title: Re: Jaded's ModPacks
Post by: Amakesh on November 08, 2021, 07:26:47 am
If i try to install, i get an error "I'm sorry but you won't be able to install "Jaded's Blueplanet" because "FSO" is missing!"
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on November 08, 2021, 11:54:30 am
Wait, cant install? I'll look into this when i get home.
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on November 08, 2021, 12:39:38 pm
If i try to install, i get an error "I'm sorry but you won't be able to install "Jaded's Blueplanet" because "FSO" is missing!"

Could you go into knossos settings  > Knossos > and make sure you have "Show Engine Builds In Mod List" checked and click save. Then, under the Explore tab, find "FSO", click Details, and select "21.2.0" from the drop down at the upper left. You should either see a blue "Update" or a blue "Install" button.

Please let me know which one it shows for you. And if it shows the install button go ahead and install FSO 21.2.0, that should resolve your issue.

VISUAL WALKTHROUGH:
Hidden Text: Visual Walkthrough • Show
(https://annapuma.scrapironcity.net/image/guide_to_fso_install_older_versions.png)

The current release of Blueplanet does not work on FSO 21.4.0, so 21.0.0 is required instead. Jaded's BPC enforces this restriction and, apparently, knossos doesn't handle that well.
Title: Re: Jaded's ModPacks
Post by: Amakesh on November 09, 2021, 07:30:22 pm
If i try to install, i get an error "I'm sorry but you won't be able to install "Jaded's Blueplanet" because "FSO" is missing!"

Could you go into knossos settings  > Knossos > and make sure you have "Show Engine Builds In Mod List" checked and click save. Then, under the Explore tab, find "FSO", click Details, and select "21.2.0" from the drop down at the upper left. You should either see a blue "Update" or a blue "Install" button.

Please let me know which one it shows for you. And if it shows the install button go ahead and install FSO 21.2.0, that should resolve your issue.

VISUAL WALKTHROUGH:
Hidden Text: Visual Walkthrough • Show
(https://annapuma.scrapironcity.net/image/guide_to_fso_install_older_versions.png)

The current release of Blueplanet does not work on FSO 21.4.0, so 21.2.0 is required instead. Jaded's BPC enforces this restriction and, apparently, knossos doesn't handle that well.

Ok, I installed FSO 21.2.0, but it does not helped. Error persists. Even if i go to home->FSO->details and choose version 21.2.0 there is no option to save changes or something like that, so if i go back to home it automatically changes the FSO version back to newest..
Title: Re: Jaded's ModPacks
Post by: Xantosh on November 22, 2021, 08:11:59 pm
1st of all, thanks for compiling these mods so far all the comments on here have helped fixed any issues that have cropped up except for one, in FSP playing the original Descent Freespace campaign i get no narrative voices or briefing voices (i can use the auto tts built into Knossos but that only applies to mission briefings!
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on December 08, 2021, 10:48:10 am
1st of all, thanks for compiling these mods so far all the comments on here have helped fixed any issues that have cropped up except for one, in FSP playing the original Descent Freespace campaign i get no narrative voices or briefing voices (i can use the auto tts built into Knossos but that only applies to mission briefings!

Make sure you have the "stu" package from Freespace Port MediaVPs installed. Knossos sometimes leaves off required packages and that package, i believe, is the one for voices.

Glad everything else is working for you.  :)

If i try to install, i get an error "I'm sorry but you won't be able to install "Jaded's Blueplanet" because "FSO" is missing!"

Could you go into knossos settings  > Knossos > and make sure you have "Show Engine Builds In Mod List" checked and click save. Then, under the Explore tab, find "FSO", click Details, and select "21.2.0" from the drop down at the upper left. You should either see a blue "Update" or a blue "Install" button.

Please let me know which one it shows for you. And if it shows the install button go ahead and install FSO 21.2.0, that should resolve your issue.

VISUAL WALKTHROUGH:
Hidden Text: Visual Walkthrough • Show
(https://annapuma.scrapironcity.net/image/guide_to_fso_install_older_versions.png)

The current release of Blueplanet does not work on FSO 21.4.0, so 21.2.0 is required instead. Jaded's BPC enforces this restriction and, apparently, knossos doesn't handle that well.

Ok, I installed FSO 21.2.0, but it does not helped. Error persists. Even if i go to home->FSO->details and choose version 21.2.0 there is no option to save changes or something like that, so if i go back to home it automatically changes the FSO version back to newest..

I have released an update for the BPC ModPack that should fix this for you. Apparently knossos has yet another bug and I was relying on it not to. Should have tested it better. Just make sure to set the build version for BPC to 21.2 after installing it.
Title: Re: Jaded's ModPacks
Post by: BlackViper on April 24, 2022, 02:45:02 pm
Sorry for necroing the thread, couldn't find answer anywhere else though. I am trying to run your modpack for FS1. Your solution for that "no executable was found" is to choose FSO 21.0.0, but I have apparently installed only 22.0.0 (going by the bin folder) because Knossos downloaded it for me. If I download 21.0.0 and put it in the same folder as 22.0.0, still can't choose FSO 21 in FSO settings. Please help - do I need to put it in another folder? Because as you can't see, I can't really choose anything in FSO settings.

(https://i.imgur.com/4O2cgSe.png)

(https://i.imgur.com/vSOY4sc.png)
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on May 01, 2022, 10:48:31 am
Hey BlackViper, sorry you're having so much trouble with this. Hopefully these issues will be history sooner rather than later.

First off, Jaded's FSPort _should_ run with 22.0.0. I'm not really sure why knossos is saying it doesn't for you. I've checked the metadata on the mod and it's set to use any version of FSO equal to or newer than 21.0, which one would think would include 22.0.

Since Knossos isn't doing what make sense you can try installing 21.0... but you can't simply download 21.0 from another source and place it in the same folder. However, you can follow the guide I posted here (https://www.hard-light.net/forums/index.php?topic=97350.msg1912131#msg1912131) (in the hidden block). This will allow you to use knossos itself to grab a copy of 21.0 and install it with the correct metadata and everything knossos needs to use it. Hopefully then 21.0 will show up in FSO options for you.

Hope that fixes the issue for you.
Title: Re: Jaded's ModPacks
Post by: BlackViper on May 01, 2022, 12:22:49 pm
Thank you so much for the answer! That solved error about "executable not found", not I am getting this:

(https://i.imgur.com/R62yLsA.png)

I've tried to setting FSO to 21.2 in options for FSPort too, but same error.  :confused:
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on May 02, 2022, 10:37:02 am
Yet another knossos bug, I'm afraid. In this case it failed to grab one of the individual package dependencies from FSPort. And then the error message is misleading.

Short version? Each mod has multiple packages, some of which are optional. Jaded's FSPort requires some of these optional packages from FSPort. Because the dependency chain is so complex for Jaded's FSPort Knossos sometimes gets confused and doesn't grab the needed optional packages from FSPort. And then Knossos reports this as all of FSPort being missing... even when it clearly isn't.

To solve this you can go to FSPort in your mod list and click details, then options, then modify. Make sure the "warble" and "stu" optional packages are check marked. Then click okay and it should install them.

The rebuilt version of Knossos that NGLD is working on isn't quite ready for a public release but it's close. All signs indicate these kinds of problems will be a thing of the past when it's ready.

Let me know if you run into any further problems.
Title: Re: Jaded's ModPacks
Post by: BlackViper on May 02, 2022, 11:05:44 am
Well, error has changed (even though packages warble and stu were checked), now I am getting "requires FreeSpace Upgrade Media VPs".. Which I have, verison 4.5.1, all Mainhalls, GOTY, FSO 22 are checked. And in Media VPs only compatibility, radar icons, advanced, animglow and cutscenes are not.
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on May 02, 2022, 04:06:15 pm
These are the required packages from FSU MVPs (other than the greyed out ones).

MV_Music
MV_CB_ANI_1
MV_CB_ANI_2
MV_CB_ANI_3

Jaded's FSPort currently uses FSU MVPs 4.4.x. When you go to click modify for FSU MVPs make sure the dropdown in the top left is the most recent 4.4.x version you have installed (and not 4.5.x) so you are modifying packages for the correct version.
Title: Re: Jaded's ModPacks
Post by: BlackViper on May 03, 2022, 01:23:30 pm
So I've installed those in FSU MVPs for 4.4.2, but I am getting the same error.  Is it possible I have to somehow force the FSU MVPs to stay in 4.4.2? Because when I go back to home page and try to run your FSport, FSU MVPs reverts to 4.4.5.? Uninstall it?

https://imgur.com/a/PxcYiBK
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on May 03, 2022, 07:42:48 pm
Hmm, based on your screenshots it should be working. Knossos will automatically select 4.4.2 when you launch Jaded's FSPort, regardless of what it says in the details page for FSU MVPs.

I'm afraid I'm not sure why it would still be having this issue. You might try asking in #knossos on discord or in the knossos thread (https://www.hard-light.net/forums/index.php?topic=94068.0) here on the forums.
Title: Re: Jaded's ModPacks
Post by: BlackViper on May 04, 2022, 02:46:20 pm
Will do. I am having the same errors when trying to run your ST:R, but weirdly your Derelict and FS2 works.

https://i.imgur.com/HHsWhhG.png
Title: Re: Jaded's ModPacks
Post by: gordon591 on July 21, 2022, 04:14:11 pm
Whenever I attempt to download Jaded's Silent Threat Reborn via Knossos, I get the error "A critical error occurred" and the mod is not downloaded. I can download all other Jaded mods via Knossos without issue.

(https://f000.backblazeb2.com/file/a23107-uploads/knossos_error.jpg)
Title: Re: Jaded's ModPacks
Post by: jadeddragoon on August 06, 2022, 07:05:22 pm
Whenever I attempt to download Jaded's Silent Threat Reborn via Knossos, I get the error "A critical error occurred" and the mod is not downloaded. I can download all other Jaded mods via Knossos without issue.

(https://f000.backblazeb2.com/file/a23107-uploads/knossos_error.jpg)

This is now fixed. I'm sorry about the long delay. I didn't see this post until recently. :-(

It was a mistake on my part. I still had Jaded's STR depending on an old version of STR that wanted the older MVPs. Once that was corrected everything worked again.
Title: Re: Jaded's ModPacks
Post by: Knecht Ruprecht on November 11, 2022, 11:38:10 am
Thanks for your modpacks! Really enjoing the upgraded experience, especially the HUD icons. There has been a new release for BP, (upgrading to the newest MediaVPs, among other stuff). Do you have plans to upgrade your mod pack, too? I have been fiddling around with the mod.json, trying to do it myself, but I somehow can't get it to work (Knossos still shows the old MVPs as installed for your modpack). Thanks again for your work!
Title: Re: Jaded's ModPacks
Post by: -Joshua- on November 14, 2022, 04:48:32 am
Heya, just letting you know Blue Planet Complete got a fairly big update recently.