Author Topic: (Another) Crash Issue  (Read 2152 times)

0 Members and 1 Guest are viewing this topic.

(Another) Crash Issue
I just finished Delenda Est, but when I try to go to the next mission I get the load screen, and then it crashes with this error message:

Malloc Failed!

ntdll.dll! NtWaitForSingleObject + 12 bytes
KERNELBASE.dll! WaitForSingleObject + 18 bytes
fs2_open_3_6_19_SSE-20130406_r9622.exe! <no symbol>
fs2_open_3_6_19_SSE-20130406_r9622.exe! <no symbol>
fs2_open_3_6_19_SSE-20130406_r9622.exe! <no symbol>
fs2_open_3_6_19_SSE-20130406_r9622.exe! <no symbol>
ntdll.dll! wcsncpy + 4 bytes
ntdll.dll! wcsncpy + 4 bytes

I previously had a graphics card issue which was resolved with the compatibility package, the error message I got then looks a lot like the one now.  I tired with a debug build,  but I'm not sure if my log is going to show anything useful since the mission didn't even start.  It's attached anyways though.  I'm at a total loss for what to do, any help would be much appreciated.

Edit: forgot to attach the log.  Oops.  Fixed.

[attachment deleted by ninja]
« Last Edit: April 13, 2013, 09:14:22 pm by Sharkfinn »

 

Offline niffiwan

  • 211
  • Eluder Class
Re: (Another) Crash Issue
I tired with a debug build,  but I'm not sure if my log is going to show anything useful since the mission didn't even start.  It's attached anyways though.

Um, that log? :D Haha - oops, too soon on the reply!

Also, from the "Malloc failed" message, you might have a corrupted pilot file.  There was a bug in earlier versions of BP that could cause this, it's been fixed in more recent versions.  Luckily for you, you're almost at the end of Act2, so you can just play the last mission from the mission simulator - press "ctrl-alt-s" from there and you can see/play all missions in the campaign.  However, to continue with Act3 you should probably upgrade to the most recent BP executable (see the stickied compatibility thread" and create a new pilot.

Anyway, regardless of all that, a log will confirm if I'm on the right track here or not.

Edit:

Are you sure that's the correct log?  It doesn't show blueplanet2 being used as a mod?
Code: [Select]
FreeSpace 2 Open version: 3.6.17.9481
Passed cmdline options:
  -mod blueplanet,mediavps_3612

Anyway, the FSO version you have does contain that bug I was talking about, so you should follow the steps I outlined above:
1) play the last mission from the techroom with ctrl-alt-s
2) update to a newer BP build
3) create a new pilot for BP2 Act3
« Last Edit: April 13, 2013, 09:21:46 pm by niffiwan »
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: (Another) Crash Issue
Ok, I'll try that, thanks.  When I create a new pilot, is there any way I don't have to play through Acts I and II again?

 

Offline niffiwan

  • 211
  • Eluder Class
Re: (Another) Crash Issue
Yes, act1 and act2 are in the same campaign (BP2 part 1).  Act3 is a new campaign (BP2 part 2), so you can just start playing from there.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: (Another) Crash Issue
Great, I can do that, thanks.  The build I'm running is a nightly from last week, which I downloaded after the link in the compatibility thread.

Edit: that's the log I got form my /data folder, the last time I made a log I did it for AoA.  The mission didn't even open this time, so I'm not sure it would have even created a log.

Edit 2: I've created a new pilot file and tried to run it in the techroom, but I get the same thing.  Debug log attached, hopefully this one is more helpful.

Edit 3: With the new pilot file, I get the same crash even with the part two campaign.

[attachment deleted by ninja]
« Last Edit: April 13, 2013, 09:37:01 pm by Sharkfinn »

 

Offline niffiwan

  • 211
  • Eluder Class
Re: (Another) Crash Issue
hmmm.. if your build is a recent nightly, it should have fixed the problem I was thinking of, so my instructions are probably not relevant. If you can find the most recent fs2_open.log you created, it would be helpful.  If you run with the current debug executable, it will create a log even if it crashes on entering the mission.  i.e. if the 1st blueplanet2 splashscreen is displayed then a log will have been created.

OK - that's malloc error is a new one to me, it's definitely not the problem I was originally thinking of (sorry!)
« Last Edit: April 13, 2013, 09:42:58 pm by niffiwan »
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: (Another) Crash Issue
Try taking your FS2 CD out of the E drive.

 
Re: (Another) Crash Issue
I took the disc out (forgot it was in there, oops), but I still have a problem.  I appear to be able to run other missions with both the old and new pilot files, but whenever I try to run "Sunglare" in either the techroom or normally I get an error, and I get an error when I try to start part 2.  The error message is different now though, but still malloc failed, it's:

Malloc Failed!

ntdll.dll! NtWaitForSingleObject + 12 bytes
KERNELBASE.dll! WaitForSingleObject + 18 bytes
fs2_open_3_6_19_SSE-20130406_r9622.exe! <no symbol>
fs2_open_3_6_19_SSE-20130406_r9622.exe! <no symbol>
ntdll.dll! RtlEnterCriticalSection + 1506 bytes
ntdll.dll! RtlEnterCriticalSection + 535 bytes
fs2_open_3_6_19_SSE-20130406_r9622.exe! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
fs2_open_3_6_19_SSE-20130406_r9622.exe! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
fs2_open_3_6_19_SSE-20130406_r9622.exe! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
fs2_open_3_6_19_SSE-20130406_r9622.exe! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
fs2_open_3_6_19_SSE-20130406_r9622.exe! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>
<no module>! <no symbol>

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: (Another) Crash Issue
Can you try with an older nightly? I'm puzzled. This is not an error that typically pops up with BP.

 
Re: (Another) Crash Issue
I'll go grab a nightly from about month ago and try that, if that's old enough.

Edit: I downloaded a build from about a month ago, but the new pilot file I made is gone and when I even try to select a Blue Planet campaign the game crashes instantly.
« Last Edit: April 13, 2013, 10:05:14 pm by Sharkfinn »

 
Re: (Another) Crash Issue
Sorry for the double post, but this was a totally new development.

I've found that with the new pilot file I can load the missions after Icarus from the techroom, but Icarus in part two or Sunglare in part one just goes to the load screen and crashes, in the way previously described.  To me this is suggesting some problem with the Sunglare and Icarus missions themselves and not some larger issue, could that be the case?

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: (Another) Crash Issue
If there is an issue, it's with the way the builds are handling those missions, since the missions themselves are fine.

 
Re: (Another) Crash Issue
Just wanted to make sure I hadn't goofed them up somehow.  So far I've tried the 3.6.17 that came with BP, which has never worked and I stopped using when I downloaded the compatibility pack, 3.6.18, which has also never worked, and the two 3.6.19 nightlys, the newer of which is the one that I've been using and that's been working.  I'm surprised that it's acting up at this point, and on only two missions.  And I was pissed after Delenda Est, I was fired up for revenge, it came at a really bad time. 

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: (Another) Crash Issue
Try deleting the advanced visual VPs if you have low-end GPU hardware?

 

Offline niffiwan

  • 211
  • Eluder Class
Re: (Another) Crash Issue
And yeah, I've just successfully tested Sunglare & Icarus (on Linux) with the compatibility package and a svn version 9625 executable.  So I really don't know what's going on unfortunately  :(

Could you post debug log from both Sunglare and Icarus when it crashes?  I'm wondering if both missions are crashing in the same place or not.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: (Another) Crash Issue
Sorry I've been awhile, I went to bed last night and was fairly busy today.  Anyways, getting rid of the advanced visuals VP didn't help, the same thing happened.  I made logs for both Sunglare and Icarus, they're attached.

[attachment deleted by ninja]

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: (Another) Crash Issue
That log has a bunch of advanced visual VPs in it...

 
Re: (Another) Crash Issue
I put it back in once I found it wasn't causing the problem, it had been working fine and as long as it wasn't the cause of the crash I figured I'd keep it in.

 

Offline General Battuta

  • Poe's Law In Action
  • 214
  • i wonder when my postcount will exceed my iq
Re: (Another) Crash Issue
I have no idea what's going on - these missions are stable and your install looks good. Keep trying earlier nightly builds, I guess.

 
Re: (Another) Crash Issue
All right, I'll try that, thanks.