Author Topic: Resolution Issue  (Read 1303 times)

0 Members and 1 Guest are viewing this topic.

Hi All,

Recently got a Samsung Odyssey G9 Monitor and using for Freespace, loving it but Blue Planet is giving me some grief!

When in settings up Blue planet if I go 'Full Screen' under Gameplay I get a message saying it cannot run under 1024 X 768 resolution. If I use 'Run in Window' it only works, but takes up about half the screen and as above, other Mods work full screen just fine. Resolution is set in Knossos as 5120 X 1440 (custom). lowest setting without custom next to it is 2560 X 1440.

Anything with custom next to it seems to dislike, natural resolution is 5120 X 1440 on this screen.

Any suggestions?

I would include attachments but Forum keeps saying upload is full, even on a 60kb file.

Ok, so up front: This is going to be somewhat hard for me to try and fix, since I can't exactly run the game in 5120x1440, but I can try to help, and I'll try to scramble people with beyond-widescreen monitors.
First of all: Please post your fs2_open.log file.  Instructions on how to do this can be found in this post. Oh, and please do this when you launch BP and run into problems, but also when you launch the MediaVPs and don't run into problems. It helps me see what may have changed.
Secondly, when you get an error in FSO like that, it copies that error directly to the clipboard. Can you paste said error into one of your posts?
« Last Edit: January 11, 2023, 05:47:43 am by Grizzly »

Hey, thanks for the reply.

Sure, link is here for a BP launch. I literally open BP, skip the cutscene, load pilot and then get the screen saying resolution is too low. If you have a discord or somewhere you'd like me to post, can do.

Please note, when I do this no actual error message pops up, its the in game background, I'd love to post it for you but the attachments function seems broken.

And here is the link for a MediaVPs launch:

Heya, thanks for the attachments you send me in PM too. It was the information I needed to track down the problem.

Sorry for not getting back to you earlier, I had a ****ty couple of days.

Anyway, please try copying these files to your bpc-core/data/tables folder, overwriting the ones already present.

Oh, incidentally, you may want to try the center_res command line flag too. Enabling a -center_res 2560x1440 flag should work for you.

Thanks, tried the files and while I saw the menu for a split second, it just crashed out - tried 3 times.

Any thoughts?

I did find a fix - I just removed the main hall files and it opens the default FS2 menu and can just jump into missions.

fuuuck I gave you the in-dev version.  :banghead: - It refers to fonts that don't exist in BP main yet.

Please revert to the original files (try 'verifying' your install on knossos). Then, try the -center_res 2560x1440 command line option. You can set this in the "Global Flags" subset of your knossos settings screen, or go to BPC, press "FSO Settings" and set it there.

Okay, I've updated the files in the link I gave you with versions build from the actual release. These should help, or you could use the center_res command line option. Or both! Both is good.

So FSO atm has a pretty weird system where it assumes that you're using a triple-screen setup once you go beyond a certain widescreen aspect ratio, and as such divides your aspect ratio to 1/3rd. In your case, this puts the aspect ratio below that of 1024x768, which is causing our mainhall configuration to bug out.

The changed files now just don't check for aspect ratio for the 1024x768 main hall at all.
That's also where the -Center_Res command line option comes in: It allows you to override that aspect ratio weirdness.