Author Topic: Diaspora in Full Screen Mode?  (Read 3917 times)

0 Members and 1 Guest are viewing this topic.

Diaspora in Full Screen Mode?
Hi friends,

congrats to this fantastic mod.

How can I start Diaspora in the Linux version in full screen mode 1280x1024? It starts in window mode only, and some HUD details are doubled on the screen or not on the screen (missile banks, subsystems of targets, etc). Also starting in 16:9 mode did not work.

Thanks in advance.

 

Offline niffiwan

  • 211
  • Eluder Class
Re: Diaspora in Full Screen Mode?
In wxlauncher, check the Advanced tab, under "Dev Tool" there should be "Run in Window".  Make sure that's not checked for starters.  I'm not sure about the doubled HUD stuff, so please create & post a fs2_open.log file :)
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 

Offline 666maslo666

  • 28
  • Artificial Neural Network
"For once you have tasted flight you will walk the earth with your eyes turned skywards, for there you have been and there you will long to return." - Leonardo da Vinci

Arguing on the internet is like running in the Special Olympics. Even if you win you are still retarded.

 
Re: Diaspora in Full Screen Mode?
Thanks for the answers. Unfortunately, compiling wxlauncher did not work. I am using YAL and window mode is deactivated there. Any hints for one of the config files?

 

Offline niffiwan

  • 211
  • Eluder Class
Re: Diaspora in Full Screen Mode?
The doubled hud is a known issue:

http://www.hard-light.net/forums/index.php?topic=83564.msg1670617

I thought that was a BluePlanet specific thing...

Thanks for the answers. Unfortunately, compiling wxlauncher did not work. I am using YAL and window mode is deactivated there. Any hints for one of the config files?

There's a file called cmdline_fso.cfg which should be either in:
a) ~/.fs2_open/data (probably in here if YAL created it)
b) <Diaspora install dir>/data

Edit that and remove "-window".  Note that if you run YAL or wxLauncher again after this, it'll overwrite the file and you'll have to remove that command line flag again.
Creating a fs2_open.log | Red Alert Bug = Hex Edit | MediaVPs 2014: Bigger HUD gauges | 32bit libs for 64bit Ubuntu
----
Debian Packages (testing/unstable): Freespace2 | wxLauncher
----
m|m: I think I'm suffering from Stockholm syndrome. Bmpman is starting to make sense and it's actually written reasonably well...

 
Re: Diaspora in Full Screen Mode?
Thanks, it the /Diaspora/data/cmdline_fso.cfg. Removing "-window" solved it.