Author Topic: FSO 19.0.0/MediaVPs 4.1.23 crash on new Ryzen 7/Radeon VII build  (Read 542 times)

0 Members and 1 Guest are viewing this topic.

Offline TheUnforgiving

  • 22
  • By my hat you will know me
    • Skype
    • Steam
FSO 19.0.0/MediaVPs 4.1.23 crash on new Ryzen 7/Radeon VII build
Issue: FSO freezes after a few seconds of displaying a MediaVPs model.  Game audio continues uninterrupted, the rest of the system is still responsive (though some graphical glitches appear on the secondary monitor), and I can move the mouse, but the game remains frozen. Windows will eventually put up the "This program is unresponsive" dialog and FSO will exit like any other frozen program.  All the MediaVPs pass a file integrity check.

Reproduce: Launch any FSO mod that uses the 4.1.23 MediaVPs (in my case, Blue Planet Complete) and enter the ship viewer in the Tech Room or launch a mission.  The game will run normally for 5-30 seconds after a ship appears and then freeze as described above.

System specs:
CPU: AMD Ryzen 7 3700X 3.6 GHz
GPU: ASRock Radeon VII 16 GB Phantom Gaming X
Motherboard: Gigabyte X570 UD ATX AM4
RAM: Corsair Vengeance LPX 16 GB (2 x 8 GB) DDR4-3200
Primary display: Dell S2719DGF 27.0" [email protected] Hz
Secondary display: LG 22BK430H-B 21.5" [email protected] Hz

OS: Windows 10 Pro 1909 (Build 18363.75)
GPU Driver:
FSO Launcher: Knossos 0.14.0
FSO Version: 19.0.0 x64 (SSE2 and AVX)

Blue Planet Complete Log:

FS2 Retail log:

FS2 MediaVPs log:

I've put together a new desktop after having been stuck with my stalwart little Asus ZenBook -- running an Intel i7-8550U and NVidia MX150 -- for over a year.  The ZenBook was completely happy with FSO; framerate would occasionally dip into the high 40s while looking at certain parts of the NTC Trinity and GTC Oberon (probably something to do with also having to render the nebula), but it ran beautifully at a solid 60 fps otherwise.  However, I wanted to continue my FSBlue campaign on the nice big 27" monitor now that I've got a GPU that can actually drive it.  I installed Freespace 2, Knossos, and Blue Planet Complete, migrated my pilot file over, fired up FSBlue where I'd left off (Proving Grounds)...and the game immediately froze.  Went into Radeon Software, turned off all the overlays, graphical overrides, and Freesync, and tried again.  Same result.  "Maybe the pilot data got borked or doesn't like changing hardware?"  Created a new pilot and started a new FSBlue campaign.  FSO crashed as soon as the instructor's Myrmidon came on screen.  "Maybe it's AVX?"  Same result on SSE2. 

It wasn't until I launched FS2 Retail with no command line flags that FSO ran normally; I was able to peruse the tech room and complete the first training mission with no problems whatsoever.  Working my way back up, I launched MediaVPs, went into the tech room and FSO froze.  Ran Knossos's file integrity check just to be sure and all the packages verified.   

I don't really know enough about how FSO works to make a guess at what's going on other than "AMD's OpenGL implementation is bad" or "My GPU and/or PSU are borked", but I have no idea if any of those are actually the problem.


Offline mjn.mixael

  • Cutscene Master
  • 212
  • Chopped liver
    • Steam
    • Twitter
Re: FSO 19.0.0/MediaVPs 4.1.23 crash on new Ryzen 7/Radeon VII build
This really looks to me like a GPU issue. Make sure the drivers are fully updated? Other than that, I'm not sure what else to offer. I'm vaguely aware that AMD doesn't play nice with OpenGL as well. That's all I've got as much as I'd like to help you.
Cutscene Upgrade Project - Mainhall Remakes - Between the Ashes
Youtube Channel - P3D Model Box
Between the Ashes is looking for committed testers, PM me for details.
Freespace Upgrade Project See what's happening.


Offline TheUnforgiving

  • 22
  • By my hat you will know me
    • Skype
    • Steam
Re: FSO 19.0.0/MediaVPs 4.1.23 crash on new Ryzen 7/Radeon VII build
Yeah, I was getting display flickering, hangs/crashes even in DirectX software.  Pretty sure the card was defective, and even if it wasn't, AMD dropped support for the Radeon VII only a few months after it released to focus on the new Navi architecture, so it wouldn't get new driver support anyway.  I RMA'd the card over the weekend and bought an EVGA 2080 Super for about the same price.  Just got done installing it ten minutes ago and I'm getting ready to put it through its paces.  Hopefully it solves the issue.