Author Topic: Silent Threat mission problem (GTI attacking Krios)  (Read 3391 times)

0 Members and 1 Guest are viewing this topic.

Offline DiabloRojo

  • 26
  • Como los chupacabras para desayuno.
    • Dienet - The Place You Go to Die (back after 5 years, baby!)
Silent Threat mission problem (GTI attacking Krios)
First I'd just like to say how happy it makes me to find out just a couple days ago that FreeSpace is alive and well after so long.. only recently did I dust off and play through both and I'm hooked again ;)  I never got Silent Threat originally, bringing me to my problem...

I tried some searches in this forum but couldn't find anything close.. though there's always a good chance I overlooked a post like "Hey DiabloRojo, here's the exact solution to your problem, ya hoser!"

I used Turey's installer (beautiful, btw) today to get everything, and all is working fine...until I got to the mission where the Krios is under attack.  When the mission starts (after the 'emergency briefing' I am completely stuck, the screen, with the exception of the HUD will go black or visible almost randomly (pressing keys like targeting seems to make this happen) All wingmen (including myself!) show as dead in the HUD, and the missions scripting continues as it should.  I can still target (but can't move or fire, etc) and I was able to enter cheats to kill enemy ships and complete the objectives, but can't warp because it never loads my ship.

I did some mission building back in '99 or so, though I never messed with missions that kept the previous mission's ships/loadouts/damage etc, but I'm guessing something with this function is the cause.  Considering I seem to be the only one experiencing this, I doubt it's the mission file, but what else could I check to see if it isn't saving/loading my previous loadout?

I installed to a clean location and copied my retail-installed FS2 pilot over to the new location to use.  That pilot was at the end of the FS2 campaign, so it loaded the final mission and it still had my loadout/etc when I initially loaded up FSOpen to check out the new visuals.  Could the pilot be the issue?  I do have a 'Rojo.SilentThreat.cs2' file in the data\player\single directory...  Also, just in case, I downloaded and replaced the mission pack, but that didn't help.  I've since replayed the previous asteroid shooting (ug) mission twice, but still have the same problem.

Thanks for any thoughts, suggestions or verbaltyped abuse!

« Last Edit: June 30, 2007, 11:35:52 pm by DiabloRojo »

 

Offline 0rph3u5

  • 211
  • Oceans rise. Empires fall.
Re: Silent Threat mission problem (GTI attacking Krios)
oh yeah... the "cool" known (to me) RA bug
(I can only theorize on what is causing it but I guess it has something to do with the loadout saved at the last red alert and now being called on (like if the mission loads a loadout from another mod with conflicting tables or there is no saved loadout to call on at all) -- mantised this mess a year back or so, but there was no time to monitor the issue; I don't recall the bug number either)

---------------------------------------------

one simple solution (for someone expericened in basics of FS modding):
get yourself VPView and search the fs_port_mission.vp for the file callled "md-09.fs2", extract it to [fsport]/data/missions (you might need to create that folder), open it up with the editor and delete the line "+Red Alert: 1" -- this will kick out the red alert and will remove the bug

If you don't dare I can supply you with the fix if you want -- just takes one minute away from me
"When you work with water, you have to know and respect it. When you labour to subdue it, you have to understand that one day it may rise up and turn all your labours into nothing. For what is water, which seeks to make all things level, which has no taste or colour of its own, but a liquid form of Nothing?" - Graham Swift, Waterland

==================

"I am Curiosity, and I've always wondered what would become of you, here at the end of the world." - The Guide/The Curious Other, Othercide

"As you sought to steal a kingdom for yourself, so must you do again, a thousand times over. For a theft, a true theft, must be practiced to be earned." - The terms of Nyrissa's curse, Pathfinder: Kingmaker

"...because they are not Dragons."

 

Offline DiabloRojo

  • 26
  • Como los chupacabras para desayuno.
    • Dienet - The Place You Go to Die (back after 5 years, baby!)
Re: Silent Threat mission problem (GTI attacking Krios)
Beautiful, worked like a charm, thanks!

What a funky bug...

Only thing I can guess at is that it's trying to load an Erynies with Kaysers which doesn't exist in FSPort, since that's the last redalert my pilot went through.  Fun stuff!

 

Offline matthew

  • 20
Re: Silent Threat mission problem (GTI attacking Krios)
So when I open the FRED editor, where do I find the red alert line?

 

Offline Snail

  • SC 5
  • 214
  • Posts: ☂
Re: Silent Threat mission problem (GTI attacking Krios)
Shift + N, uncheck 'Red Alert'

  

Offline colecampbell666

  • I See Dead Pictures
  • 212
  • Evolution and ascension.
Re: Silent Threat mission problem (GTI attacking Krios)
:welcomepurple:
matthew!
Gettin' back to dodgin' lasers.