Author Topic: GT Advanced Amazon Drone  (Read 819 times)

0 Members and 1 Guest are viewing this topic.

GT Advanced Amazon Drone
I've returned to Freespace after a LONG absence. I have exactly one goal. Play through the Freespace series. I have a clean install of FS2. Let me walk you through the saga of nonsense I have endured. To begin I tried using Freespace Open installer. This was a mistake. It had all kinds of errors, and couldn't download a handful of files. I had selected the Silent Threat and Freespace Port options along with the standard media vps etc. Naturally the game launched with the 72 errors detected thing. I installed Freespace Port manually, as well as the Freespace media vps with 14 and 3.6.

Of course this solved nothing. Same issues, so I downloaded Knossis and installed everything that way. This time... no errors... at least none detected. I had to verify file integrity a few times but I got it done. Sadly... all of this took about a day, so today I began fresh. Loading up the mediavp for Freespace Open I tried to do the tutorial... unfortunately after you destroy the cargo box brought by the lifter you are supposed to go through the targeting subsystem section.

Except Advanced Amazon Drone doesn't appear. Its a blank nothing. The two cargo ships have engine glow and sprites and a collision hitbox, but there is nothing there. I can't shoot anything so I cannot pass through the tutorial. At least in the mediavps.

So I just load up the standard Freespace port and they appear so I can pass the mission. But now I'm worried something else is wrong. I also opened up the codex/index thingie and the Advanced Amazon Drone is still blank. Any ideas?

*EDIT* It seems the science ship is having the same issue. Not that I've seen it in the main campaign but its not showing up in the codex..... which if I have to protect one could be useful. :P
« Last Edit: August 06, 2019, 11:13:44 am by OneoftheLost »


Offline 0rph3u5

  • 211
  • Oceans rise. Empires fall.
Re: GT Advanced Amazon Drone
Would you be so kind as to provide a fs_open.log?
"When you work with water, you have to know and respect it. When you labour to subdue it, you have to understand that one day it may rise up and turn all your labours into nothing. For what is water, which seeks to make all things level, which has no taste or colour of its own, but a liquid form of Nothing?" - Graham Swift, Waterland


"I am Curiosity, and I've always wondered what would become of you, here at the end of the world." - The Guide/The Curious Other, Othercide

"As you sought to steal a kingdom for yourself, so must you do again, a thousand times over. For a theft, a true theft, must be practiced to be earned." - The terms of Nyrissa's curse, Pathfinder: Kingmaker

"...because they are not Dragons."


Offline Mito [PL]

  • 210
  • Proud Member of Slavicus Mechanicus
Re: GT Advanced Amazon Drone
Interesting. This would mean that the model package is somehow borked, but Knossos should be able to find and/or report a broken archive... You could maybe try:

Generating a debug log: under mod options there's "Run fast debug", and run it until you encounter the issue, then exit the game. Then select "Upload debug log" and share the link here.

Verifying FSPort MediaVPs files and if that doesn't help, redownloading the mod.

Using a recent nightly build - in Knossos settings (gear symbol in the topright corner) set "Preferred engine stability" to "Nightlies" and then check the box "Show FSO builds in mod list", get back to Explore page, update FSO. Then you can launch FSPort-mediavps, just check in mod settings if it will use the nightly.
How do you kill a hydra?

You starve it to death.

Re: GT Advanced Amazon Drone
Woops I was still figuring out debugging with Knossos. Instead of doing the mission again I just went into the ship and weapon specifications. It suddenly popped all kinds of errors... which is odd. Anyway.

Does this work?


Offline Goober5000

  • HLP Loremaster
  • 214
    • Goober5000 Productions
Re: GT Advanced Amazon Drone
By the looks of your log, you are missing MV_Assets, part of the MediaVPs.  Download that and try again.