Author Topic: Campaign Weapons Loadout Issues  (Read 1212 times)

0 Members and 1 Guest are viewing this topic.

Offline Jabba

  • 24
  • Project: 'Megaton'
Campaign Weapons Loadout Issues

Hi. I am having weapons loadout problems in a mini campaign I have created. Here is the closest search result I have found.

http://www.hard-light.net/forums/index.php?topic=62950.0

So, I have tried to rectify this issue myself and my searching brings me only to this unsolved thread in which the original poster has the same issue as me. About the 12th post down, 'wistler' states that in the weapon loadout screen in his mission, there are no weapons for the player to select. All of the slots on the player ship and the available weapons pool are empty. This is when the mission is part of a campaign. If the mission is a single, then there is no problem. So, can anybody shed some light on this problem? That would be nice. I have grouped some quick missions together in a dummy campaign to test out mission branching and things and I cannot learn untill this is solved. Thanks for any help you can provide.

Build:  3.6.10
Mod:    fsport and/or fsport,mediavps
FRED:   Open with -mod fsport / -mod fsport,mediavps
Ultra sucky for announcing greatness and returning with nothing.....

 

Offline The E

  • He's Ebeneezer Goode
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
Re: Campaign Weapons Loadout Issues
Open the campaign editor. Under "Initial Status", select "Weapons". Mark all weapons you want to allow in the campaign. Same for ships.

If you don't want everything to be available at once, use the allow-ship and allow-weapon sexps. Note that you have to use them in the mission preceding the one where the weapons and ships should be available (That is, if you want to hold back the Kayser until mission 10, you need to have an "allow-weapon Kayser" event somewhere in mission 9).

Clear?
If I'm just aching this can't go on
I came from chasing dreams to feel alone
There must be changes, miss to feel strong
I really need lifе to touch me
--Evergrey, Where August Mourns

 

Offline Spoon

  • 212
  • ヾ(´︶`♡)ノ
Re: Campaign Weapons Loadout Issues
Be sure to reset your campaign (in game) too
Urutorahappī!!

[02:42] <@Axem> spoon somethings wrong
[02:42] <@Axem> critically wrong
[02:42] <@Axem> im happy with these missions now
[02:44] <@Axem> well
[02:44] <@Axem> with 2 of them

  

Offline Jabba

  • 24
  • Project: 'Megaton'
Re: Campaign Weapons Loadout Issues
Hi. Thanks for your inputs. Every weapon and ship box was checked in the team loadout editor and in the campaign editor. I have solved the problem. I was saving the mission and campaign files in different areas and this was causing the glitch. Using FSPort and not saving all of the mission and campaign files causes no weapons to appear and other ship selection glitches.

So dur durpey durp to doing that.

Oh and thanks for responding so quick too :D
Ultra sucky for announcing greatness and returning with nothing.....