Hosted Projects - FS2 Required > Series Resurrecta

Minor issues with setting up SR

<< < (2/2)


--- Quote from: CT27 on October 30, 2020, 08:00:31 pm ---Is that literally the text I should put into the mod.ini file (in addition to adding an image 255X112 line with a bmp picture file I made)?
--- End quote ---
Yep. However, no need to specify a custom bmp, the launcher can live without that.

--- Quote ----Should I change the items in that line to their more specific versions?  For example, since this uses 4.3.X files should I change "FreeSpacePortMVP" to what other mods use as "fsport-mediavps_43x"?

--- End quote ---
That's up to how you configured your folders - just make sure that they link to the correct named ones (so if your FreeSpace Port MVPs are in a folder named "fsport-mediavps_43x" you need to adjust it). For manual installation I always use the recentmost version of each, so I don't need an extension with the versionnumber. Also it helps me that I don't have to mess around with the mod.inis everytime a new version of, say, the MVPs is released.

--- Quote ----Should "secondrylist" be changed to "secondarylist"?
--- End quote ---
Idk about wxLauncher, it doesn't matter on 5.5g; maybe do that to be double-safe.

The ModDB package is essentially my SerRes v.1.0.6 folder; it includes a mod.json but no mod.ini. We'll try to set up even handier ModDB backups in the future.  :)

I tried using the template Nightmare gave (the only changes I made were expanding the general names to their specific versions...'FreespaceportMVP' to 'fsport-mediavps_43X' for example) and I got the same issues as before.  It showed the FS1 intro and said 12 errors on the pilot select screen (though, like before, I was still able to play the game).

I'm pretty sure I did everything right.  I put the main SR folder into my Games/FS2 folder and then put the various folders in the files (models/maps/etc.) into SR/data.  That's how I've manually done mods before and they worked.  There was that small 'intro' movie file and I'm pretty sure I put it in the right place (SR/data/movies).

I forgot to change 'secondrylist' to 'secondarylist' so maybe that was an issue...I'll try it again with that change.


--- Quote ---I forgot to change 'secondrylist' to 'secondarylist' so maybe that was an issue...I'll try it again with that change.
--- End quote ---

Probably try that. :)

I tried it again using the template provided (though making modifications so my specific folders could be used):

modname      = SerRes;
infotext     = ;

secondarylist = fsport-mediavps_43X,fsport,MediaVPs_43X;

...and I still got the same problems as before (seeing the FS1 intro movie and a non-HD mainhall and a 12 error report).  I've tried using the moddb download and I tried downloading the individual files from fsknossos and manually putting them in my folder and I've got the same results.

However, like before...the game still works and I didn't encounter any gamebreaking errors when actually playing the campaign.


[0] Message Index

[*] Previous page

Go to full version