Author Topic: "Arachnophobia" TAG error  (Read 480 times)

0 Members and 1 Guest are viewing this topic.

Offline CT27

  • 211
"Arachnophobia" TAG error
On the mission "Aracnophobia" in the GVTA branch (where you have to take out three heavy beams), I ran into some technical problems with the TAG missile part of the mission.  The mission is still beatable, but it was confusing for a while.

(FYI I was playing on the 4.5 MVPs with build 21.4.0 official)

On the first part when I was asked to TAG my required beam cannon, I targeted the beam turret and locked my TAG on and fired.  The missile hit but it did nothing.  The weird thing is it worked after two more tries and it went to the part of the plot where the system glitches and Command orders you to reset (Alt-X) your TAG system.


In the next part where Command orders you to try to TAG the beam turret again, the same thing happened basically.  I fired 4/5 of my bank of TAGs while locked on to the turret and it did nothing.  The final one worked though and it progressed the mission.


I got to the final part where you had to TAG the final turret of the Arachnas, and locked on to the turret and fired...and my TAG missiles did nothing.  My whole bank didn't work.  I tried rearming and doing it again but it didn't work.  10 TAGs I think didn't progress the mission at that point.  So I thought I was stuck and that the mission was broke.  However, I found an interesting workaround.  I got close to the Arachnas and pointed my fighter at the turret and manually dumbfired a TAG at the turret (I didn't have the Arachnas or turret targeted or locked).  That worked and the mission progressed with the final Helios strike and I was able to beat the mission.

I made sure to have my TAG system on or off at the appropriate times as the directive list said.  Do you think this could be fixed?

 

Offline Goober5000

  • HLP Loremaster
  • Moderator
  • 214
    • Goober5000 Productions
Re: "Arachnophobia" TAG error
This is a known bug and Renegade Paladin helped me diagnose the problem.  Basically, Nyctaeus's Arachnas used to be too big for most computers to handle, causing the frame rate to slow down.  Recently computers have been able to process that model at a high frame rate, and it turns out that at a high frame rate there is a bug in the collision code which causes missile hits to not be detected on bowl-shaped turrets.

The bug is fixed, but it requires a flag that is only available on recent builds.  As soon as 22.0 final is out, I will release a new Scroll version that has the flag.
« Last Edit: March 09, 2022, 07:21:30 pm by Goober5000 »

 
Re: "Arachnophobia" TAG error
In the meantime, you can work around it by hitting the beam turret from the side rather than straight on.  It doesn't matter how many missiles you throw at it as long as you're at a direct front angle; you need to be nearly perpendicular to the hull. 
"Courage is the complement of fear.  A fearless man cannot be courageous.  He is also a fool." -- Robert Heinlein

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Re: "Arachnophobia" TAG error
I just forgo the entire thing and take out everything with Prometheus fire from distance.  You can take out all of the defense platforms and the cruisers in this manner.
The Trivial Psychic Strikes Again!

  

Offline Goober5000

  • HLP Loremaster
  • Moderator
  • 214
    • Goober5000 Productions
Re: "Arachnophobia" TAG error
A bit late, but 1.8.10 is out with these fixes.