Author Topic: Where Eagles Dare  (Read 3161 times)

0 Members and 1 Guest are viewing this topic.

I've got a problem with the mission Where Eagles Dare. After taking down the fighters and proceeding to the freighters my screen suddenly goes black with a red line through it(almost as if you're in FRED). HUD still works and I can still order my wingmen, but nothing just happens. I've got SuperCoolAl missions installed(the ones with FS1 music) and SCP 3.6.7 .
Furthermore, I had some problems installing the port: First I made a seperate folder and put all the port stuff in there, but this way I couldn't select the Freespace campaign in the Campaign Room(I had the Launcher configured for the right directory). So I used VPView to extract all the files to their respective directories and now it works.

As you can see I haven't exactly a 100% clean install but I was wondering if this is a common problem, for I'd rather not reinstall FS2 if not absolutely nessecary :( Hope you can help me out, I'm really enjoying this port!

my thanks in advance
Don't sit on the grass, just smoke it

 
You mean this, right?


Well.. I get this too...
With FreeSpace 1, Silent Threat and in The Destiny of Peace.
in other words: Only FS1Port...
Oh... And the mission, where you have your first contact with the shivans crashes (segfault)...

I will run the debug-build to see if I can get some information about the crash...

 
Okay...
gdb won't give me a backtrace... But I think it does have something to do with shockwaves... Don't know exactly...

There's nothing very suspicious in the log... But what is:
Code: [Select]
Playing stupid joystick effectThat's funny...

Okay... I have many messages like this:
Code: [Select]
...
Player lethality: 107.9, num turrets targeting player: 0
Player lethality: 107.8, num turrets targeting player: 0
Player lethality: 107.7, num turrets targeting player: 0
Player lethality: 107.6, num turrets targeting player: 0
Player lethality: 107.6, num turrets targeting player: 0
Player lethality: 107.5, num turrets targeting player: 0
Player lethality: 107.4, num turrets targeting player: 0
Player lethality: 107.4, num turrets targeting player: 0
...

And the last thing that isn't like those messages:
Code: [Select]
rotvel reset in physics_collide_whack
But then... SEGFAULT...
No backtrace, no log-message, nothing...

 
That one exactly! And those are some strange lines of code, Playing Stupid Joystick Effect? I'll run the thing in debug mode as see what it says to me.
Don't sit on the grass, just smoke it

 

Offline Goober5000

  • HLP Loremaster
  • Moderator
  • 214
    • Goober5000 Productions

 
:confused:

Yeah... That was exactly my thought, when it happened the first time...
In the middle of an attack. Much action, much fun!
Then I shot something, it explodes and all of a sudden I'm in this black... Don't know what it is...
But it happened only 2-3 times and only in FSPort...
Maybe it's over again?
Maybe it does have something to do with the 3.6.8 Beta VPs?
Or with the CVS builds I always use...
Well... I will report, when it happens again...

 

Offline CaptJosh

  • 210
I got that effect when playing Inferno R1, myself. I figured I had eaten a Stiletto III and it had EMPed my electronics to death. Except that I should have still been able to see. Cockpits aren't solid metal.
CaptJosh

There are only 10 kinds of people in the world;
those who understand binary and those who don't.

 
Okay... Now it happened in one of my FS2-Missions, too!
And something else...
It seems that other ships can disappear, too!


Almost a whole wing of Maras an Nahemas disappeared!
Also: One of my wingmen and the Support-Ship...
Off-Radar and off-screen... I could only target them with "normal" targetting ("t")...
Notice: Distance: 0 and Speed: >>NAN<<...

And after that, I disappeared! Screen black and... Yeah... Nothing else... I even can't jump out...

I will Mantis that now...

 

Offline taylor

  • Super SCP/Linux Guru
  • 212
    • http://www.icculus.org/~taylor
Oh... And the mission, where you have your first contact with the shivans crashes (segfault)...
This is a loadonlyused weapons bug early in that mission.  If you use the -loadallweps cmdline option does it still crash?

 

Offline Trivial Psychic

  • 212
  • Snoop Junkie
Okay... Now it happened in one of my FS2-Missions, too!
And something else...
It seems that other ships can disappear, too!

Almost a whole wing of Maras an Nahemas disappeared!
Also: One of my wingmen and the Support-Ship...
Off-Radar and off-screen... I could only target them with "normal" targetting ("t")...
Notice: Distance: 0 and Speed: >>NAN<<...

And after that, I disappeared! Screen black and... Yeah... Nothing else... I even can't jump out...

I will Mantis that now...
Something like that happenned to me once.  I was doing some testing of a new ship for TBP, and every time it was hit with either weapons fire or if something made contact with it, the ship would vanish.  I could still target it with the hostile targetting controls, but it would show up with a non-location. and "0" distance and velocity.  I solved the problem when I openned it up in MODview and openned the MOI controls.  There was some non-numeric data in at least one of the fields, and that was screwing up its reaction to hits.  If the models were working before, its possible something went wrong with IBX generation.  Try deleting the IBX files from the offending models and see if it happens again.
The Trivial Psychic Strikes Again!

 
THX for the reply, but I already deleted/regenerated the IBX-Files...
And it also happens with 100% default ships... Not altered by any TBMs...