Author Topic: missing hud  (Read 1559 times)

0 Members and 1 Guest are viewing this topic.

Offline Mewgen1

  • 25
Greetings all!  Over the last few days ive been greatly enjoying ST:R, and I must say to all the devs:  fantastic job!    :yes:  I have, however, hit a snag. 

I'm not entirely sure if this belongs here or in the SCP forums, but since it only seems to have happened when im using a mod with FSPort I figured this would be a good place to start.

Just after I got ST:R and the FSPort 3.1.1 downloaded I tried to download the latest version of the FS:SCP, which at present is the nightly release from 12/25/2008 (r5020). 

When i got this all downloaded and installed and modified the mod.ini file to include these lines:

Code: [Select]
[multimod]
primarylist = FSPort_mediavps;
secondarylist = fsport,mediavps;

Then I loaded the r version of the new .exe and launched myself into the void of space.  problem was there was no hud, no lead indicator, no aspect targetting lock, heck i couldnt even see the gauges for velocity or weapon energy  :confused:

Afraid that I had a corrupted file I quite the game, changed the .exe back to the 3.6.9 release and everything loaded fine.  After taking a look around the boards here and not finding much I tried a few other versions of 3.6.10 all with the same result.  I even tried a couple of the debug builds, which report several missing files like: 2_lock1_fs1, 2_lockspin_fs1, 2_lead1_fs1 & 2_energy2_fs1. 

After I select not to go to the debugger on each error message it goes almost immediatley to this message:

Code: [Select]

Assert: bm_bitmaps[bitmapnum].handle == handle
File: bmpman.cpp
Line: 1915


Call stack:
------------------------------------------------------------------
    fs2_open_3_6_10d-20081225_r5020.exe 00bd14e8()
    fs2_open_3_6_10d-20081225_r5020.exe 007c6948()
    fs2_open_3_6_10d-20081225_r5020.exe 00bcb88d()
    fs2_open_3_6_10d-20081225_r5020.exe 00bcbf0d()
    fs2_open_3_6_10d-20081225_r5020.exe 0096ab6d()
    fs2_open_3_6_10d-20081225_r5020.exe 0073947b()
    fs2_open_3_6_10d-20081225_r5020.exe 00739fba()
    fs2_open_3_6_10d-20081225_r5020.exe 0073ad3d()
    fs2_open_3_6_10d-20081225_r5020.exe 0073d91b()
    fs2_open_3_6_10d-20081225_r5020.exe 0095241d()
    fs2_open_3_6_10d-20081225_r5020.exe 0073ef98()
    fs2_open_3_6_10d-20081225_r5020.exe 0073f22e()
    fs2_open_3_6_10d-20081225_r5020.exe 00c95106()
    fs2_open_3_6_10d-20081225_r5020.exe 00c94f8f()
    kernel32.dll 76a2e3f3()
------------------------------------------------------------------


 


I looked in the FSPort_3.1.1.vp file and found files that almost completley matched the ones listed as missing except the '2_' part at the begging.  so I extracted the offending files, added the '2_' at the start and tried dropping them in every folder related the mods I am using, including the main Freespace 2 folder.  But everytime i try to run the game the error comes back, but only if im running the 3.6.10 .exes with any mod including the FSPort. 

I've exhausted all of my knowledge on this, so I was wondering if anyone else has encountered this and might have a solution.

 

Offline Goober5000

  • HLP Loremaster
  • Moderator
  • 214
    • Goober5000 Productions
Fsport3_0_4.vp -> fsport3_1_1.vp is not the only file that changed.  You need to download the updated version of sparky_hi_fs1 and other files.  The easiest way to do this is by using Turey's installer.

 

Offline Mewgen1

  • 25
Thanks Goober5k.  I spnt the better part of yesterday redownloading all the other files and viola, it worked.  Now, back to the game for me.   :warp: