Author Topic: Bug in Ancients Movies 1, 2, 3  (Read 3460 times)

0 Members and 1 Guest are viewing this topic.

Bug in Ancients Movies 1, 2, 3
The other pre-rendered movies in the FS1-port play fine (the intro, the experiment, the boarding action, etc...), but the cutscenes about the Ancients pixelate and eventually crash. I tried it and it crashed with both fsport-mediavps and fsport. I suspected that it wouldn't make a difference, but thought I should check for completeness. I'm running FS2_open on OS X, v. 3.6.12. I've attached the debug logs. The media files are in odeon_fs1.vp, but I have the GOG version and could replace them with the retail cutscene files if needed. Thanks for your help in advance! ;)
« Last Edit: April 08, 2011, 09:02:59 pm by crazy_dave »

 

Offline mjn.mixael

  • Cutscene Master
  • 212
  • Chopped liver
    • Steam
    • Twitter
Re: Bug in Ancients Movies 1, 2, 3
Make sure you do NOT have "disable scale-to-window for movies" selected in the launcher. If that doesn't work, try downloading the 480p versions of those cutscenes from here.

Cutscene Thread
Cutscene Upgrade Project - Mainhall Remakes - Between the Ashes
Youtube Channel - P3D Model Box
Between the Ashes is looking for committed testers, PM me for details.
Freespace Upgrade Project See what's happening.

 
Re: Bug in Ancients Movies 1, 2, 3
Make sure you do NOT have "disable scale-to-window for movies" selected in the launcher. If that doesn't work, try downloading the 480p versions of those cutscenes from here.

Cutscene Thread

Unfortunately I did indeed have that option deselected already so that wasn't the problem. I've put the cutscenes that I got from the GOG version of FS1 into the fsport folder (creating the data/movies path) and all the cutscenes including the ancient ones seem to be playing okay now. For some reason I can see a bunch more of the cutscenes in the Tech room than I should have access to given my position in the campaign - all the way through Ancients cutscene 3 and the hall fight, but I'm practically at the beginning of the campaign - Ancients 1 video. Anyway the cutscenes seem to work now - however, I'm going to download your updated ones to see hi-def versions. :) That seems like a pretty intense project, best of luck finishing it!

 

Offline Goober5000

  • HLP Loremaster
  • Moderator
  • 214
    • Goober5000 Productions
Re: Bug in Ancients Movies 1, 2, 3
I'm running FS2_open on OS X, v. 3.6.12

OSX builds have an OGG movie bug that requires rebuilt libraries to fix.  Unfortunately, we don't seem to have any OSX coders available to fix the problem...
http://www.hard-light.net/forums/index.php?topic=68937.0

 
Re: Bug in Ancients Movies 1, 2, 3
I'm running FS2_open on OS X, v. 3.6.12

OSX builds have an OGG movie bug that requires rebuilt libraries to fix.  Unfortunately, we don't seem to have any OSX coders available to fix the problem...
http://www.hard-light.net/forums/index.php?topic=68937.0

Interesting ... thanks for the info/pity about the bug. I wonder why only the Ancients videos were affected? After all, the other movies worked okay ... in odeon.vp are some of the cutscenes OGG and some MVE?

At any rate, it's good thing for the .mve versions since they all work now. :)

 

Offline Vespene

  • 24
Re: Bug in Ancients Movies 1, 2, 3
Just ran into the same issue. =/

I guess I'm gonna have to escape out of the movies and enjoy them outside the game, then come back to the briefing.

 
Re: Bug in Ancients Movies 1, 2, 3
Just ran into the same issue. =/

I guess I'm gonna have to escape out of the movies and enjoy them outside the game, then come back to the briefing.

Sorry for the late response I didn't see your post until now. Have you putting in the retail FSport movies into the folder? That worked for me (second post). If you need to you can get retail Freespace 1 from GOG for $5.99 - maybe not worth it if all you want is the cutscenes, but if you'd like to get retail FS1 anyway, it's there.

 

Offline AV8R

  • 28
Re: Bug in Ancients Movies 1, 2, 3
Unfortunately I did indeed have that option deselected already so that wasn't the problem. I've put the cutscenes that I got from the GOG version of FS1 into the fsport folder (creating the data/movies path) and all the cutscenes including the ancient ones seem to be playing okay now. For some reason I can see a bunch more of the cutscenes in the Tech room than I should have access to given my position in the campaign - all the way through Ancients cutscene 3 and the hall fight, but I'm practically at the beginning of the campaign - Ancients 1 video. Anyway the cutscenes seem to work now - however, I'm going to download your updated ones to see hi-def versions. :) That seems like a pretty intense project, best of luck finishing it!

I'm having a similar issue, although it's not crashing my system - I just get really low frame rates during the ancients cut scenes (like 3FPS). My PC just doesn't have the horsepower to run the high-res odeon_fs1.vp (it's a P3 1Ghz with 512MB of RAM and an ATI 9550 AGP card). So I took the advice of the poster above and downloaded the 480p oggs instead and put them in the folder this person mentioned (Freespace2\fsport\data\movies). I tested playing these 480p files outside of FS with WMP and they play fine fullscreen. But when I launch FS and try to play them in the tech room, I get the same low frame rates. So I can tell it's still using the high-res movies in the odeon_fs1.vp files instead of the lower res movies in the movies folder.  :(

How do I force FSPort to use the lower res OGG movies cutscenes?

 

Offline mjn.mixael

  • Cutscene Master
  • 212
  • Chopped liver
    • Steam
    • Twitter
Re: Bug in Ancients Movies 1, 2, 3
Nope.

Loose files inside data/movies WILL override any files in odeon.vp.

The problem is more likely that your computer can't do the 480s either.

To break it down further and more specifically.. your computer CAN play the hi-res versions in an external media player like WMP. However, FSO has a bottleneck with the movies. I've requested SCP to look into it, but they have their hands full. The problem is that your computer isn't powerful enough to run both FSO and any of the remade cutscenes... As a last resort, you might try browsing fsmods.net. I'm pretty sure they still have the old retail cutscenes available.
Cutscene Upgrade Project - Mainhall Remakes - Between the Ashes
Youtube Channel - P3D Model Box
Between the Ashes is looking for committed testers, PM me for details.
Freespace Upgrade Project See what's happening.

 

Offline AV8R

  • 28
Re: Bug in Ancients Movies 1, 2, 3
Ok, I understand. I'll put the original MVE's in the same folder. I have the original movies (I have to reinstall the retail FS1 to get them, but I've got 'em).

Thanks for your post - I'll go the original MVE route.

Not as pretty - but better than 3FPS...  :D

 

Offline mjn.mixael

  • Cutscene Master
  • 212
  • Chopped liver
    • Steam
    • Twitter
Re: Bug in Ancients Movies 1, 2, 3
I.. don't think MVE's will work with FSO.. you'll need to get the converted ones off fsmods.net like I mentioned before.
Cutscene Upgrade Project - Mainhall Remakes - Between the Ashes
Youtube Channel - P3D Model Box
Between the Ashes is looking for committed testers, PM me for details.
Freespace Upgrade Project See what's happening.

 

Offline Timerlane

  • 27
  • Overseer of Slag Determination
Re: Bug in Ancients Movies 1, 2, 3
I think MVE support was missing at one point(sometime before 3.6.10), but AFAIK, it is present in more modern versions of FSO. My old Win98 machine didn't like my installing the codecs for the OGG cutscenes for whatever reason(it was finicky like that), and the support for the old AVIs had already been pulled(3.6.10), but fortunately, it ran the original MVEs from the CDs just fine.

I don't know for sure if there's anything different about Mac versions of FSO specifically, however.

 

Offline Jeff Vader

  • The Back of the Hero!
  • 212
  • Bwahaha
Re: Bug in Ancients Movies 1, 2, 3
I recall that mve support was not present in FSO at first (that is, it was actually removed from the FS2 code), but then later someone wrote new code and I can, from personal experiences, confirm that there was mve support at least in 3.6.9. And I doubt it has been removed since.
23:40 < achillion > EveningTea: ass
23:40 < achillion > wait no
23:40 < achillion > evilbagel: ass
23:40 < EveningTea > ?
23:40 < achillion > 2-letter tab complete failure

14:08 < achillion > there's too much talk of butts and dongs in here
14:08 < achillion > the level of discourse has really plummeted
14:08 < achillion > Let's talk about politics instead
14:08 <@The_E > butts and dongs are part of #hard-light's brand now
14:08 <@The_E > well
14:08 <@The_E > EvilBagel's brand, at least

01:06 < T-Rog > welp
01:07 < T-Rog > I've got to take some very strong antibiotics
01:07 < achillion > penis infection?
01:08 < T-Rog > Chlamydia
01:08 < achillion > O.o
01:09 < achillion > well
01:09 < achillion > I guess that happens
01:09 < T-Rog > at least it's curable
01:09 < achillion > yeah
01:10 < T-Rog > I take it you weren't actually expecting it to be a penis infection
01:10 < achillion > I was not

14:04 < achillion > Sometimes the way to simplify is to just have a habit and not think about it too much
14:05 < achillion > until stuff explodes
14:05 < achillion > then you start thinking about it

22:16 < T-Rog > I don't know how my gf would feel about Jewish conspiracy porn

15:41 <-INFO > EveningTea [[email protected]] has joined #hard-light
15:47 < EvilBagel> butt
15:51 < Achillion> yes
15:53 <-INFO > EveningTea [[email protected]] has quit [Quit: http://www.mibbit.com ajax IRC Client]

18:53 < Achillion> Dicks are fun

21:41 < MatthTheGeek> you can't spell assassin without two asses

20:05 < sigtau> i'm mining titcoins from now on

00:31 < oldlaptop> Drunken antisocial educated freezing hicks with good Internet == Finland stereotype

11:46 <-INFO > Kobrar [[email protected]] has joined #hard-light
11:50 < achtung> Surely you've heard of DVDA
11:50 < achtung> Double Vaginal Double ANal
11:51 < Kobrar> ...
11:51 <-INFO > Kobrar [[email protected]] has left #hard-light []

 

Offline AV8R

  • 28
Re: Bug in Ancients Movies 1, 2, 3
I recall that mve support was not present in FSO at first (that is, it was actually removed from the FS2 code), but then later someone wrote new code and I can, from personal experiences, confirm that there was mve support at least in 3.6.9. And I doubt it has been removed since.

Confirmed.... when I put the original MVE files in the required folder (Freespace2\fsport\data\movies), the movies played just fine (outside of some minor audio skipping). Just for fun I tried the other audio settings from the launcher (Generic Hardware) and while it eliminated the skipping it introduced popping/snapping instead. Shame.

It seems so much of FSO has been all about the good stuff (graphics improvements) at the expense of the other part - the audio experience. Unfortunately, it's evident that this project has yet to attract someone who is proficient in optimizing audio code. Having FSO coded to take advantage of hardware audio optimizations would really go a long way in improving the FSO gaming experience as a whole. What's more is that it's a one-time thing - once you get the code optimized to run audio at 16bit/44.1kHz (or, if CD-quality isn't required, some lower default audio level) on most current audio hardware, it doesn't have to be dealt with again for a long time since audio hardware/standards don't change very much over time (I don't think anyone here is expecting Dolby 7.1 audio - and if you are, get a life).

Open-AL might have given this project cross-platform compatibility convenience but it really falls short of an optimized audio experience that's worthy of the outstanding graphical improvements made to Freespace Open.

Maybe someday.....  :blah:

 

Offline Goober5000

  • HLP Loremaster
  • Moderator
  • 214
    • Goober5000 Productions
Re: Bug in Ancients Movies 1, 2, 3
FSO isn't exclusively about audio and video, mind you.

 

Offline AV8R

  • 28
Re: Bug in Ancients Movies 1, 2, 3
You only have to look a the vast list of campaigns/ports available on this site to realize that....  ;)

But honestly, even mjn.mixael agreed earlier in this thread that there are bottlenecks/issues with the video decoding portion of FSO - and there aren't enough resources (ie - coders with time/experience) to optimize that part of the port(s). And as I just stated before, it's obvious that the same holds true for the audio portion of these ports. Makes me wish I knew how to code. :(

While I agree that hardware optimizing the audio portion of FSO to work with various OS platforms and audio chipsets may be a daunting task - just as the efforts made to the graphics portion of FSO over the years produced beautiful results, so would doing the same with the audio.

Just sayin'.....  :nod:
« Last Edit: September 19, 2011, 05:39:15 pm by AV8R »