Author Topic: Error after selecting pilot/user  (Read 1240 times)

0 Members and 1 Guest are viewing this topic.

Offline indyfan

  • 23
Error after selecting pilot/user
Hi everyone!! first time trying to mod anything. Followed all manual instructions for FSO and media VP 2014. Im using the latest version of FSO 3.7.2.RC3 ( no sse)

Freespace 2 using media Vps 2014 mod works so far but i wanted to play the first freespace first.

Then i followed all instructions for Fsport 3.5 with media Vp 2014 add on.

i also got Mjn.Mixael s Tango_Hi1 through Tango_Hi5 and main hall packs. I didn't get the music upgrade or the cut scenes upgrades.

I created a new pilot as suggested. When i click select, i crash to desktop and get this error:

freespace.fc2(line 16):
Error: Required token = [#End] or [$Mission:], found [+Debriefing Persona Index: 1].

ntdll.dll! ZwWaitForSingleObject + 21 bytes
kernel32.dll! WaitForSingleObjectEx + 67 bytes
kernel32.dll! WaitForSingleObject + 18 bytes
fs2_open_3_7_2_RC3_NO-SSE.exe! <no symbol>
fs2_open_3_7_2_RC3_NO-SSE.exe! <no symbol>
fs2_open_3_7_2_RC3_NO-SSE.exe! <no symbol>

In the freespaceport 3.5 section, it states i should use 3.7.2RC5.

Is this the issues at hand? i can't seem to find it.

anyway i uploaded my debug log (fs2_open.log)

Sorry if went about this issue the wrong way. Thanks for any help given

[attachment deleted by nobody]


Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Re: Error after selecting pilot/user
You should use 3.7.2 Final instead of an outdated release candidate.

Alternatively, if you want to experience the cutting edge of FSO development, you can try a recent Nightly Build.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.


Offline indyfan

  • 23
Re: Error after selecting pilot/user rule!!!

Thanks for the info. I have no idea why i had a older version. It seems to work so far. No time to really play tonight, but i ended up trying the first tutorial.

Thansk again bud!!!