Modding, Mission Design, and Coding > FS2 Open Tools

Knossos will not launch anything after first boot


[EDIT]:  I just realized I didn't post this in the right place.  Can a mod please move this to the support forum?  Sorry about that! [/EDIT]

Hey everyone.  After kinda going off the radar for a long while without notice I'm back again with the FS2 bug.

I've updated the mediavps and all the basics before playing again and I have a rather frustrating issue.

Knossos won't start FS2 at all.  I'll get "FSO is launching" for a moment, then it vanishes and nothing happens.

After some fiddling around I discovered a pattern:

If I delete all of Knossos' data files from the %AppData%/Roaming/HardLightProductions/ folder then start up Knossos, go in the settings to tell it which build to run (21.2 RC2 is the latest Knossos sees in the global flags section) and start the standard Mediavps FS2, it boots.

The instant I leave the game and try to run it again, "FSO is launching" then nothing.  Vanilla FS2 run from the .exe file outside of knossos works just fine.

This obviously seems related to something within the files in that folder - it runs when Knossos is forced to recreate them, but something in there just prevents it from running again...but I don't know which file or what within that file would cause the issue.

I have my doubts it's the fs2_open.ini file, but I can't be certain.

Here's the contents of the file right after doing this process, just for kicks...

--- Quote ---[Default]
VideocardFs2open=OGL -(1920x1080)x32 bit
CurrentJoystick=No Joystick

PlaybackDevice=OpenAL Soft on TSB-TV (Intel(R) Display Audio)
CaptureDevice=OpenAL Soft on Microphone (Realtek High Definition Audio)


--- End quote ---

As I said, it runs fine if I delete the contents of the appdata folder.  It's only after it reloads that this happens.  I made a few searches but couldn't find this issue in the forums.

Thanks in advance!

Darkdaej - one of the oldheads nobody here remembers :)

So...I'm an idiot.

The solution was rather simple and frustrating to discover...I just wasn't clicking the "save" button at the top of the Knossos window after putting up my settings.

I realized I wasn't actually saving Knossos settings and I just saved the global flags.

Still I don't understand why this allowed me to run the game once if I deleted all the "appdata" files first.  Might be worth looking into.

Glad to hear you got it working! If there is no app data folder then the game simply makes one and uses default values.

I am having the same issue and I tried your fix, I have made sure I saved it after putting in settings and it still will not launch anything. only works when i delete the hard light folder and then it launches in a resolution that won't allow me to click anything. i have no idea what to try next. it worked for months then all of a sudden stopped working.


[0] Message Index

Go to full version