Modding, Mission Design, and Coding > The Modding Workshop

Jaded's ModPacks

<< < (5/7) > >>

jadeddragoon:

--- Quote from: teejaycrunk on April 05, 2021, 03:54:10 pm ---
so going through and reinstalling the mod and ALL of the extras with it even if they have already been installed, i was able to run the freespace2 campaign with the updated visuals, and great job man, now im having issues with this on the blue planet complete. i made sure to install ALL of the files that were available for this install. and i havnt played yet, im just worried about issues. and if this is normal or if i should be informing the mods for blue planet about the issue to possibly get help if its needed.


i really appreciate your work with the mods, i wish i was able to do these things as well. i think it would be fun to tinker with

--- End quote ---

Hmm, that error usually means something isn't correctly installed. Like an installation partially failed. That's probably not a problem with blueplanet itself, so either my modpack or Knossos is going to be responsible.

Could you run the game in fast debug and then post a log for me? Fast Debug and the option to post a log can be found under the mods `Options` button in `Details`. Similar to the `FSO Settings` above. This should give me a complete list of what files it's failing to find and help me narrow down the source of the problem. Just run the game in fast debug until you get that error then exit and upload the log... then copy the link to me here so i can see it.

jadeddragoon:

--- Quote from: jadeddragoon on April 07, 2021, 10:33:22 am ---Hmm, that error usually means something isn't correctly installed. Like an installation partially failed. That's probably not a problem with blueplanet itself, so either my modpack or Knossos is going to be responsible.

Could you run the game in fast debug and then post a log for me? Fast Debug and the option to post a log can be found under the mods `Options` button in `Details`. Similar to the `FSO Settings` above. This should give me a complete list of what files it's failing to find and help me narrow down the source of the problem. Just run the game in fast debug until you get that error then exit and upload the log... then copy the link to me here so i can see it.

--- End quote ---

Looks like I was wrong... this actually IS an issue in Blueplannet Complete based on info teejaycrunk gave me in discord. There's been a recent change in FSO that affects how sound tables are parsed. It seems the formatting of the BluePlannet Complete sound tables runs afoul of this change.

BPC already has a fix coming down the pipe... i'll release another RC with that version of BPC soon. If you can't wait, make sure you are playing the BluePlanet Complete modpack on 21.0.0 as per here.

eldarion:
I really apreciate the work you are doing but i am getting the following:

 
--- Quote from: jadeddragoon on March 12, 2021, 12:34:30 pm ---
--- Quote from: SandyKcaz on March 11, 2021, 11:40:10 am ---When I try launching your mod collection from Knossos, it says there is no executable found for this mod. What would I need to do to get this to work? Thx.

--- End quote ---

This looks like a bug in Knossos that I have unwittingly stepped in. Apparently, MJN's Mainhalls must be fully installed even if you only need one mainhall. At least, that's the information I was able to find on the subject. Why that would create this specific error is beyond me. And this one is a bit difficult for me to test.

I'll change the dependencies on the mod in the next release candidate. For now, manually selecting FSO 21.0 should fix the issue.

--- End quote ---

". Apparently, MJN's Mainhalls must be fully installed"
Jesus.... this is everything that is wrong with Knossos. Please come back wxLauncher!

By the way, i faced this very same problem. It's the same if you try to install 4K Hud, for instance. I had to download Gb of data only for that!

jadeddragoon:
Hey guys! Good news. I've been watching for bug reports from these mods for a while now and I'm hearing nothing that can't be traced to knossos bugs. As such I've decided to make the current RCs into the first gold release of my modpacks... with one exception.

The Blue Planet Complete modpack remains in RC status due to it still missing the hd mainhall mod. There's a whole thing behind this, but the good news is it's almost been worked out and the BPC modpack should go gold soon as well. All I'm waiting for is MVPS to update to depend on the 1.4.4 version of the mainhalls mod. Then I'll be able to include them and make one last RC for that modpack. I was originally planning to release the Gold version of the BPC mod without the hd mainhalls... but since we are so close I'm going to go ahead and do so. If I don't get any bug reports it should go gold as well not long after.

Please, if you spot any bugs, don't hesitate to let me know.

jadeddragoon:

--- Quote from: eldarion on August 06, 2021, 12:56:44 pm ---I really apreciate the work you are doing but i am getting the following:

 
--- Quote from: jadeddragoon on March 12, 2021, 12:34:30 pm ---
--- Quote from: SandyKcaz on March 11, 2021, 11:40:10 am ---When I try launching your mod collection from Knossos, it says there is no executable found for this mod. What would I need to do to get this to work? Thx.

--- End quote ---

This looks like a bug in Knossos that I have unwittingly stepped in. Apparently, MJN's Mainhalls must be fully installed even if you only need one mainhall. At least, that's the information I was able to find on the subject. Why that would create this specific error is beyond me. And this one is a bit difficult for me to test.

I'll change the dependencies on the mod in the next release candidate. For now, manually selecting FSO 21.0 should fix the issue.

--- End quote ---

". Apparently, MJN's Mainhalls must be fully installed"
Jesus.... this is everything that is wrong with Knossos. Please come back wxLauncher!

By the way, i faced this very same problem. It's the same if you try to install 4K Hud, for instance. I had to download Gb of data only for that!



--- End quote ---

This turned out to be an intermittent Knossos bug. In practice it seems the mainhalls do not need to be fully installed. The actual solution can be found here. Simply select an FSO build from the list. The 1.0.0 version of the mods are tested with 21.2.0... but 21.4.0-RC1 should work just fine as well.

As for going back to wxLauncher... that would be a huge blow to the community. For all of Knossos's flaws it's dependency management system is something this community has desperately needed for decades... almost since the start. The only reason I decided to de-lurk was when I discoved someone had finally made something like Knossos. And with the complete re-write of Knossos months if not weeks from public beta... moving back to wxLauncher now would be a huge mistake.

In any case, glad you're enjoying the mod packs. :-) I'm planning to release several more for other famous campaigns. But only once I've got these four to the point I want them.

Navigation

[0] Message Index

[#] Next page

[*] Previous page

Go to full version