Author Topic: Troubleshooting Guide  (Read 42964 times)

0 Members and 1 Guest are viewing this topic.

Re: Troubleshooting Guide
It is, unfortunately, an issue with FS in general, though not a bug.
A turret can shot throught the ship it's mounted on and it's a standard retail FS behaviour.
In 3.6.10 builds there's a subsystem flag "Check Hull", which prevents such behaviour, but at the time WCS Prologue was made, it wasn't existing.
Final WCS should have this flag on all turrets of all ships and most likely will have.
Thanks.
I've already downloaded the 3.6.10 rc2 exes and I'll check it out again.
btw sorry for being stupid. I haven't noticed the sentence "Report Wing Commander Saga bugs with Mantis". My apologies.
Audio Converter of Enigma Campaign 2666:
http://enigma.de.to/

German translator of WC: Hostile Frontier:
http://www.ciinet.org/kevin/wchf/

My Youtube Channel:
http://www.youtube.com/user/FekLeyrTarg?feature=mhee

 

Offline Dragon

  • Citation needed
  • 212
  • The sky is the limit.
Re: Troubleshooting Guide
Download 3.6.10 final, not RC2.
And don't forget that build itself won't solve the "issue", you need to make a mod for Prologue that will add "Check Hull" flag to ship turrets to do that.
Also, as I said it's not a bug, engine version provided with Prologue doesn't have "Check Hull" flag.

 
Good news. The PC restart bug has been fixed by upgrading one of my drivers. It's running fine now.
Audio Converter of Enigma Campaign 2666:
http://enigma.de.to/

German translator of WC: Hostile Frontier:
http://www.ciinet.org/kevin/wchf/

My Youtube Channel:
http://www.youtube.com/user/FekLeyrTarg?feature=mhee

 
I have an X-52 Saitek Hotas which the game doesn't recognise, any thoughts as to how I can remedy this?

 

Offline Tolwyn

  • The Admiral
  • Administrator
  • 214
  • Ridiculously Old Fraud
    • Wing Commander Saga
Try using Force 0/1 settings in the launcher.
Wing Commander Saga: A Legend Is Reborn | WingCenter
 
Tolwyn’s reputation for risk taking with other people’s lives was considered  to understate the facts. The admiral’s willingness to sacrifice anyone or anything to achieve his objectives had long been lauded in the popular press. He was “the man who got things done”.- Colonel Blair

No errors, no random CTDs, just pure fun and proof of why getting hit with missiles is a bad thing.
-WC Saga's beta tester


Report Wing Commander Saga bugs with Mantis

 
Try using Force 0/1 settings in the launcher.
Well, I'm not sure what that means exactly but, I did fix it.
I dropped the whole kit and kaboodle into the FreeSpace2 folder and ran it from that launcher where it was no tribble, er, trouble at t'all.

 

Offline KeldorKatarn

  • Moderator
  • 211
We'll make sure the main game will have an easier to use launcher.

 
My only problem is with the movies.   Movie audio is fine, but the video (in Direct3d8) is only showing up in the bottom-right 2/3rds of the screen (regardless of the settings I try, be they in the config program or my usual desktop graphics settings).  Once the movie is done the game returns to normal.

In Direct3D8 all other game aspects work 100% fine... menu, flying/combat, etc.  I haven't tried completing the first mission yet to see if the between-mission type bits where you can click on save/load or talk-to-person type screens look okay, so I'm thinking it has something to do maybe with a bad codec, or perhaps a codec splitter is interfering (I have Combined Community Codec Pack on my system for multiple video format playback... I'll have to see if the Haali a/v splitter or something is messing up the video part of the movies).

I'd play in OpenGL but on startup it gives a "cannot create proper pixel opengl w32" or something... and oddly, no matter what video resolution I set for, the screen momentarily goes to 800x600 and back.

So aside from the movies, the game and gameplay are fantastic.

 

Offline The E

  • He's Ebeneezer Goode
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
 :wtf: What build are you using? Direct3D hasn't worked right in ages......

Please try and download a 3.6.10 build from here, select it in the Launcher, and run it. If it still gives you that error, select the debug version (filename ends with a d), run it, then go to the data folder in your WCS directory, and post the fs2_open.log found there here.
If I'm just aching this can't go on
I came from chasing dreams to feel alone
There must be changes, miss to feel strong
I really need lifе to touch me
--Evergrey, Where August Mourns

 
kk, here's the log.... btw, same error message as before, but now I also get it if I try to run in direct3d8 too (whereas before d3d8 only had the movies not showing up right... the flying/combat part was 100% fine)


==========================================================================
DEBUG SPEW: No debug_filter.cfg found, so only general, error, and warning
categories can be shown and no debug_filter.cfg info will be saved.
==========================================================================
FreeSpace version: 3.6.10
Passed cmdline options:
  -ambient_factor 100
  -glow
  -spec
  -cache_bitmaps
  -ship_choice_3d
  -snd_preload
  -wcsaga
Building file index...
Found root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_anims.vp' with a checksum of 0x20ede0b2
Found root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_asteroids.vp' with a checksum of 0xed4efb11
Found root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_core.vp' with a checksum of 0x2c725bc9
Found root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_effects.vp' with a checksum of 0xb0272d7b
Found root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_hud.vp' with a checksum of 0x0a624b02
Found root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_interface.vp' with a checksum of 0x17c4567c
Found root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_music.vp' with a checksum of 0x244979b7
Found root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_ships.vp' with a checksum of 0x4248ea63
Found root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_sounds.vp' with a checksum of 0xda87e6ba
Found root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_voice.vp' with a checksum of 0x3066cebf
Searching root 'E:\Program Files\Wing Commander Saga Prologue\' ... 40 files
Searching root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_anims.vp' ... 3 files
Searching root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_asteroids.vp' ... 21 files
Searching root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_core.vp' ... 60 files
Searching root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_effects.vp' ... 245 files
Searching root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_hud.vp' ... 205 files
Searching root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_interface.vp' ... 1313 files
Searching root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_music.vp' ... 37 files
Searching root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_ships.vp' ... 1167 files
Searching root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_sounds.vp' ... 157 files
Searching root pack 'E:\Program Files\Wing Commander Saga Prologue\prologue_voice.vp' ... 685 files
Found 11 roots and 3933 files.
AutoLang: Language auto-detection successful...
Setting language to English
Initializing OpenAL...
  Using 'Generic Software' as OpenAL sound device...
  OpenAL Vendor     : Creative Labs Inc.
  OpenAL Renderer   : Software
  OpenAL Version    : 1.1

... OpenAL successfully initialized!
Initializing OpenGL graphics device at 1280x960 with 32-bit color...
  Initializing WGL...
ERROR: Unable to initialize display device!

File: gropengl.cpp
Line: 2972
    gr_init_sub()    gr_init()    game_init()    game_main()    WinMain()    WinMainCRTStartup()    kernel32.dll 7c817077()

 

Offline The E

  • He's Ebeneezer Goode
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
That's because Direct3D support has been cut from FS2_Open completely. Even if you select it in the Launcher, it will ALWAYS use OpenGL.

Now, this error usually means that your GPU drivers are broken. What card are you using?
If I'm just aching this can't go on
I came from chasing dreams to feel alone
There must be changes, miss to feel strong
I really need lifе to touch me
--Evergrey, Where August Mourns

 
asus p4p800-mx motherboard with a 2.6 ghz cpu, 1 gb ram stick (and a 256 ram stick... so guess that writes as 1.256 gb ram?)
for video:
intel video chipset 82865g with latest drivers installed

trying to find what version opengl I have (thinking its 1.1 think I read the game needs 1.2 or higher)

 

Offline The E

  • He's Ebeneezer Goode
  • 213
  • Nothing personal, just tech support.
    • Steam
    • Twitter
The game actually needs 1.4 (Actually, it should work with 1.2, but 1.4 is recommended). And Intel GMAs are basically crap. Any chance you can get a real GPU in there?
If I'm just aching this can't go on
I came from chasing dreams to feel alone
There must be changes, miss to feel strong
I really need lifе to touch me
--Evergrey, Where August Mourns

 
WTF?  re-ran their latest-chipset-driver checker program and suddenly its saying my drivers are OLD.  Ran the prog like 10 times in the past 5 hours and it always said that I had version 6.x (2005 date) and was up to date.... but suddenly it said I had 6.x.x but 14.x.x was the latest (and the date was like 2007 for 14.x)

so installed and retested... video working 99.99% fine now (some odd garbage at top and bottom of screen... movie occupies full screen from left to right, but only about the middle 5/7th's top to bottom... bout 1" empty room at top and bottom of monitor... and that 1" has odd-colored garbage)

 
Is there a save for immediately after the 2nd mission?  Seems the auto-pilot is really jerky and even fairly buggy.

SUGGESTION:  an "AUTO" text should display while in auto-pilot.

Visuals are beautiful.  What little gameplay I've seen has been great.  Audio seems spot-on to the feeling of the background music I remember from actual WC games.  Just the damn buggy auto-pilot.

7 attempts so far and:

3 attempts had the auto-pilot engaged and was in route to nav 1 when transport "suddenly" blows up and I find myself back approaching the carrier (alive) only then it cuts to "you left formation and went against the pirates on your own against the order to stay in formation.  You were one, they were many, your now dead."   :mad:

1 attempt had auto-pilot on route to nav 3 (with like 8k left to the nav-point) when suddenly my ship drops out of auto-pilot (or something) and then suddenly my fighter flips 180 degrees and I can see the transport (moving at like it was still at 64X high-speed autopilot) and then blam, it rams me over and over again (till I'm dead).  I can only guess I was still in auto since I couldn't stear or use afterburner to get out of its way.

2 attempts got as far as nav 3 then, just short of where auto-pilot should turn off, without warning I'm dead (and it gives the "you left formation" blaw blaw message.

1 attempt got 3 pirates killed within the first few moments, few minutes later there only was ONE pirate left with the transport at like 12% health and clearly the pirate isn't in missile range of it when, just like 1/2 second after the pirate explodes, suddenly blam, the transport vanishes (no explosion) and I get the "you failed to protect the transport" ...  :confused:

 

Offline KeldorKatarn

  • Moderator
  • 211
What build are you using for this? This sounds very strange, I've never heard anything like this happen before.

 

Offline Tolwyn

  • The Admiral
  • Administrator
  • 214
  • Ridiculously Old Fraud
    • Wing Commander Saga
Please use, if possible, the EXE supplied with the game.
Wing Commander Saga: A Legend Is Reborn | WingCenter
 
Tolwyn’s reputation for risk taking with other people’s lives was considered  to understate the facts. The admiral’s willingness to sacrifice anyone or anything to achieve his objectives had long been lauded in the popular press. He was “the man who got things done”.- Colonel Blair

No errors, no random CTDs, just pure fun and proof of why getting hit with missiles is a bad thing.
-WC Saga's beta tester


Report Wing Commander Saga bugs with Mantis

 

Offline bombush

  • 21
Definitly got OpenAL 1.1 from openal.org
Installer doesn´t need much time, but says installation complete.

And the files are inthe system32 directory ( and in the game directory too )
It´s a bit strange

If everything else fails (and it did on my XP SP3 machine), try copying wrap_oal.dll to your wcsaga folder and renaming it as openal32.dll
(you can delete the original openal32.dll file from the wcsaga directory).
It works just fine for me.

Big thanks for this great game to the modder/developer team...