Hosted Projects - Non-FreeSpace > MechCommander OmniTech

Windows 10, how to run?

(1/5) > >>

Hey there,

I try to play MCO (lates build) under Windows 10 64 bit.

Sadly the gameplay suffers from heavy visual lag and it looks rendered like software mode. Even in the main menue it all looks very unclear. On my laptop it runs fine, and is smooth and nice.

I have an Nvidia EVGA 980 TI and it looks like that card is not supported by the game.

I can play but it looks bad and runs very slow.

I tried much things.. clean new install, older version, different compatibilty settings etc. etc. etc.

Is there any way to get it running smooth and nice under windows 10 with such a card? I do not want to downgrade drivers.. any other solution?


Turn vertical synchronisation off.
Close other software like Browsers, Media players and so on.
Set graphic Driver back to older version if possible.

Sadly nothing of that helped.

Running it as an admin and deactivating fullscreenoptimisation helped but then there was a new major windows update and since then, its back to "software rendering and visual lag".

Rolling back my driver is something that I won´t do.

I hope there is more to do, otherwise thanks for your help :)

Does the graphic card come with a control panel interface? Its where you can set options for individual programs.

Set everything to 'off' or 'set by application' for the MCO exe.

And run as admin.

I used the Nvidia Control Panel and made all to "set by application" - sadly that did not help.

It already is running as an administrator.

Strangely my intel Notebook onboard card runs it fine. Only my PC with my Nvidia Card has that problems.


[0] Message Index

[#] Next page

Go to full version