Announcements > Getting Started

Back from a decade hiatus, and my joystick won't work

(1/2) > >>

Hello everyone! I've been gone for the better part of a decade because.... I ghosted a lot back then. But I'm back and I wanna play!

But, on the latest version of FSO, my joystick won't work. Doesn't matter what driver I choose either. What's strange is that the old 3.7.1 version does work with my stick. What's going on? I use a Logitech Xtreme 3D Pro on windows 7.

That said, sometime in the next few months I intend on picking up my old playable Shivan mod along with a rebalance mod. Unfortunately my Shivan mod is gone, and I can't retrieve it, so that's gonna have to start anew, but that should be fun!

Welcome back! Quick question to help us troubleshoot, are you using Knossos as the game launcher, or something else? Also, feel free to say hi on the Discord channel!

Thank you wookieejedi. I'm using YAL, but the same happens with wx. Haven't tried Knossos yet. It's new since I'm been gone.

YAL probably won’t work with more recent FSO builds (a lot has changed) and even wxL might not. Knossos should, though.

I’d think Extreme 3D Pro would work; it’s fairly common.

Just tried going thru Knossos, and it just sat there saying it was launching. I made sure to choose the EXE to use and such.


[0] Message Index

[#] Next page

Go to full version