Author Topic: *edited* mission-questions regaring purchase file  (Read 1881 times)

0 Members and 1 Guest are viewing this topic.

*edited* mission-questions regaring purchase file
Please ignore this post and scroll to the latest one instead, thanks :)

Hi there :)

i am currently enjoying the MCO 092 release, the exodus campaign to be precise.
Although i like it very much, i have a question: is it working as intended, that i cannot salvage mechs during the mission, even if i have the resource points, in most missions (i just rescued the kurita official`s son)? I am not trying to debate the design descision, just asking if its correct.

But now to the topic title:

The editor (with the 092-package) crashes if i either try to save or if i try to open a map i extracted from the mission.fst file that came with the core installation ...
i have the XNA 3.1 runtime installed and work on a win7-32bit pc, if it is of any importance ...
« Last Edit: July 29, 2011, 05:05:09 pm by BulletSix »


Offline Timerlane

  • 27
  • Overseer of Slag Determination
Re: Editor trouble (saving & when opening a mission from the base release)
Just to note(not sure if this is the case); if you don't have any extra pilots left, then you can't salvage additional Mechs, even if you have the RPs.


Offline magic

  • Moderator
  • 211
Re: Editor trouble (saving & when opening a mission from the base release)

Thank you for downloading and playing. In exodus campaign everything is as intended. Salvage is limited, resources are low...

The editor is working well under win7 with one exception. It will load/save any mission (not all old missions can be safely opened/saved, because MCO is very different from MC2). Try creating your own mission and see what is going on. It will crush after saving, but mission will be OK. It will not crush in XP.

From your description looks like xna problem to me. Please read program requirements file.

Editor is completely fixed now, no more crushes on exit in win7, 4 groups for mechs: IS/Clan Light & Medium, IS/Clan Heavy & Assault, 5 more groups for buildings...

New release is coming soon...

ok then, thanks for looking at it :)

i`m looking forward to the next release(s) and will check the requirements more thoroughly.

And btw. imo its much more fun with limited resources ;)

i got it to work on one pc ... leaves just the 64bit-machine to test
(in case someone is wondering, it seemed a incorrect installment of the XNA ... silly me )

But now a question regarding the exodus campaign ... maybe even a game bug?

i played until mission N° 19, named e_1_3 (i hope its clear for those who know the campaign ... i am trying to stay clear of spoilers :) )
after that i got some ... interesting purchase choices *g*
long story short, i bought some, and decided to look at the map by starting the mission, look at the layout and decide then what loadout i wanted to give my Mechs. (please do not comment this playstyle atm ;) )
Then i aborted the mission back to the selection screen ... or so i thought.
But the interesting purchase choices were gone :( just some left i had seen for a few missions now .
i tried loading my savegame i took when i first saw the mission briefing ... no luck
i tried loading the automatic save game at this point .. no luck.
i tried again after re-starting the game again ... no luck.
i loaded an eariler savegame and quickloaded into mission e_1_3, played the mission again ... no luck.
played the mission from the sart again ... no luck.
i looked at the campaign and purchse-files defined for that mission in the campaign (they showed the interesting choices)... no luck
i tried to give the previous mission the purchases (by editing the campaign-file)... no luck

whats happening there? Where did i botch and how?


hmm .. seems the scroll back to pre mission and tthen forward to the mechbay-trick works ^^

Edit3: on my way to becoming a nuisance ^^ :

Exodus campaign Mission where you have to defend 3 Bunkers crashes on exit.
It plays well (got utterly destroyed the first tries *g*), i got all my targets,
i get the mission success screen, and then the picture gets dark as always.
But instead of getting to the next briefing, the game crashes. (yes i tried a few times)

EXCEPTION : Attempt to read from NULL in MCOREL! (+0x11E8DD)
Address   : 0x0051F8DD
Location  : MCOREL! (+0x11E8DD)

Call Stack
0x00434E55 MCOREL! (+0x33E55)               
0x0042B603 MCOREL! (+0x2A603)               
0x0043506B MCOREL! (+0x3406B)               
0x0044B5D3 MCOREL! (+0x4A5D3)               
0x004038EB MCOREL! (+0x28EB)               
0x005A8614 MCOREL! (+0x1A7614)             

any ideas? Shoudn`t i have captured the headquarter building besides the repair bay?
« Last Edit: July 30, 2011, 03:33:10 am by BulletSix »