Author Topic: Colossus and hatty issues.  (Read 383 times)

0 Members and 1 Guest are viewing this topic.

Offline starbug

  • 210
    • DarkSide Animations
Colossus and hatty issues.
So I recently updated to the latest release of MVPs and I decided it's a long time since I played the base Fs2 campaign so I am playing the FS2blue in Blue planet.

I seem to have come across a few things, though i am unsure if it is a blue planet thing or FSU MVPs.

I am not 100% sure if this should be here or in BP.

So issue 1 is the mission where the repulse rams the colossus I noticed 2 things I hadn't before.
1. The colossus never fires its beams at the repulse, even on repeats of the mission.

2. When the repulse actually rams the colossus, the collision data for the colossus is weird the repulse actually enters the colossus and gets to about the beginning of the engine section before the repulse explodes. Again its the same result on multiple plays of the mission.

I also notice that the hatty will not fire her main beams at all unless its scripted to do so in FRED. I have tried a few tests in FRED, where I have just beam freed the hatty and it will not fire any of the main beams not matter where I posistion the enemy ships. But it will fire if I use sexps command it to fire at targets.

So is there a bug with the hatty's turrets? As I have looked at the pof turret data/fire points and nothing stands our for me.
http://www.youtube.com/user/AnubisX1

if there is any consistancy with the Shivans, it's their lack of consistancy - -Norbert-

 

Offline EatThePath

  • 28
  • Laser Lich
    • Twitter
Re: Colossus and hatty issues.
Not sure about the beams issue. Did you give the hatty an attack order in that test? it might need that, perhaps.

For the clipping issue, it's not a problem with the Collosus. It may also be a retail issue? Not sure. Someone would have to check if the MVPs and retain Orion have the same eyepoint data and bounding box. I expect they do, as I recall this problem being fixed a time or two before
Name your damn turrets and sounds! Numbers alone aren't helpful!
"if disco is dead then I am the laser lich"
"...[Warmachine] keeps changing as fast as EatThePath can force the engine to do his dark bidding..."

 

Offline starbug

  • 210
    • DarkSide Animations
Re: Colossus and hatty issues.
So i went back and played Retail FS2 yeah i know it was weird. in the Mission with Repulse, which i played 5 times. On 2 of the play throughs the Repulse is destroyed by the Colossus beams. the rest the repulse rams the colossus, but each time the repulse is destroyed as soon as it touches the head of the retail colossus model.

Now went back to the FSO/MVP/FS2blue. Each time again the Colossus will not open on the Repulse and each time the repulse ends up going inside the colossus and denotating at the engine section of the Colossus, this is why i thought there was a issue with the MVP ships.

As for the Hatty, i tried all that, even replaced the Turrets1, 2, & 3 with terran turrets and they wouldn't fire, Turret 2 fired briefly when there was a target directly infront of it.
http://www.youtube.com/user/AnubisX1

if there is any consistancy with the Shivans, it's their lack of consistancy - -Norbert-

 

Offline Iain Baker

  • 29
  • 'Sup?
    • Steam
    • Twitter
    • NOMAD's Reviews
Re: Colossus and hatty issues.
The weird ramming issue is a known bug in FSBlue. It’s been like that for a while. Hopefully it will get patched out. There were a few other issues people encountered too. One was with the mission with all the mojlinr sentry guns - it was proving almost impossible to kill the Orion that comes through.
Wanna check out my video games, technology and media website? If so, visit; https://www.nomadsreviews.co.uk/

Interested in hiring my freelance writing, proof-reading, editing, SEO, TTSO, Web Development or Social Media Management services? If so, please messege me at [email protected]

 

Offline starbug

  • 210
    • DarkSide Animations
Re: Colossus and hatty issues.
Ah right, so that just leaves the Hatty's main beam turrets issue
http://www.youtube.com/user/AnubisX1

if there is any consistancy with the Shivans, it's their lack of consistancy - -Norbert-

 

Offline mjn.mixael

  • Cutscene Master
  • Moderator
  • 212
  • Chopped liver
    • Steam
    • Twitter
Re: Colossus and hatty issues.
The Hatty model has not been changed since 2010, according to the SVN log. That doesn't mean there isn't an issue with the model causing turrets not to fire, but it does mean if that is now suddenly happening then something in the engine or FSBlue must be either the cause or exacerbated an existing issue with the model that no one has yet discovered.
Cutscene Upgrade Project - Mainhall Remakes - Between the Ashes
Youtube Channel - P3D Model Box
Between the Ashes is looking for committed testers, PM me for details.
Freespace Upgrade Project See what's happening.

 

Offline starbug

  • 210
    • DarkSide Animations
Re: Colossus and hatty issues.
Weirdly enough a lot of the campaigns I have played, rarely use the hatty and only is rarely used as a combat ship more a carrier.

So I have tried out a few tests in both Fsblue and retail Fs2 MVP and I found that the issue is worse in FSblue than just standard FS2.

I pitted the hatty against a demios, and each time the demios won without the aid of Sexps for the hattys beam cannons.

While in the standard FS2 MVP it does fire but only once in a blue moon, its gets the demios down to about 20% but just takes to long to return to finish it off.

 Wow since 2010, I hadn't realised it was that old. Still a lovely model for 12 years old.

Oh i am running it with FSO 22 RC6
http://www.youtube.com/user/AnubisX1

if there is any consistancy with the Shivans, it's their lack of consistancy - -Norbert-

 

Offline Nyctaeus

  • The Slavic Engineer
  • 212
  • 6-digit polycounts are overrated.
    • Minecraft
    • Exile
Re: Colossus and hatty issues.
Both issues with Colossus and Repulse are extremely old and hard to track down. I encountered both many years ago in vanilla and on various versions of the FSO. If I remember correctly, the differences in mass, MOI, bounding boxes etc of either of the assets caused them to appear too far or not close enough. The detonation sequence is carefully sexped and timed, so any inconsistencies in pof data causes mission to bug out.

But both of them should be fixed years ago. Nobody reported this issue for years.

Colossus not firing beams was happening if player used C + 3 + 6 on Repulse.

The reason why this stuff happens again is up to anybody's guess. I doubt of this is happening due to pof bugs. I'll check the Orion for differences in pof data as it's the only new asset involved. Colossus and Hatshepsut are much older assets and they barely got touched in the last couple releases, so if they refuse to fire by other reason then C + 3 + 6, it may as well be FSO bug.
Exile | Shadow Genesis | Inferno | Series Resurrecta  | DA Profile | P3D Profile

Proud owner of NyctiShipyards. Remember - Nyx will fix it!

All of my assets including models, textures, skyboxes, effects may be used under standard CC BY-NC 4.0 license.