Author Topic: UniformBufferManager.cpp line 133  (Read 438 times)

0 Members and 1 Guest are viewing this topic.

UniformBufferManager.cpp line 133
So i posted this some weeks ago and now I re post it with the fast debug option the thing is I run a mission on blue planet and then the game crashes and the error apears so here is the topic again with the debug https://fsnebula.org/log/609f132dd424e511af391309

 
Re: UniformBufferManager.cpp line 133
Hm, try without shadows and FXAA.

 

Offline ngld

  • Administrator
  • 29
  • Knossos dev
Re: UniformBufferManager.cpp line 133
Quote
Missed uniform fence deadline!!
Missed uniform fence deadline!!
[...]
Failed to wait until uniform range is available!
As far as I understand the code, this error is caused by your GPU taking more than 0.5ms for a frame which *really* shouldn't happen since that'd result in 2 FPS or less.
Since you're running on integrated graphics, disabling the more demanding features (like shadows and lightshafts) should help with the issue.

 

Offline m!m

  • 211
Re: UniformBufferManager.cpp line 133
As far as I understand the code, this error is caused by your GPU taking more than 0.5ms for a frame which *really* shouldn't happen since that'd result in 2 FPS or less.
Since you're running on integrated graphics, disabling the more demanding features (like shadows and lightshafts) should help with the issue.
That is correct but we wait up to 10 times with 0.5 seconds each time so a total of 5 seconds. No frame should ever take that long to render. I would be more inclined to say that your graphics driver has some kind of bug.

 
Re: UniformBufferManager.cpp line 133
Is there any way to disable the shadows? cus Im still getting the same error even with some high performance options disabled like FXAA lightshafts etc But I dont find a way to disable the shadows :confused:

 
Re: UniformBufferManager.cpp line 133
(UPDATE) I tried disabling shadows and even more high performance options. . yet the error is still apearing I did a new debug log to see if it helps with something https://fsnebula.org/log/60a5b1f9d424e511af39130a

 
Re: UniformBufferManager.cpp line 133
For anyone using integrated graphics and still having this issue, I was able to solve the problem for me by updating my display drivers, so maybe check if they are up to date. Note to Intel HD graphics users: you might need to manually download the latest display drivers from Intel's website, since they might not be in Microsoft's repository, hence your computer will say that the latest drivers are already installed, even though they are from 2015...