Author Topic: RELEASE - The Procyon Insurgency  (Read 182722 times)

0 Members and 1 Guest are viewing this topic.

Re: RELEASE - The Procyon Insurgency
Definitely a great campaign. I remember the portal reconnaissance missions vividly.


Offline kschang

  • 21
    • Skype
    • Steam
Re: RELEASE - The Procyon Insurgency
Just got started on this couple days ago. The "make it through the Gonossis" was a real head-ache. (hahaha)      Need to keep track of a certain hostile fighter better.

Was kinda stuck on 14 part 3 where I'm in the nebula following Alpha 1 around. 

Any way, here goes...

I was following Alpha 1, killed the 6 fighters, the containers, the 3 great war fighters... Came across the Agni again.

it says to follow Agni, so I did... For the next 30 minutes. NOTHING happened. It was then I realized I followed it at distance of 750. I closed in to 250, got the "keep searching!" and things started to happen. Ran into the battle.

Then the EXE poof popped up with a FRED error, something about a certain ship has TWO secondary weapons and no primary, then a different ship, same error. If I hit cancel, the EXE dies. I hit OK and it continues...

I decided to ignore the Ancients ships, and the Agni eventually came to a stop... and again, NOTHING HAPPENED for 10 minutes. But the "Scan the unknown ships" remained at 5.

So I imagine I kinda broke the script by not listening to the briefing or was it that unclear? The order says "follow Agni", but never said how close. The second order was "go scan those ships" but somehow I couldn't at the time, which was why I ignored it.

Just tried AGAIN. This time, I scanned EVERY ship, including the fighters. All scanned.

Followed Alpha 1 back, we ran into a couple Ancients harassed by a bunch of Shivans. I shot the Shivans down. But Alpha 1 never budged. He just follow one of the ancient around like a puppy, in a circle.  Right on the guy's tail. At speed 19. 

What do I need to do? Shoot down the ancients too? WTF?
« Last Edit: June 08, 2017, 07:59:35 pm by kschang »


Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Re: RELEASE - The Procyon Insurgency
For future reference, you can just use [spoiler].
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.


Offline kschang

  • 21
    • Skype
    • Steam
Re: RELEASE - The Procyon Insurgency
FWIW, I went ahead and shot down the ancients (they show as hostile on my IFF), nothing happened. Alpha 1 still circles, albeit at speed 23.

For grins, I shot at him. He turned into a red dot, and I can no longer target him and lock on him. AND I lost the nav point, but I can't kill him. He seems to have plot armor on.

Oh well, I quit.