Recent Posts

Pages: [1] 2 3 4 5 6 7 8 ... 10 Next >
1
Nightly Builds / Nightly: 19 June 2021 - Revision c541ac91d
« Last post by SirKnightly on June 19, 2021, 01:48:13 am »
Here is the nightly for 19 June 2021 - Revision c541ac91d



Group: Linux
nightly_20210619_c541ac91d-builds-Linux.tar.gz (Mirror)


Group: Win64-SSE2
nightly_20210619_c541ac91d-builds-x64-SSE2.zip (Mirror)


Group: Win32-SSE2
nightly_20210619_c541ac91d-builds-Win32-SSE2.zip (Mirror)

Code: [Select]
------------------------------------------------------------------------
commit eb6f7fb01
Author: the-maddin
Commit: the-maddin

    Fix some clang stuff
 qtfred/src/CheckedDataListModel.h | 12 ++++++------
 1 file changed, 6 insertions(+), 6 deletions(-)

------------------------------------------------------------------------
commit 474f22567
Author: the-maddin
Commit: the-maddin

    be explicit for msvc
 qtfred/src/CheckedDataListModel.h | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

------------------------------------------------------------------------
commit 14337c22b
Author: the-maddin
Commit: the-maddin

    Rewrite CheckedDataListModel
 qtfred/src/CheckedDataListModel.h | 111 +++++++++++++++++++++++++-------------
 1 file changed, 75 insertions(+), 36 deletions(-)

------------------------------------------------------------------------
commit 4f5fb48f7
Author: Birk Magnussen
Commit: Birk Magnussen

    Add shadow map generation for briefing
 code/missionui/missionbrief.cpp | 21 +++++++++++++++++----
 1 file changed, 17 insertions(+), 4 deletions(-)
2
Yeah I watched that, and it kind of hurt my brain trying to think of it intuitively. Which is kind of a fun feeling actually.
3
I'll put the details first then the video:

Quote
Veritasium - 2 weeks ago:

If you want more detail on the explanation here it is:
1. The car is powered only by the wind. There is no motor or batteries of any kind.
2. The propeller does NOT spin like a windmill. The wind does NOT push it and make it turn.
3. Instead the wheels are geared to the propeller to turn it the opposite way, like a fan, so it pushes air backwards.
4. To start the vehicle the wind simply pushes on the whole vehicle (like a block of styrofoam) and gets it moving.
5. The wheels are turning so they turn the propeller in the opposite direction to how the wind is pushing it.
6. The prop is pushing air back so air pushes the prop forwards, accelerating the car.
7. Once you get up to wind speed there is no apparent wind on the vehicle. If the prop were spun like a windmill this would mean no more thrust. But, since the prop is operating like a fan, it still accelerates air backwards, generating thrust.
8. You can go faster than wind speed continuously because even when going faster than the wind, the prop can still accelerate air backwards (in the car's frame of reference) generating thrust. In a stationary frame of reference you would see that the wind behind the propellor is slower than the surrounding air. So it's clear that the energy is coming from the wind.

FAQ: If power is coming from the wheels to turn the prop, why doesn't that slow down the wheels more than it gets the prop to push back?
A: Because the wheels are moving over the ground much faster than the prop is moving through the air (because there's a tailwind).

Example:
Let's say the car is going 12m/s in a 10m/s tailwind, so faster than the wind (note the prop will be moving through an apparent headwind of 2m/s).

Power = Force x Velocity

Let's say the chain applies a drag force of 100N on the wheels to drive the prop. This means we're taking power from the wheels = FxV = 100N x 12m/s = 1200W

If we apply this power to the fan, it can create a force of F = P/V = 1200W / 2m/s = 600N

Admittedly I've assumed no losses, but even if we waste half the power, we'd still get 300N of thrust which is more than the 100N of drag the prop adds to the wheels. The key is that we're harvesting power at higher speed, lower force, and deploying it at lower speed, higher force (which is only possible because we have a tailwind - in still air this wouldn't work because the relative velocity of the wheels over the ground would be exactly the same as the relative velocity of the prop through the air).

4
FreeSpace & FreeSpace Open Support / Re: Unable to find ship class
« Last post by General Battuta on June 18, 2021, 08:34:43 pm »
It do be that way.
5
FreeSpace & FreeSpace Open Support / Re: Unable to find ship class
« Last post by RJ Callahan on June 18, 2021, 07:25:00 pm »
Hm, that's odd. I couldn't find any reference to that ship anywhere on the internet. I ended up solving the problem by using an older FSO build for the mod. The cockpit mod apparently doesn't play well with the most recent builds, but it works fine on 19.0.0.
6
FreeSpace & FreeSpace Open Support / Re: Unable to find ship class
« Last post by General Battuta on June 18, 2021, 06:49:55 pm »
The cockpit mod seems to contain references to a ship (the GTB Snake) that doesn't actually exist either in the mod or in base FreeSpace 2.
7
FreeSpace & FreeSpace Open Support / Unable to find ship class
« Last post by RJ Callahan on June 18, 2021, 05:19:00 pm »
Hi

I'm trying to play Freespace 2 (original FS2 campaign with FSO) with a cockpit mod that I installed with Knossos. Whenever I try to launch the game, I get the following error message:

Warning: cockpits-hdg.tbm(line 7):
Error: Unable to find ship class GTB Snake in stuff_int_list!
File: parselo.cpp
Line: 310

I tried disabling parsing errors in the launcher (not sure if this is considered a n00b move), which just results in a CTD without an error message. FS2 with mediaVPs 4.4.2 works just fine, but I really want cockpits! I would appreciate it if someone can assist me with this. The dirty dishes in my room probably know more about coding than I do, and I can't find anything on the forums (not even on the cockpit mod's forum) about this. I've considered going back to using the wxLauncher, which ran the cockpit mod (albeit with a bunch of warnings popping up in the main menu), but I deleted my freespace 2 folder after I switched to Knossos, which means that I would have to redownload everything, which will take forever on my connection. I'm also including the link to the fs2_open.log:

https://fsnebula.org/log/60cd1767c9b5f261cd39130e

P.S. This is my first time posting a new topic, so please excuse any rookie mistakes that I might have made.
8
Mission & Campaign Releases / Re: RELEASE: Road to Orum'Pur - prologue
« Last post by ShivanSlayer on June 18, 2021, 11:57:37 am »
It boots up now, but on the campaign menu, the actual campaign doesn't show up. I can only choose the original story campaigns
9
Mission & Campaign Releases / Re: RELEASE: Road to Orum'Pur - prologue
« Last post by Jackho on June 18, 2021, 11:07:09 am »
Hi there,

I got help from Knossos creator, I think now you will be able to make it work as expected. So I pushed a new version 1.1.1 and made an update to the latest MediaVPs and stable engine (21.2).
Please try it and tell me if you still run into trouble.

Cheers!
10
Voice Acting / Re: Voice Acting: The Battle of Neptune
« Last post by Dilmah G on June 18, 2021, 09:35:38 am »
Hey dude, will do! Cheers.
Pages: [1] 2 3 4 5 6 7 8 ... 10 Next >