General FreeSpace > FreeSpace Discussion

Freespace 2 Ope: Borderless Windowed?

(1/2) > >>

I love to play my less demanding games in 3840x2160 DSR on my 1080p ASUS VG278QR monitor.  When I have Freespace 2 Open set at 3840x2160 and have my desktop set at 1920x1080 I only see the top-left quadrant of the screen.  Does this port only run in borderless window?  Is there a command line parameter to force it to exclusive fullscreen.  At the moment I have to set my desktop resolution to 3840x2160, which I don't like to do as my screen is 27 inches, so text is near impossible to read.

You could try -fullscreen_window and see if it does anything.

I recall having this exact issue a long time ago but don't remember if I ever got it to work. What I do remember is that DSR can be quite finicky about your scaling settings so I recommend trying different scaling modes both in your GPU control panel and also your monitor.

I did try that but it did the same thing.  If I want to run Freespace 2 Open in 4K DSR, I have to set my desktop to 4K DSR first.  I think WXLauncher had an exclusive fullscreen option, but as I installed Freespace 2 Open with Knossos the game and Freespace 2 Open are in different folders, unlike the last time the java installer worked, when I was on Windows 7.

Another thing you can try is right clicking the FS2 open .exe and under Compatibility turn on Disable full screen optimizations. I don't have the game installed right now so this is just a guess.

Now that I think back, I probably ended up doing the same thing as you which is setting the desktop resolution to 4k before launching the game. It's a little inconvenient but at least it works.

just launch with the -window and the correct resolution

BUT, you will need to put the windows scaling to 100% in order to make it work properly. If you are running 4K as your windows resolution it is likely that you are using 150% scaling.


[0] Message Index

[#] Next page

Go to full version