Author Topic: Crash report  (Read 1097 times)

0 Members and 1 Guest are viewing this topic.

Hey,
I'm currently on Blood of the Innocents...whenever the Hades jumps in and destroys the Egyptos (at the end of the mission) the game crashes and the .exe stops working. The explosion from the Egyptos stops the game. Is there any way that I can avoid this issue from occurring? Thanks

 

Offline Cobra

  • 212
  • Snake on a Cain
    • Minecraft
    • Skype
    • Steam
    • Twitter
fs2_open.log? Run a debug build and post the one that appears in your main FreeSpace 2 data folder.
To consider the Earth as the only populated world in infinite space is as absurd as to assert that in an entire field of millet, only one grain will grow. - Metrodorus of Chios
I wept. Mysterious forces beyond my ken had reached into my beautiful mission and energized its pilots with inhuman bomb-firing abilities. I could only imagine the GTVA warriors giving a mighty KIAAIIIIIII shout as they worked their triggers, their biceps bulging with sinew after years of Ivan Drago-esque steroid therapy and weight training. - General Battuta

 
fs2_open.log? Run a debug build and post the one that appears in your main FreeSpace 2 data folder.

Thanks man for the message - I figured it out. I disabled the enhanced mediavps and played the mission with vanilla graphics. Now that I finished the mission, I can go ahead switch back on the mediavps - so problem solved.

 

Offline Cobra

  • 212
  • Snake on a Cain
    • Minecraft
    • Skype
    • Steam
    • Twitter
No, that's the error message. It's a warning, so it shouldn't directly cause the crash.

You select the debug version of whatever build you're using and run it until the crash. You may even get a different error on crash. Speaking of builds though, what build are you using?


[EDIT] The fact that the mediavps are causing an issue is something we want to find the cause of.
To consider the Earth as the only populated world in infinite space is as absurd as to assert that in an entire field of millet, only one grain will grow. - Metrodorus of Chios
I wept. Mysterious forces beyond my ken had reached into my beautiful mission and energized its pilots with inhuman bomb-firing abilities. I could only imagine the GTVA warriors giving a mighty KIAAIIIIIII shout as they worked their triggers, their biceps bulging with sinew after years of Ivan Drago-esque steroid therapy and weight training. - General Battuta

 
No, that's the error message. It's a warning, so it shouldn't directly cause the crash.

You select the debug version of whatever build you're using and run it until the crash. You may even get a different error on crash. Speaking of builds though, what build are you using?


[EDIT] The fact that the mediavps are causing an issue is something we want to find the cause of.

I'm running FS2 Open v3.7.2 and mediavps 3.6.12. I ran the debug for v3.7.2 and this is what I got from the debugger window:

Invalid subobj_num or model_num in subsystem 'enginesupleft' on ship type 'GTD Hades'.
Not linking into ship!

(This warning means that a subsystem was present in the table entry and not present in the model
it should probably be removed from the table or added to the model.)

ntdll.dll! NtWaitForSingleObject + 21 bytes
kernel32.dll! WaitForSingleObjectEx + 67 bytes
kernel32.dll! WaitForSingleObject + 18 bytes
fs2_open_3_7_2-DEBUG.exe! SCP_DumpStack + 354 bytes
fs2_open_3_7_2-DEBUG.exe! Warning + 421 bytes
fs2_open_3_7_2-DEBUG.exe! subsys_set + 314 bytes
fs2_open_3_7_2-DEBUG.exe! ship_set + 604 bytes
fs2_open_3_7_2-DEBUG.exe! ship_create + 1457 bytes
fs2_open_3_7_2-DEBUG.exe! parse_create_object_sub + 77 bytes
fs2_open_3_7_2-DEBUG.exe! parse_create_object + 193 bytes
fs2_open_3_7_2-DEBUG.exe! mission_parse_maybe_create_parse_object + 390 bytes
fs2_open_3_7_2-DEBUG.exe! post_process_ships_wings + 111 bytes
fs2_open_3_7_2-DEBUG.exe! post_process_mission + 69 bytes
fs2_open_3_7_2-DEBUG.exe! parse_mission + 1520 bytes
fs2_open_3_7_2-DEBUG.exe! parse_main + 444 bytes
fs2_open_3_7_2-DEBUG.exe! mission_load + 228 bytes
fs2_open_3_7_2-DEBUG.exe! game_start_mission + 192 bytes
fs2_open_3_7_2-DEBUG.exe! game_enter_state + 511 bytes
fs2_open_3_7_2-DEBUG.exe! gameseq_set_state + 310 bytes
fs2_open_3_7_2-DEBUG.exe! game_process_event + 242 bytes
fs2_open_3_7_2-DEBUG.exe! gameseq_process_events + 152 bytes
fs2_open_3_7_2-DEBUG.exe! game_main + 782 bytes
fs2_open_3_7_2-DEBUG.exe! WinMain + 330 bytes
fs2_open_3_7_2-DEBUG.exe! __tmainCRTStartup + 358 bytes
fs2_open_3_7_2-DEBUG.exe! WinMainCRTStartup + 15 bytes
kernel32.dll! BaseThreadInitThunk + 18 bytes
ntdll.dll! RtlInitializeExceptionChain + 99 bytes
ntdll.dll! RtlInitializeExceptionChain + 54 bytes

I found the fs2_open.log, do you want me to paste all its contents?

 

Offline Cobra

  • 212
  • Snake on a Cain
    • Minecraft
    • Skype
    • Steam
    • Twitter
I found the fs2_open.log, do you want me to paste all its contents?

You can just attach it by clicking on the reply button next to the thread options below this post.

Also, you're using outdated MediaVPs.

http://www.hard-light.net/forums/index.php?topic=86475.0
To consider the Earth as the only populated world in infinite space is as absurd as to assert that in an entire field of millet, only one grain will grow. - Metrodorus of Chios
I wept. Mysterious forces beyond my ken had reached into my beautiful mission and energized its pilots with inhuman bomb-firing abilities. I could only imagine the GTVA warriors giving a mighty KIAAIIIIIII shout as they worked their triggers, their biceps bulging with sinew after years of Ivan Drago-esque steroid therapy and weight training. - General Battuta

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
It's also possible that the mod may not be installed correctly, or the mod overrides are not working.  The fs2_open.log will shed light on this.

 
Here you go.

[attachment DELETED!! by Strong Bad]

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Yeah, this isn't set up correctly.  Did you use the FSO Installer or did you do it manually?  Using the installer is recommended to avoid configuration errors.

Move these files into C:\GOG Games\Freespace 2\fsport:
Code: [Select]
Found root pack 'C:\GOG Games\Freespace 2\mediavps_3612\stu_fs1.vp' with a checksum of 0xa75a86ce
Found root pack 'C:\GOG Games\Freespace 2\fsport-missions.vp' with a checksum of 0x3b0c0e71
Found root pack 'C:\GOG Games\Freespace 2\fsport3_5.vp' with a checksum of 0xe3af711d
Found root pack 'C:\GOG Games\Freespace 2\sparky_hi_fs1.vp' with a checksum of 0xdf2dbf98
Found root pack 'C:\GOG Games\Freespace 2\stu_fs1.vp' with a checksum of 0xa75a86ce
Found root pack 'C:\GOG Games\Freespace 2\tango_hi1_fs1.vp' with a checksum of 0x110c971c
Found root pack 'C:\GOG Games\Freespace 2\tango_hi2_fs1.vp' with a checksum of 0xe3c8d13b
Found root pack 'C:\GOG Games\Freespace 2\tango_hi3_fs1.vp' with a checksum of 0x5ddd28f7
Found root pack 'C:\GOG Games\Freespace 2\tango_hi4_fs1.vp' with a checksum of 0x52d85c46
Found root pack 'C:\GOG Games\Freespace 2\tango_hi5_fs1.vp' with a checksum of 0xf615f6be

Move these files into C:\GOG Games\Freespace 2\fsport-str:
Code: [Select]
Found root pack 'C:\GOG Games\Freespace 2\fsport-str-voice.vp' with a checksum of 0xc986703b
Found root pack 'C:\GOG Games\Freespace 2\fsport-str.vp' with a checksum of 0xc798b80a

Move these files into C:\GOG Games\Freespace 2\fsport-mediavps:
Code: [Select]
Found root pack 'C:\GOG Games\Freespace 2\mv_fsport-bastion-a.vp' with a checksum of 0x7c522f8e
Found root pack 'C:\GOG Games\Freespace 2\mv_fsport-bastion-b.vp' with a checksum of 0x30502d7b
Found root pack 'C:\GOG Games\Freespace 2\mv_fsport-galatea-a.vp' with a checksum of 0x1571779f
Found root pack 'C:\GOG Games\Freespace 2\mv_fsport-galatea-b.vp' with a checksum of 0x56c8ac09
Found root pack 'C:\GOG Games\Freespace 2\mv_fsport-krios.vp' with a checksum of 0x6ce9f17e
Found root pack 'C:\GOG Games\Freespace 2\mv_fsport-soyakaze.vp' with a checksum of 0x08533bd6

And make sure each mod folder has the correct mod.ini file in it.

 
Yeah, this isn't set up correctly.  Did you use the FSO Installer or did you do it manually?  Using the installer is recommended to avoid configuration errors.

Move these files into C:\GOG Games\Freespace 2\fsport:
Code: [Select]
Found root pack 'C:\GOG Games\Freespace 2\mediavps_3612\stu_fs1.vp' with a checksum of 0xa75a86ce
Found root pack 'C:\GOG Games\Freespace 2\fsport-missions.vp' with a checksum of 0x3b0c0e71
Found root pack 'C:\GOG Games\Freespace 2\fsport3_5.vp' with a checksum of 0xe3af711d
Found root pack 'C:\GOG Games\Freespace 2\sparky_hi_fs1.vp' with a checksum of 0xdf2dbf98
Found root pack 'C:\GOG Games\Freespace 2\stu_fs1.vp' with a checksum of 0xa75a86ce
Found root pack 'C:\GOG Games\Freespace 2\tango_hi1_fs1.vp' with a checksum of 0x110c971c
Found root pack 'C:\GOG Games\Freespace 2\tango_hi2_fs1.vp' with a checksum of 0xe3c8d13b
Found root pack 'C:\GOG Games\Freespace 2\tango_hi3_fs1.vp' with a checksum of 0x5ddd28f7
Found root pack 'C:\GOG Games\Freespace 2\tango_hi4_fs1.vp' with a checksum of 0x52d85c46
Found root pack 'C:\GOG Games\Freespace 2\tango_hi5_fs1.vp' with a checksum of 0xf615f6be

Move these files into C:\GOG Games\Freespace 2\fsport-str:
Code: [Select]
Found root pack 'C:\GOG Games\Freespace 2\fsport-str-voice.vp' with a checksum of 0xc986703b
Found root pack 'C:\GOG Games\Freespace 2\fsport-str.vp' with a checksum of 0xc798b80a

Move these files into C:\GOG Games\Freespace 2\fsport-mediavps:
Code: [Select]
Found root pack 'C:\GOG Games\Freespace 2\mv_fsport-bastion-a.vp' with a checksum of 0x7c522f8e
Found root pack 'C:\GOG Games\Freespace 2\mv_fsport-bastion-b.vp' with a checksum of 0x30502d7b
Found root pack 'C:\GOG Games\Freespace 2\mv_fsport-galatea-a.vp' with a checksum of 0x1571779f
Found root pack 'C:\GOG Games\Freespace 2\mv_fsport-galatea-b.vp' with a checksum of 0x56c8ac09
Found root pack 'C:\GOG Games\Freespace 2\mv_fsport-krios.vp' with a checksum of 0x6ce9f17e
Found root pack 'C:\GOG Games\Freespace 2\mv_fsport-soyakaze.vp' with a checksum of 0x08533bd6

And make sure each mod folder has the correct mod.ini file in it.

Gotcha, I attempted to manually install it...so I'll try and move the files. If that causes issue, I'll use the alternate method you mentioned, and use the installer. Thanks for the help, I'll be sure to post here if there are any other issues.

 

Offline Goober5000

  • HLP Loremaster
  • Administrator
  • 214
    • Goober5000 Productions
Sounds good.  You might want to post another fs2_open.log when you try again, just so we can double check.