Recent Posts

Pages: [1] 2 3 4 5 6 7 8 ... 10 Next >
1
Blue Planet / Re: RELEASE — Blue Planet
« Last post by Steel Prophet on September 25, 2021, 11:13:30 am »
The inspirations drawn from Babylon 5 and Assassin's Creed are subtle enough to not ruin it, yet obvious enough for a fan to notice at first glance. Being a huge fan of both series this is simply amazing for me :-)
I just love it. This is one of the best games I ever played. Not mods. Not campaigns. Games! Just started Act 3. The lack of voice acting makes following the story in-mission a bit more difficult but what the heck. This is one of the games/stories I with would never end...
2
Wing Commander Saga / Re: Knossos installer?
« Last post by Admiral Nelson on September 25, 2021, 07:42:35 am »
Give this copy of Alcor 2 a try. 

I do recall that WCS had that Excalibur bug but I hadn't encountered it in this version.  I will look into it.

[EDIT] Mission 36 has in it the sexps to allow the Reaper and Tachyon weapons, so if you skip this mission the Excalibur will have no weapons.
3
Wing Commander Saga / Re: Knossos installer?
« Last post by CT27 on September 24, 2021, 07:28:10 pm »
I can't reproduce either of those issues - this video shows the autoland and cutscenes both working using just 21.2:


I did just push version0.95 to knossos, which contains a fix for the Alcor 2 issues others have mentioned above.  Try downloading the new version and see if it clears up any issues you may have had.

I downloaded the .9.5 version (since I don't use Knossos yet what I did was just downloaded the new files from the Knossos page and put them in my /Freespace2/Wing Commander Saga folder to replace the older version).  I tried it out and I have good news and bad news:


Good news:  I tried Vega 5 through the techroom and the game autolanded me this time and I saw the Vega bombardment and got the debriefing afterwards.  I wasn't even able to do that on the techroom before so it looks like this particular issue is fixed for me.  Thank you.


Bad news:  I've ran into a couple other technical issues now:
-Alcor 2 (the mission you said the new version was designed to fix) won't load now.  When I try to start this mission I click on the part of the screen where you're suppsed to click to start/continue a campaign...it goes to the loading screen with the Confed logo on it and the loading bar at the bottom.  The loading bar progresses a little bit but then I always get a popup that says "Attempt to load mission failed."  Other missions seemed to load fine but Alcor 2 wouldn't.  I tried this on campaign mode on my Alcor 2 save file and it wouldn't load...Alcor 2 wouldn't load in the techroom either.  Same thing on a Hyperion 2 save file I tried...Alcor 2 wouldn't load.  In other words I can't even get into the mission to do the 5x death skip trick.  I tried this on multiple builds including 21.2...it looks like Alcor 2 is inaccessible now unfortunately.  Can this be fixed?

I don't know if this is relevant to help out but I figured I might as well give you more info: I noticed under /data/missions that mission 36 aka Alcor 2 has two files in this new version.  It has M-36-BG-hermes.fs2 like all the other missions do (they just have their respective number in place of 36) but it also has M-36-BG-hermes.bak (it's the only "bak" file in there).

-The Excalibur missions (starting with Hyperion 1) don't have any guns for the Excalibur.  After Hyperion 1's briefing, I went to the weapon select screen and missiles were there to pick from.  But it showed my Excalibur as having zero guns (primaries) loaded.  There were also zero guns shown on the weapon select (left) side of the screen.  Usually on the weapon select screen you're able to see the guns you have (even if WCS doesn't let you change guns).  When I started the mission there was nothing at all in the lower right part of the screen where your primaries are shown and you can select which gun/guns to fire.  It only showed missiles.  So now Excaliburs don't have guns.
I was going to say this earlier but I didn't get to it before the recent update, but to be fair this wasn't just an issue with this new version.  .9.4 did not have guns for Excaliburs either.  I tried the 5x death skip to see if this was an issue in more than one mission but campaign Hyperion 2 had this problem as well.
Now, Excaliburs had guns in techroom mission playthroughs, but not when playing through the missions as a campaign.  Can this be fixed too please (I remember no Excalibur guns was a problem in the original standalone WCS release as well)?
4
FreeSpace Discussion / Re: FreeSpace Meme Thread: GO
« Last post by DefCynodont119 on September 24, 2021, 01:19:24 pm »
Into the Inferno:
5
General Discussion / Re: Stuff we saw on youtube! (redux!)
« Last post by -Joshua- on September 24, 2021, 04:59:00 am »

Kurzgesagt at it again
6
FS2 Open Tools / Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
« Last post by jg18 on September 23, 2021, 11:52:20 pm »
Hi there!

Your best bet is to ask for help on the #knossos channel on the HLP Discord.

Note that we can't guarantee that a specialized Linux distro, such as Pop!_OS, will be able to run Knossos/the game well or even at all, even if it's based on a general-purpose distro (Ubuntu in this case).

As for updating the Knossos build instructions, RL is unfortunately too hectic right now for me to set up an Ubuntu VM (on Windows) and produce reliable setup instructions. Perhaps I can do that sometime later this year, or maybe someone else can do it sooner.

Hope that helps.
7
FreeSpace & FreeSpace Open Support / Re: Can't log in Knossos Nebula
« Last post by starbug on September 23, 2021, 04:19:02 pm »
Its cool i managed to get it sorted, Ngld got me sorted :)
8
FreeSpace Discussion / Re: FreeSpace Meme Thread: GO
« Last post by DefCynodont119 on September 23, 2021, 01:58:54 pm »
. . .
9
FS2 Open Tools / Ubuntu Desktop Shortcut To Launch Knossos (Supports HiDPi too)
« Last post by MachManX on September 23, 2021, 12:55:27 pm »
This is a quick guide on how to setup a desktop shortcut on the Ubuntu desktop to launch Knossos rather than having to type in the command in terminal.  I'm using 20.04 but this will probably work on older versions as well.  This can be modified to suit your own distro and/or location of Knossos source files.

First create two files using a text editor:
- x.desktop
- y.py

where x and y are names of your choosing.  It will be safer just to use a continuous word, unless you're a linux expert and can deal with those spaced names.  For example, I named my files 'Knossos.desktop' and 'RunKnossos.py'.  I will be referring to those files as x.desktop and y.py throughout this guide.  So please make the appropriate name changes for the rest of the guide according to what names you have chosen for those files.   Move the x.desktop file to the Desktop folder under the user (home/user/Desktop).  Move the y.py file to the knossos parent folder.

Open x.desktop in a text editor and enter the following data (copy and paste if you like):
Code: [Select]
[Desktop Entry]
Version=1.0
Name=Knossos   
Comment=Runs Knossos
Exec=/path/to/y.py
Icon=/path/to/icon.png
Path=/path/to/parent folder
Terminal=false
Type=Application
Categories=Application;

Name is the text that will show up under the icon after you allow Launching, which I will show you how later.  Exec is the path to the y.py file you created. Icon is the path to the icon (I chose the hlp.png file under the data folder, which is under the knossos parent folder).  Path is the path to the knossos parent folder.  The rest of the options you can leave as is.  Don't forget to save your changes  ;)

Let's edit the y.py file by opening it in a text editor.  Just paste ONE of the following commands inside of it:
Code: [Select]
python3 -m knossos
QT_AUTO_SCREEN_SCALE_FACTOR=1 python3 -m knossos

Use the first command if you have no scaling issues with the GUI.  Use the 2nd command if you have a HiDPi screen, like myself, and/or have scaling issues.  Save your changes  :)

Now for the final step, which may differ amongst distros.  So I cannot say if this works for them; I have only tested this on Ubuntu 20.04.  Go to your physical desktop (physical, AR?, projected particle display?  :confused:), right-click the x.desktop file you just created and click on 'Allow Launching'.  This should make the text below the icon change from x.desktop to the name you chose in the file itself.  It should also change the icon to the path you chose in said file.  If you don't see an icon or something weird, then recheck the path.

Now go ahead and test it by double-clicking on the icon.  It should load Knossos without relying on the terminal.  :yes:
10
FS2 Open Tools / Re: PUBLIC BETA: Knossos 0.14.3 (combined launcher/installer)
« Last post by Overhaze on September 23, 2021, 11:21:12 am »
Hello.

I'm fairly new to linux (I'm on pop os) and I am trying to set up Knossos with little success. I tried following the official instructions but they are apparently outdated? Could someone please give me a clear instructions on how to install it?

Thanks.
Pages: [1] 2 3 4 5 6 7 8 ... 10 Next >