Author Topic: Is it normal for the menus in 2014 MediaVPs to not be stretched to res?  (Read 850 times)

0 Members and 1 Guest are viewing this topic.

Is it normal for the menus in 2014 MediaVPs to not be stretched to res?
I appreciate the newer, more proportional HUD in-game but I've been playing with the Tech Room, briefings and main menu stretched to widescreen for so long with the old mediavps and 3.7.0 that the new shiny 3.7.2 build and 2014 mediavps just look weird to me until the actual mission starts. I notice that the cutscenes fit my resolution so that's nice.

Also, this is my first real post after a lifetime of lurking and downloading your installers so I'd like to take this opportunity to thank everyone who had a part in this project for keeping the game I loved from an early age relevant even today. You guys are heroes!

 

Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Re: Is it normal for the menus in 2014 MediaVPs to not be stretched to res?
Yes, it's normal. If you want to restore the old stretching behavior, you can add -stretch_menu to your command-line parameters.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME
<MageKing17> THE REASON IS PEOPLE ARE STUPID
<MageKing17> ESPECIALLY ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
(...)
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.