Author Topic: Error!  (Read 1500 times)

0 Members and 1 Guest are viewing this topic.


I am experiencing an error upon loading the final mission of WiH 2.  After clicking "Play" from the command hall, it proceeds to load the mission, and then produces the errors mentioned below. Also seems to be an error when rendering the durga bomber... i can only see the cockpit flying around  :confused:

Please help!

Attempt to page in new subsystems subsystems failed because mission file contains more than 4000 subsystems
ntdll.dll! ZwWaitForSingleObject + 12 bytes
KERNELBASE.dll! WaitForSingleObject + 18 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! SCP_DumpStack + 354 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! Error + 284 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! ship_page_in + 1520 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! level_page_in + 48 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! freespace_mission_load_stuff + 206 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! game_post_level_init + 177 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! game_start_mission + 377 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! game_enter_state + 520 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! gameseq_set_state + 303 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! game_process_event + 242 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! gameseq_process_events + 149 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! game_main + 787 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! WinMain + 328 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! invoke_main + 30 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! __scrt_common_main_seh + 346 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! __scrt_common_main + 13 bytes
fs2_open_3_7_4_SSE2-DEBUG.exe! WinMainCRTStartup + 8 bytes
KERNEL32.DLL! BaseThreadInitThunk + 36 bytes
ntdll.dll! RtlSubscribeWnfStateChangeNotification + 1081 bytes
ntdll.dll! RtlSubscribeWnfStateChangeNotification + 1028 bytes

[attachment stolen by Russian hackers]

Blue Planet Complete was never 3.7.4 compatible. You'll need a newer 3.7.5 nightly which has a higher subsystem limit(or no limit at all, not completely sure on this one). The "War in Heaven" cutscene breaks the old subsystem limit because it has a lot of big ships and a lot of Kents, each one of which has like 30 subsystems used for various animations.
[19:31] <MatthTheGeek> you all high up on your mointain looking down at everyone who doesn't beam everything on insane blindfolded

Thanks for your reply! sadly my problems are not over yet...

I tried with the latest nightly build and the last mission's cutscene plays till i get the following error message:


Error: Illegal subsystem type.

File: ship.cpp
Line: 12910

Someone knows what is this about?
thanks again


Offline AdmiralRalwood

  • 211
  • The Cthulhu programmer himself!
    • Skype
    • Steam
    • Twitter
Blue Planet Complete was never 3.7.4 compatible.
Well, that's patently false; the release thread still links to 3.7.4 Final.
Ph'nglui mglw'nafh Codethulhu GitHub wgah'nagl fhtagn.

schrödinbug (noun) - a bug that manifests itself in running software after a programmer notices that the code should never have worked in the first place.

When you gaze long into BMPMAN, BMPMAN also gazes into you.

"I am one of the best FREDders on Earth" -General Battuta

<Aesaar> literary criticism is vladimir putin

<MageKing17> "There's probably a reason the code is the way it is" is a very dangerous line of thought. :P
<MageKing17> Because the "reason" often turns out to be "nobody noticed it was wrong".
(the very next day)
<MageKing17> this ****ing code did it to me again
<MageKing17> "That doesn't really make sense to me, but I'll assume it was being done for a reason."
<MageKing17> **** ME

<MageKing17> God damn, I do not understand how this is breaking.
<MageKing17> Everything points to "this should work fine", and yet it's clearly not working.
<MjnMixael> 2 hours later... "God damn, how did this ever work at all?!"
<MageKing17> so
<MageKing17> more than two hours
<MageKing17> but once again we have reached the inevitable conclusion
<MageKing17> How did this code ever work in the first place!?

<@The_E> Welcome to OpenGL, where standards compliance is optional, and error reporting inconsistent

<MageKing17> It was all working perfectly until I actually tried it on an actual mission.

<IronWorks> I am useful for FSO stuff again. This is a red-letter day!
* z64555 erases "Thursday" and rewrites it in red ink

<MageKing17> TIL the entire homing code is held up by shoestrings and duct tape, basically.

There was an update just after 3.7.4 that broke "War In Heaven" with a model swap and needed the subsystem limit extended. It was released mid last year, very shortly after 3.7.4 final. I remember this specific bug and I'm pretty sure the solution was to change the code rather than change the mission.

I mean obviously BPC was targetting 3.7.4 at one point since it was released before 3.7.4 FINAL, I just meant that the current version that people are downloading was never 3.7.4 compatible.

The release thread really shouldn't be linking to 3.7.4 final though, unless I'm wrong and the subsystem limit was extended in 3.7.4 final for BP. I can't exactly remember if that bug was found in testing(or if we even did testing for that patch) or after release.

Osternesse I'm afraid I can't help you much with that problem right now as I don't have the release version of BPC installed and that bug doesn't happen on the current SVN version.
« Last Edit: April 01, 2017, 06:02:46 pm by FrikgFeek »
[19:31] <MatthTheGeek> you all high up on your mointain looking down at everyone who doesn't beam everything on insane blindfolded

Code: [Select]
Found root pack 'C:\Games\Freespace 2\bpcomplete\adv-bp2-cockpits.vp'Delete this.

Code: [Select]
Found root pack 'C:\Games\Freespace 2\bpcomplete\adv-bp2-cockpits.vp'Delete this.

It worked!

Thank you all, looking forward to WIH 3.